I recently downloaded Ubuntu from the main website with the hopes of dual booting it with Windows. While the operating system works, it says that I need to install a driver for my graphics card. When I type in my password the installation fails. I figure it is because I need Internet access. I tried to install my WiFi USB adapter with the installation disc but Ubuntu doesn't seem to run the setup when I click the exe.

What are my available solutions as I would really like to use Ubuntu from my programming and Windows for my gaming needs?

The name as read on the box is: Linksys AE1200 Wireless- N USB Adapter

The description reads as such:

ID  13b1:0039 Linksys (a comma messed up format)
ID  046d:0a0b Logitech, Inc. ClearChat Pro USB (headset)
  • We'll need much more information about your wireless adapter before we can give you instructions. Make sure your USB WLAN adapter is connected, then in the command line type lsusb, and edit your question including what you see in the terminal after using that command (that way we'll have the vendor ID and product ID of your adapter). Also helps to include the model name of your adapter. Jan 31, 2012 at 5:24
  • 2
    Just a heads up, exe are for windows, and usually we won't be installing windows drivers in Ubuntu, unless you have to use the windows driver to get your wireless internet enabled, but that's only for cards where you can't get a good Linux driver, and it's done using an interface called ndiswrapper. You probably don't need to worry about that, we'll give you detailed instructions once we know more about your wireless adapter. Jan 31, 2012 at 5:27
  • I edited my original post with the information you requested. I also through in my usb headset as I anticipate a similar problem may arise. Jan 31, 2012 at 5:39
  • No, this is not your Wireless-Adapter, it is your Headset ;-) Please look again at the list of lsusb!
    – Michael K
    Jan 31, 2012 at 6:49
  • I re-edited my post. There was a comma that ommited the usb adapter from being highlighted but i got the formatting right now. Jan 31, 2012 at 7:32

5 Answers 5


I just bought the Linksys AE1200 USB Wireless adapter and it works fine 19-Oct-2012.

My lsusb results:

Bus 001 Device 005: ID 13b1:0039 Linksys AE1200 802.11bgn Wireless Adapter [Broadcom BCM43235]

For some reason, the Win XP driver on the installation CD would not work. None of the other broadcom chipset drivers that I attempted worked for me either.

The solution

So, a search of here and Ubuntuforums yielded this link: http://www.wikidevi.com/wiki/Linksys_AE1200 and provided this repaired version of the xp driver: http://wikidevi.com/files/Drivers/Broadcom/bcmwl_4323x.zip.

  1. Download the bcmwl_4323x.zip and extract (for my example to follow, my downloads directory)
  2. I opened a Terminal window:
    • cd /Downloads/bcmwl_4323x/xp/
    • :~/Downloads/bcmwl_4323x/xp$ sudo ndiswrapper -i bcmwlhigh5.inf
    • sudo modprobe ndiswrapper
  3. ndiswrapper -l yielded:

bcmwlhigh5 : driver installed
device (13B1:0039) present

  • Exit Terminal window, unplug LAN cable, System Restart.
  • (Optional) If the USB Wireless card does not work after reboot, you may need to add ndiswrapper to your /etc/modules so that it loads ndiswrapper at startup.
    • You should be able to test if this is needed if upon boot, the LED on your wireless card is not lit. You run in terminal sudo modprobe -r ndiswrapper | sudo modprobe ndiswrapper and then the LED turns on.

I'm running Ubuntu 12.04 and after searching these forums unsuccessfully, I have installed the driver for my AE1200 and it is working correctly.

Here is how I did it:

First, install ndiswrapper and be sure to install ndiswrapper-common and ndiswrapper-dkms as well.

Then, download the XP driver for the device: http://support.linksys.com/en-us/support/adapters/AE1200

Extract the zip and cd to the folder (probably xp). If you attempt to install the driver with ndiswrapper at this point, you will receive the "couldn't find section "Linksys_AE1200.files.NTamd64"" error. To resolve this, edit the bcmwlhigh5.inf file. Find the section that looks like this:


Underneath it, add this:



Save and close. Then, if you've already attempted to install the driver with ndiswrapper you'll need to remove it, run:

sudo ndiswrapper -e bcmwlhigh5

Then do the install again:

sudo ndiswrapper -i bcmwlhigh5.inf

Verify with:

sudo ndiswrapper -l

Now plug in the USB device and the blue light should come on.

I could be wrong, but I think this means whoever wrote these .inf files forgot to include those lines, which I find funny.

**Update for 12.10- If you install ndiswrapper-dkms it will fail and you will start getting system errors. Follow the solution here to resolve: https://bugs.launchpad.net/ubuntu/+source/ndiswrapper/+bug/1023645/comments/3

As a side note the source code he refers to is everything in the "driver" directory of the extracted tar.gz

In addition, you will also want to run:

sudo dkms remove ndiswrapper/1.57 --all


sudo dkms uninstall ndiswrapper/1.57
  • That's probably b/c XP 64 notoriously sucks.
    – MDMoore313
    Jan 25, 2014 at 12:51
  • +1 for the info on the missing section. Incredibly useful info, and amusing that linksys/cisco left that section out of the inf.
    – Garrett
    May 16, 2015 at 16:12

It doesn't look like Cisco cares about supporting Linux on that specific device: http://homecommunity.cisco.com/t5/Wireless-Adapters/AE1200-linux-Driver/m-p/410963?comm_cc=HSus&comm_lang=en#M30247

One user on that forum suggests the RALinkTech driver "RT3572USB" will function for your device, but suggests it will be an annoyance. I cannot confirm either statement.

ndiswrapper (a tool that provides enough Windows APIs to let Windows drivers  run under Linux) doesn't mention your device on their supported devices list.

In general, it is best to buy devices after  finding out their level of support. Some companies (Intel) put extra effort into making sure their hardware works under Linux (sometimes before Windows drivers are released; the members of their development teams I've talked with have been excited to support Linux). Some companies just don't care. Finding out for sure which specific devices are supported can be difficult; one simple approach is to look in /lib/modules/$(uname -r)/kernel/drivers/net/ for drivers. All the USB drivers are in the usb/ subdirectory. On my system:

$ for f in * ; do echo -ne "$f \t" ; modinfo $f | grep ^description ; done
asix.ko     description:    ASIX AX8817X based USB 2.0 Ethernet Devices
catc.ko     description:    CATC EL1210A NetMate USB Ethernet driver
cdc_eem.ko  description:    USB CDC EEM
cdc_ether.ko    description:    USB CDC Ethernet devices
cdc_ncm.ko  description:    USB CDC NCM host driver
cdc-phonet.ko   description:    USB CDC Phonet host interface
cdc_subset.ko   description:    Simple 'CDC Subset' USB networking links
cx82310_eth.ko  description:    Conexant CX82310-based ADSL router USB ethernet driver
dm9601.ko   description:    Davicom DM9601 USB 1.1 ethernet devices
gl620a.ko   description:    GL620-USB-A Host-to-Host Link cables
hso.ko  description:    USB High Speed Option driver
int51x1.ko  description:    Intellon usb powerline adapter
ipheth.ko   description:    Apple iPhone USB Ethernet driver
kaweth.ko   description:    KL5USB101 USB Ethernet driver
mcs7830.ko  description:    USB to network adapter MCS7830)
net1080.ko  description:    NetChip 1080 based USB Host-to-Host Links
pegasus.ko  description:    Pegasus/Pegasus II USB Ethernet driver
plusb.ko    description:    Prolific PL-2301/2302 USB Host to Host Link Driver
rndis_host.ko   description:    USB Host side RNDIS driver
rtl8150.ko  description:    rtl8150 based usb-ethernet driver
sierra_net.ko   description:    USB-to-WWAN Driver for Sierra Wireless modems
smsc75xx.ko     description:    SMSC75XX USB 2.0 Gigabit Ethernet Devices
smsc95xx.ko     description:    SMSC95XX USB 2.0 Ethernet Devices
usbnet.ko   description:    USB network driver framework
zaurus.ko   description:    Sharp Zaurus PDA, and compatible products

One thing that this cannot show is the driver quality  -- which varies from driver to driver and device to device. There's nothing to be done but web searches for specific devices you're interested in and seeing if people generally have success or complaints -- knowing that most people will report complaints but not that their equipment works fine.

  • Thank you for the response. I didn't anticipate dual booting until this weekend after taking my software engineering class for a few days. I realized using Ubuntu at home would be more beneficial for me. Feb 1, 2012 at 2:48

I followed the instructions from @Lukashka plus the recommendations here: Install drivers (in Spanish) and it works in Ubuntu 14.10:

They say that:

1. Install ndiswrapper:

sudo aptitude install ndiswrapper-common ndiswrapper-modules-1.9 ndiswrapper-utils-1.9

2. Install drivers:

Go to the linksys page and download the drivers for xp, then follow the instructions from @Lukashka specially if you are using Ubuntu 64bits

Then in the downloaded folder we use:

sudo ndiswrapper -i bcmwlhigh5.inf

Then we make sure that is installed:

sudo ndiswrapper -l

If there are errors, then we need to uninstall (sudo ndiswrapper -e bcmwlhigh5) and then fix the error (ex. download other file) and install again.

3. Load ndiswrapper module:

To the system:

sudo depmod -a
sudo modprobe ndiswrapper

When the WIFI USB interface is active:

sudo ndiswrapper -m

When Ubuntu start (add ndiswrapper as a new line):

sudo gedit /etc/modules

Then check your connections, it should list your device.

  • 1
    Extremely helpful step-by-step directions. Worked like a charm.
    – Garrett
    May 16, 2015 at 16:13

Just to let the community know that Linksys AE1200 is working flawlessly as in Windows.

But, I have to inform, that the modified XP driver, posted above on other comment, did not work on WPA2 routers, I got a workaround, and found the untouched WinXP driver, and got it up and running.

Did it the following way:

Downloaded XP driver UNMODIFIED from: http://drivers.softpedia.com/dyn-postdownload.php?p=159439&t=0&i=1

Installed ndisgtk and ndiswrapper-dkms packages via terminal ==> sudo apt-get install ndisgtk && sudo apt-get install ndiswrapper-dkms

Extracted the zipped WinXP driver downloaded from the link above.

Opened Windows Wireless Drivers from the menu, chose the bcmwlhigh5.inf file and installed the driver.

Rebooted just to be sure and finally got it working.

I'm running Lubuntu at the moment, but, I assume in that in Ubuntu and also in Ubuntu derivatives, there is no need to add ndiswrapper to /etc/modules as in Lubuntu ndiswrapper is loaded by default by the kernel.

Well hope this helps anyone, the easy and hassle-free way to set Cisco Linksys AE1200 USB wireless dongle to work, without too much terminal commands, for less experienced users!

EDIT: If you're in a situation that you cannot by any means reboot, right after the driver install, the blue LED should be immediatelly on, and you can start using the wi-fi dongle right away.

Not the answer you're looking for? Browse other questions tagged or ask your own question.