0

I just setup a local standalone landscape on premises server on Ubuntu Server 16.04.3 LTS named landscape. It is Landscape On Premises release 17.03. I added the IP Addr for landscape to my client's hosts file.

The first time I tried configuring a client I got the SSL error because of the self signed certificate, so I copied the certificate locally and added it to the client.conf file. Now when I run the configuration command

sudo landscape-config --computer-title "node-1" --account-name standalone  --url https://landscape/message-system --ping-url http://landscape/ping --ssl-public-key /etc/landscape/landscape-server-ca.crt

It gets all the way to the "request registration" step, and then after about a minute returns with the error:

We were unable to contact the server.
Your internet connection may be down. The landscape client will continue to try and contact the server periodically.

I can ping landscape by name, and wget against those URLs pulls down a response. I've restarted both the client and the server. I've tried this from two different clients on the local network, and both give the same error. The pending computers link on the Landscape server shows no pending computers.

I looked in the broker.log and found the following error:

2018-01-28 22:36:10,281 INFO     [MainThread] Starting urgent message exchange with https://landscape/message-system.  
2018-01-28 22:36:10,304 ERROR    [PoolThread-twisted.internet.reactor-0] Error contacting the server at https://landscape/message-system.  
Traceback (most recent call last):  
  File "/usr/lib/python2.7/dist-packages/landscape/broker/transport.py", line 71, in exchange message_api)  
  File "/usr/lib/python2.7/dist-packages/landscape/broker/transport.py", line 45, in _curl headers=headers, cainfo=self._pubkey, curl=curl))  
  File "/usr/lib/python2.7/dist-packages/landscape/lib/fetch.py", line 113, in fetch
raise PyCurlError(e.args[0], e.args[1])  
PyCurlError: Error 77:   
2018-01-28 22:36:10,305 INFO     [MainThread] Message exchange failed.

Am I missing something in my landscape configuration, or is it something wrong with my network settings? I'd like to get Landscape configured. Thanks!

0

I had copied the servers /etc/ssl/certs/landscape_server_ca.crt locally without renaming it. The solution was to rename it to server.pem

Here is the solution in script form

sudo scp cluster@landscape:/etc/ssl/certs/landscape_server_ca.crt /etc/landscape/server.pem  
sudo echo "ssl_public_key = /etc/landscape/server.pem" >> /etc/landscape/client.conf  
sudo landscape-config --computer-title "node-0" --account-name standalone  --url https://landscape/message-system --ping-url http://landscape/ping --ssl-public-key /etc/landscape/server.pem  

And that did the trick.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.