1

I'm running Ubuntu 17.10 in a VM using vmware workstation, and trying to get the guest OS to see the shared directory. I have installed vmware tools using the VM menu.

Afterwards, vmware-hgfsclient returns the name of the shared directory from Windows, but it is not mounted in /mnt/hgfs (although that directory does exist.

I followed the directions here and ran vmware-config-tools.pl

It goes smoothly until it wants to configure hgfs, and asks for the path to the gcc binary. According to which gcc it's installed in /usr/bin/gcc. However, when I specify that path I get an error saying that the path is invalid, and I am unable to get any further.

I've done a lot of searching on this error and have tried a bunch of different things (at this point I've lost track of everything I've tried), and so am hoping somebody can help me out.

Thanks in advance!

Error message:

Searching for GCC...
The path "" is not valid path to the gcc binary.
Would you like to change it? [yes] 

What is the location of the gcc program on your machine? /usr/bin/gcc

The path "/usr/bin/gcc" is not valid path to the gcc binary.
Would you like to change it? [yes]
  • 1
    I've upgraded from 17.04 to 17.10 and am having the same problem. – Jasonbartfast Jan 30 '18 at 0:42
  • Can you please include the exact error message? – Seth Jan 31 '18 at 15:23
  • updated original post – Jasonbartfast Jan 31 '18 at 20:50

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.