0

I'm pretty new to both Linux and Docker. I'm trying to install Docker CE on Ubuntu 16.04 Desktop (Live USB) and I followed all the steps as the documentation stated. But I always get stuck at the last step with this error:

   Setting up docker-ce (18.01.0~ce-0~ubuntu) ...
Job for docker.service failed because the control process exited with error code. See "systemctl status docker.service" and "journalctl -xe" for details.
invoke-rc.d: initscript docker, action "start" failed.
● docker.service - Docker Application Container Engine
   Loaded: loaded (/lib/systemd/system/docker.service; enabled; vendor preset: enabled)
   Active: activating (auto-restart) (Result: exit-code) since Mon 2018-01-29 08:35:46 MMT; 4ms ago
     Docs: https://docs.docker.com
  Process: 3320 ExecStart=/usr/bin/dockerd -H fd:// (code=exited, status=1/FAILURE)
 Main PID: 3320 (code=exited, status=1/FAILURE)

Jan 29 08:35:46 ubuntu systemd[1]: Failed to start Docker Application Conta...e.
Jan 29 08:35:46 ubuntu systemd[1]: docker.service: Unit entered failed state.
Jan 29 08:35:46 ubuntu systemd[1]: docker.service: Failed with result 'exit...'.
Hint: Some lines were ellipsized, use -l to show in full.
dpkg: error processing package docker-ce (--configure):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 docker-ce
E: Sub-process /usr/bin/dpkg returned an error code (1)

I tried to find the solution on the internet but with no success. Please help.


Edit: I tried to install Ubuntu again, this time without persistent file. Docker installed successfully and ran smoothly. I tried again with persistent file and the same error occurred again. So is the problem with the persistent file? I use multibootusb to install the iso file.

  • Seems answered at stackoverflow.com/questions/30248794/… – user535733 Jan 29 '18 at 3:16
  • I can't run $ sudo docker version. My problem is that docker not getting installed. It is returning the same error. I don't know why. – user8703143 Jan 29 '18 at 10:50
  • The Live environment is primarily designed to test hardware compatibility. It's user environment is not identical to an installed system. Docker is far outside it's tested envelope. Seeing the complete error lines instead of the '...' abbreviations might help - you cut off the important parts. – user535733 Jan 29 '18 at 13:28

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.