3

I've searched around about my issue and I can't seem to find anything similar to my case. Today I installed Ubuntu on my laptop and after the installation I was configuring the input languages in the system settings. My active languages were Greek and English(UK). I wanted to delete enUK in order to replace it with enUS. And here is where things got messed up. When I deleted enUK (before adding English US), my laptop froze and restarted by itself. When it booted up and asked for my password, the only language available was Greek, but my password is in English.

I tried to boot in recovery mode and change my password through the root but when I get in the command line of the root, the only languge there is Greek again. Same goes for the kernel. The only place I can type in english is in grub when I configure the boot code of each boot option. Is there anything I can do?

Maybe I could do something from the bootable usb with the Ubuntu installation? Or create some sort of script in my usb which will do what I want? Any help would be very much appreciated. Thanks a lot!

PS: I know that my last option is to re-install Ubuntu from scratch but I'm trying to avoid it.

1

You can force the keyboard mapping using a boot parameter.

Just add this to your temporary boot parameters:

setkmap=de

Now you can make all the changes and reboot.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.