3

I have installed AMDGPU Pro version 17.10. A few days ago, I had tabs crashing with Firefox. about:crashes told me there was an issue with amdgpu-pro.

I then had the good idea of updating AMDGPU Pro. Depending on which page you land on, you either get version 16.40, 17.40, or 17.50 advised, the latter being the one advised when going through support.amd.com.

All of them lead me to not being able to log in correctly. I first get the same error I had before (see lvmetad not active ubuntu--vg-root clean NO BOOT due to AMDGPU-PRO). After a few seconds, a window appears with an error message mentioning that my graphic card is not functioning, and I cannot access the graphical desktop. I can however check the xorg logs, and this is what I find:

[    38.931] (EE) module ABI major version (10) doesn't match the server's version (9)
[    38.931] (EE) Failed to load module "glx" (module requirement mismatch, 0)
[    38.931] (EE) module ABI major version (23) doesn't match the server's version (20)
[    38.931] (EE) Failed to load module "amdgpu" (module requirement mismatch, 0)
[    38.932] (EE) module ABI major version (23) doesn't match the server's version (20)
[    38.932] (EE) Failed to load module "amdgpu" (module requirement mismatch, 0)

Answer to this question: Can't login after installing AMDGPU-PRO 16.60 advises to do

./amdgpu-pro-install --px

I can't do it as I have the following error:

E: Impossible de trouver le paquet xserver-xorg-video-modesetting-amdgpu-pro

(or in English: unable to find xserver-xorg-video-modesetting-amdgpu-pro package)

This package is nowhere to be found.

I wanted to downgrade back to 17.10, but I am unable to find a link to the .tar on the AMD website.

I can however access a terminal with CTRL+Alt+F1. So meanwhile, I have uninstalled amdgpu-pro completely with amdgpu-pro-uninstall . I can reuse Ubuntu, albeit without all the perks of the drivers (like sound through HDMI).

Note that I am using 16.04 and I regularly update everything. I believe the origin of the problem is a new kernel. Mine is 4.4.0-112-generic.

Xorg -version prompts:

X.Org X Server 1.18.4
Release Date: 2016-07-19
X Protocol Version 11, Revision 0
Build Operating System: Linux 4.4.0-97-generic x86_64 Ubuntu
Current Operating System: Linux hyamanieu-desktop 4.4.0-112-generic #135-Ubuntu SMP Fri Jan 19 11:48:36 UTC 2018 x86_64
Kernel command line: BOOT_IMAGE=/vmlinuz-4.4.0-112-generic root=/dev/mapper/ubuntu--vg-root ro quiet splash vt.handoff=7
Build Date: 13 October 2017  01:57:05PM
xorg-server 2:1.18.4-0ubuntu0.7 (For technical support please see http://www.ubuntu.com/support) 
Current version of pixman: 0.33.6
    Before reporting problems, check http://wiki.x.org
    to make sure that you have the latest version.
  • Bug reports are off-topic. – user68186 Jan 28 '18 at 14:30
  • 1
    @user68186 Is this really a bug or a mix of incompatible modules? If it's the latter, I'm sure someone can see the question and respond to it by advising to downgrade some packets in a certain way. I think this will ultimately be the answer, but I have zero idea how and which. – Wli Jan 28 '18 at 19:43
1

I have had a similar problem, it was due to running on the ubuntu 16.04 initial release which did not contain HWE. The latest amgpu-pro version that worked on that one is 17.10.

Upgrading the version solved it and made amdgpu-17.50 work for me. https://wiki.ubuntu.com/Kernel/LTSEnablementStack here are the instructions on how to do so.

It did in my case however not solve the Firefox tab crashes that appeared since Firefox 58. However temporarily disabling WebGL in Firefox can stop these.

  • amdgpu-pro 17.50 could be installed after the version upgrade: check disabling ff 58 WebGL stopped crashes: check Answer accepted, I'll continue posting my issues on askubuntu Thank you Guest dash dash! – Wli Feb 4 '18 at 15:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.