Everything was running fine until yesterday when I installed KDE Plasma on my Ubuntu 17.10 desktop. I have a bunch of startup applications which I set to start upon my login. After installing KDE, I restarted my system and changed the desktop environment to Plasma and logged in. All things looked okay. Now today I started my PC and logged in with GNOME set as desktop environment, and no startup applications were started. I logged out and changed the desktop environment to Plasma and again logged in, and startup applications were started. Then again I logged out and logged in with GNOME, none of my startup applications were started. I rebooted and repeated again the things and also tried with other desktop environments.

Problem what I actually found was that the startup applications only start when I log in with Plasma and not with any other Desktop Environments. Now that's very agitating that if you wanna start your session with desktop environment other than plasma, startup applications do not start. Need urgent help. How to fix this problem?

  • Looks like KDE has the autostart applications in a different folder than the others. Look at docs.kde.org/trunk5/en/kde-workspace/kcontrol/autostart/… as I believe that if you move the startup applications to $HOME/.config/autostart folder KDE should be able to start them as well. – Terrance Jan 28 '18 at 3:53
  • 1
    While I hope @Terrance's advice works for you, I'll remind you of the comment I posted in your other question. Both the GNOME and KDE desktop environments (DEs) are somewhat aggressive in trying to take control of your system. Other DEs such as LXDE and XFCE may play well with each other or with other DEs. – DK Bose Jan 28 '18 at 4:06
  • I agree with @DKBose about having multiple DEs in use. I actually very recently wiped out my system due to multiple DEs causing many unpredictable problems on my system. One was my network had to be brought up manually after every reboot. Another was icons and applications getting moved all over, plus parts of the other DEs were not working correctly. – Terrance Jan 28 '18 at 4:09
  • @Terrance and DKBose, first of all things, my problem is that Startup Applications only start when I start KDE. Secondly, the link posted by Terrance tells that "The autostart feature has a bug, currently it is not possible to run a script after the startup of your Plasma™ session", but actually my PC is acting totally different. – V. Ag. Jan 28 '18 at 4:21
  • The document, and by inference, the bug refer to Plasma 5.4 (2015-07-22). Run plasmashell --version to know your current version. – DK Bose Jan 28 '18 at 4:28

I had the same problem, I just removed all the startup applications and added them again being in gnome session. It worked for me.

  • 1
    Does that work? let me try... – V. Ag. Feb 3 '18 at 2:48

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.