Whenever I try to install any package, I get the error "Unable to Download Packages", "Check your Internet connection". But the strange part is that I can use synaptic to download and install the same packages.

Any help would be great. Thanks.

up vote 3 down vote accepted

Open Software Center > Edit > Software Sources.. > then from Ubuntu Software (tab) > (Check ) Download From > { Change the Server }

enter image description here

Have you checked which server you are downloading from ? Try switching to main, i just recently had the same problem with the canadian server.

  • im on my phone when i get to a pc i can tell you how to change/check it – rlemon Jan 31 '12 at 1:56
  • 1
    The main server didn't work, it wasn't even connecting to the repositiory. But thanks, the next reply helped. – Prarobo Feb 2 '12 at 22:08

I had the same issue. It started after I switched from a wireless card to a standard ethernet connection. After I switched to ethernet, my internet browser (Chrome) and E-mail (Thunderbird) worked fine, but I was getting the same software update issues.

If you look in the upper right hand edge of the screen, there is a up-arrow/down-arrow symbol near the blutooth and speaker volume symbols. This is the network manager.

It you right-click on it with a mouse you should see a list of your wired and wireless connections. After I switched, Network Manager had a message at the top that said something to the effect of "Ethernet connection wired device not managed".

I found the article: network manager says "device not managed"

But to summarize, I used the following Command Line commands to make it work:

To do this - in a terminal:

sudo nano /etc/NetworkManager/NetworkManager.conf

Change the line




Save (CTRLX, then Y and enter)

Stop and start network manager:

sudo service network-manager restart

And it should work (it worked for me).

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.