0

Ubuntu 17.10 I'm using .desktop files to run applications through desktop icon.

This is my .desktop file

[Desktop Entry]
Type=Application
Encoding=UTF-8
Name=Fishin
Comment=fishin
Exec=/usr/share/applications/fishgm1.py  #pls note I tried Exec = /usr/bin/env pyhton3 /usr/../fishgm1.py as well
Icon=/usr/share/icons/hicolor/36x36/apps/gonefishin36.png
Terminal=true'

source code includes proper shebang #!/usr/bin/env python3

I was successful previously. Now that is not the case I am only able to run these apps through the ubuntu gui >usr> share>app . Clicking the desktop icon yields 'untrusted applciation launcher'. I have used a screencap comparing my attempt today with my successful attempt. fishgm1.py/fishgm1.desktop is my unsuccessful attempts. simi1.py/test1.desktop is my previous successful attempt.

I moved the .py files into /usr/share/applications with sudo -i. I cp'd from home/path/files to /usr/share/applications and /usr/share/icons/hicolor/36x36/apps for my icon. Permissions are correct. Again, file runs from ubuntu files gui but not from my desktop icon.

Screencap is included. Please notice that permissions are the same for both files but icon image shows up only on one app. my failing deployment compared to my working deloyment

  • The file is owned by root. Problem solved in this post: askubuntu.com/questions/425192/… – lordBAbaracus Jan 28 '18 at 0:23
  • @lordBAbaracus sudo chown myuser:myusergroup /home/me/Desktop/file.desktop -R did the trick ...may I ask what impact this technically has on the bits ...b/c the .desktop file has r+x for all ... (permissions are not my strong suit) – meyeti Jan 28 '18 at 0:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.