1

During some experiments I pressed CTRL+ALT+F1 which switch the to ttyl1, I logged in and then since I didn't know how to get back to the GUI I typed startx which I think started another GUI that was not lightdm or a version of lightdm with less function. Then I reboot in cli and when my computer booted back I was asked to provide a passphrase for swap (first time), and after that the the screen was blank and frozen.

I managed to boot by adding the option 3 on grub which boots on ttyl, from where I can start lightdm.

However, after reboot the issue persist : if I don't add '3' to grub, Ubuntu won't boot and I get stuck on a blank screen.

On the boot log I found :

[FAILED] Failed to start NVIDIA Persistence Daemon.

So I checked the status of nvidia-persistenced.service

nvidia-persistenced.service - NVIDIA Persistence Daemon
   Loaded: loaded (/lib/systemd/system/nvidia-persistenced.service; static; vendor preset: enabled)
Active: failed (Result: exit-code) since dim. 2018-01-28 00:39:57 CET; 3min 26s ago
Process: 5033 ExecStart=/usr/bin/nvidia-persistenced --user nvidia-persistenced --no-persistence-mode --verbose (code=exited, status=203/EXEC)

janv. 28 00:39:57 M systemd[1]: Starting NVIDIA Persistence Daemon...
janv. 28 00:39:57 M systemd[1]: nvidia-persistenced.service: Control process exited, code=exited status=203
janv. 28 00:39:57 M systemd[1]: Failed to start NVIDIA Persistence Daemon.
janv. 28 00:39:57 M systemd[1]: nvidia-persistenced.service: Unit entered failed state.
janv. 28 00:39:57 M systemd[1]: nvidia-persistenced.service: Failed with result 'exit-code'.   

My setup is the following:

  • XPS 9560
  • Ubuntu 16.04.3
  • Kernel 4.13.0-32-generic

Thank you very much for your help!

0

Check the ownership of your home directory's "hidden" files, the ones starting with a dot, e.g.

 ls -Al  

They should all be owned by you. root ownership probably crept in when you did the startx, and that will mess you up. The contents of the root owned directories should be changed back too, e.g.

chown -R username:username .config  

.dbus should be owned by you, so change it (and its contents). Then probably just reboot and login again.

  • Hello, in my home dir all the files and directory belong to me unless .. and .dbus. I think .dbus always belonged to root however I don't have any idea of .. should I change it too ? – raphael Jan 28 '18 at 9:28
  • @raphael My ~/.dbus is also owned by root. – WinEunuuchs2Unix Jan 28 '18 at 16:39
  • @WinEunuuchs2Unix thanks, what about .. on ~ ? – raphael Jan 28 '18 at 17:12
  • @raphael .. refers to the parent directory which would be /home which of course is owned by root because it created that directory during installation. – WinEunuuchs2Unix Jan 28 '18 at 17:27
  • @WinEunuuchs2Unix that is what I thought but had to be sure, so that is not what is messing things on my computer... Do you have any solutions or ideas for my issue ? Thanks again – raphael Jan 28 '18 at 17:32
0

The following procedure worked for me (I do not think anything is required) :
To my mind the issue was related with the NVIDIA Drivers so i decide to remove them

sudo apt-get purge --auto-remove libcud*
sudo apt-get purge --auto-remove cuda*   
sudo apt-get purge --auto-remove nvidia*

And then I installed it back again :

sudo add-apt-repository ppa:graphics-drivers/ppa
sudo apt update/etc/default/grub 

sudo ubuntu-drivers autoinstall

After that I changed my grub settings located in /etc/default/grub and change the line GRUB_CMDLINE_LINUX_DEFAULT by :GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_rev_override=5". Do not forget to run update-grub after that. I would recommend you to change the grub settings before reinstalling the nvidia drivers. Because I think that when I did the setup of ubuntu 16.04 I already added the acpi override but something seems to have deleted it.

With that I was able to run kernel 4.14.15-041415-generic.

Extra:

I did run:

bash -c "$(curl -fsSL https://gist.githubusercontent.com/whizzzkid/d5f9491cd60f09be51920e973a60e401/raw/3e94e3cb3ca785ec4f3488594828c7c0b5db8ce4/IGFWL.sh)"

to install Intel Graphics Patch Firmwares but I'm not sure it was usefull.

  • ubuntu-drivers is not installed by default in Xenial – jjmerelo Feb 24 '19 at 11:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.