1

I am getting this error when trying to upgrade:

E: Failed to fetch http://archive.ubuntu.com/ubuntu/pool/main/l/linux-firmware/linux-firmware_1.157.15_all.deb  Hash Sum mismatch

To check what is wrong I downloaded the package from the address and checked the md5 which is showing something different in my machine from the one given on the website.

2

That generally means that the download was corrupted. Try the following to remove the downloaded file and retry the upgrade:

sudo apt-get clean
sudo apt-get upgrade
| improve this answer | |
  • 1
    tried :/ still same – Chetan Jan 27 '18 at 6:37
  • Are you behind a proxy server that might cache the downloads? – Chai T. Rex Jan 27 '18 at 6:38
  • nope, i am wondering why is that md5 sum is given on packages.ubuntu.com/xenial-updates/all/linux-firmware/download ,if u try to manually download and check both are different – Chetan Jan 27 '18 at 6:54
  • here in my machine its 2a7001cd87df0e459eb7fe5b98c8f77e and on website its c144ae5a59948a989a4695de73f11eac – Chetan Jan 27 '18 at 6:54
  • can you try with sudo apt-get autoremove sudo apt-get autoclean sudo apt-get update – sourav Mar 13 '18 at 13:01
0

As an addendum to the previous answer:

Delete your local copy of the file. Choose a different apt mirror (to prevent caching of the corrupt download by some transparent proxy) and retry.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.