2

It doesn't seem like that nslookup falls back to other DNS servers in Ubuntu 17.10.

DNS subsystem is now managed by systemd-resolved daemon. And I see the /etc/resolv.conf is linked as below:

$ ls -l /etc/resolv.conf 
lrwxrwxrwx 1 root root 32 Jan 22 15:40 /etc/resolv.conf -> /run/systemd/resolve/resolv.conf

As per systemd-resolved man page it seems that it should've tried all the DNS servers in parallel, but it doesn't. It doesn't try secondary DNS name servers if first on fails.

As per the manpage getaddrinfo() internally retries all DNS servers in parallel, but it doesn't seem like that.

socket.getaddrinfo("internal.set", 80, 0, 0, socket.IPPROTO_TCP)
Traceback (most recent call last):
File "", line 1, in
File "/usr/lib/python3.6/socket.py", line 745, in getaddrinfo
for res in _socket.getaddrinfo(host, port, family, type, proto, flags):
socket.gaierror: [Errno -2] Name or service not known

In the case above, 'internal.set' is valid name but only accessible via secondary DNS server.

BTW, i tried setting set fail as per nslookup man page. Wireshark still reports that only one DNS server has been tried.

$ nslookup 
> set fail
> host internal.set
Server:         8.8.8.8
Address:        8.8.8.8#53

Non-authoritative answer:
*** Can't find host: No answer
> 
0

In Ubuntu 17.10 they changed to netplan to manage networks.

for desktop it is now netplan/networkmanager for server (headerless) it is now netplan/networkd

So basically anything you have edited in the past doesn't really work anymore. To make life more confusing it is all still there, and editing it can just add further layers of problem (that's experience talking). Once I just started working with only the netplan stuff, everything started to work again.

As far as I understand you now edit gui from within the gui (I don't use the gui), if you google ubuntu 18.04 static ip netplan networkd you will probably find what you are looking for. I have only just discovered most of this, and I am still not 100% sure how it all works, which is why I have not told you how I setup my network stuff. Bad advise only makes things worse.

My key info was found here: https://websiteforstudents.com/configure-static-ip-addresses-on-ubuntu-18-04-beta/

Once I get a chance to work through it fully and test it all I will do a short blog on it.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.