1

I would like to ask the following question. I installed Ubuntu 17.10.1 on my Thinkpad X1C 5th gen. Trackpoint worked after putting the kernel option "psmouse.proto=bare". But, I can not change the scrolling direction. Now, pushing the trackpoint up (toward the display) scrolls a window down and pushing the trackpoint down (toward the trackpad) scrollls a window up. How can I reverse this scrolling?

I created the file /usr/share/X11/xorg.conf.d/90-evdev.conf with the following content:


Section "InputClass"
Identifier "Touchpad/TrackPoint"
MatchProduct "PS/2 Generic Mouse"
MatchDriver "evdev"
Option "EmulateWheel" "1"
Option "EmulateWheelButton" "2"
Option "Emulate3Buttons" "0"
Option "XAxisMapping" "7 6"
Option "YAcisMapping" "5 4"
EndSection


Then, I changed the XAxisMapping into "6 7". But, even after logout/login, nothing has changed on the scrolling. What should I do instead? Thank you in advance.

  • I switched to Cinnamon and it solved. But, still solutions for original gnome setting is welcome! – veo Jan 27 '18 at 2:04
  • Please, show the output of xinput list-props Trackpoint (with the Trackpoint replaced with either its name or its id from the xinput list output). – Hi-Angel Aug 14 '18 at 8:56

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.