2 replaced http://askubuntu.com/ with https://askubuntu.com/
source | link

Problem

I was experiencing the same issue on a ThinkCentre m900 SFF with a i7-6700 CPU. The system would freeze randomly and a hard reset was required, which rendered working with that system a pain if not impossible. The log only showed a lockup state of the CPU, but did not provide extensive information as the logging was frozen as well.

Research

This issue is probably related to the power states the Skylake processor, which are not compatible with Kernels from the 4x series yet.

Solution Attempts

I tried setting the boot parameter intel_idle.max_cstate=1, as suggested here and herehere and here. This did not have a positive effect and the system continued to freeze every few hours.

I also installed newer kernels in Ubuntu 16.10, including Kernel 4.8 which should support the Skylake CPUs, but still the problem remained and the system freezed. I also tried Mint 18.0, Mint 18.1, Ubuntu 16.04 and Ubuntu 16.10. All systems showed the same behavior, which - in retrospective - was not surprising as they are all Xenial based, but I tried to exclude the Window Manager from being a cause. I disabled the on-board GPU and only used the Nvidia card and vice versa to exclude the GPU as a cause. I disabled UEFI and reinstalled with a legacy BIOS, same effect.

Workaround Solution

Lenovo certified the system for Ubuntu 14.04 officially, see here. As a last try, I reinstalled the older version of Ubuntu, which appeared before the CPU was released. I did not expect the 3.x Kernel to work, but as a surprise I am now running Mint 17.3 Rosa, based on Trusty (14.04.05 LTS) and have security updates until early 2019. I hope the problem is resolved until then, so far I had no more freezes.

Problem

I was experiencing the same issue on a ThinkCentre m900 SFF with a i7-6700 CPU. The system would freeze randomly and a hard reset was required, which rendered working with that system a pain if not impossible. The log only showed a lockup state of the CPU, but did not provide extensive information as the logging was frozen as well.

Research

This issue is probably related to the power states the Skylake processor, which are not compatible with Kernels from the 4x series yet.

Solution Attempts

I tried setting the boot parameter intel_idle.max_cstate=1, as suggested here and here and here. This did not have a positive effect and the system continued to freeze every few hours.

I also installed newer kernels in Ubuntu 16.10, including Kernel 4.8 which should support the Skylake CPUs, but still the problem remained and the system freezed. I also tried Mint 18.0, Mint 18.1, Ubuntu 16.04 and Ubuntu 16.10. All systems showed the same behavior, which - in retrospective - was not surprising as they are all Xenial based, but I tried to exclude the Window Manager from being a cause. I disabled the on-board GPU and only used the Nvidia card and vice versa to exclude the GPU as a cause. I disabled UEFI and reinstalled with a legacy BIOS, same effect.

Workaround Solution

Lenovo certified the system for Ubuntu 14.04 officially, see here. As a last try, I reinstalled the older version of Ubuntu, which appeared before the CPU was released. I did not expect the 3.x Kernel to work, but as a surprise I am now running Mint 17.3 Rosa, based on Trusty (14.04.05 LTS) and have security updates until early 2019. I hope the problem is resolved until then, so far I had no more freezes.

Problem

I was experiencing the same issue on a ThinkCentre m900 SFF with a i7-6700 CPU. The system would freeze randomly and a hard reset was required, which rendered working with that system a pain if not impossible. The log only showed a lockup state of the CPU, but did not provide extensive information as the logging was frozen as well.

Research

This issue is probably related to the power states the Skylake processor, which are not compatible with Kernels from the 4x series yet.

Solution Attempts

I tried setting the boot parameter intel_idle.max_cstate=1, as suggested here and here and here. This did not have a positive effect and the system continued to freeze every few hours.

I also installed newer kernels in Ubuntu 16.10, including Kernel 4.8 which should support the Skylake CPUs, but still the problem remained and the system freezed. I also tried Mint 18.0, Mint 18.1, Ubuntu 16.04 and Ubuntu 16.10. All systems showed the same behavior, which - in retrospective - was not surprising as they are all Xenial based, but I tried to exclude the Window Manager from being a cause. I disabled the on-board GPU and only used the Nvidia card and vice versa to exclude the GPU as a cause. I disabled UEFI and reinstalled with a legacy BIOS, same effect.

Workaround Solution

Lenovo certified the system for Ubuntu 14.04 officially, see here. As a last try, I reinstalled the older version of Ubuntu, which appeared before the CPU was released. I did not expect the 3.x Kernel to work, but as a surprise I am now running Mint 17.3 Rosa, based on Trusty (14.04.05 LTS) and have security updates until early 2019. I hope the problem is resolved until then, so far I had no more freezes.

1
source | link

Problem

I was experiencing the same issue on a ThinkCentre m900 SFF with a i7-6700 CPU. The system would freeze randomly and a hard reset was required, which rendered working with that system a pain if not impossible. The log only showed a lockup state of the CPU, but did not provide extensive information as the logging was frozen as well.

Research

This issue is probably related to the power states the Skylake processor, which are not compatible with Kernels from the 4x series yet.

Solution Attempts

I tried setting the boot parameter intel_idle.max_cstate=1, as suggested here and here and here. This did not have a positive effect and the system continued to freeze every few hours.

I also installed newer kernels in Ubuntu 16.10, including Kernel 4.8 which should support the Skylake CPUs, but still the problem remained and the system freezed. I also tried Mint 18.0, Mint 18.1, Ubuntu 16.04 and Ubuntu 16.10. All systems showed the same behavior, which - in retrospective - was not surprising as they are all Xenial based, but I tried to exclude the Window Manager from being a cause. I disabled the on-board GPU and only used the Nvidia card and vice versa to exclude the GPU as a cause. I disabled UEFI and reinstalled with a legacy BIOS, same effect.

Workaround Solution

Lenovo certified the system for Ubuntu 14.04 officially, see here. As a last try, I reinstalled the older version of Ubuntu, which appeared before the CPU was released. I did not expect the 3.x Kernel to work, but as a surprise I am now running Mint 17.3 Rosa, based on Trusty (14.04.05 LTS) and have security updates until early 2019. I hope the problem is resolved until then, so far I had no more freezes.