111 reputation
3
bio website appleseedhq.net
location
age
visits member for 2 years, 1 month
seen yesterday

Mar
19
awarded  Popular Question
Sep
14
awarded  Editor
Sep
14
revised Setting LD_LIBRARY_PATH before running an app from a terminal has no effect
added 86 characters in body
Sep
14
comment Setting LD_LIBRARY_PATH before running an app from a terminal has no effect
Unfortunately, it doesn't: LD_LIBRARY_PATH=/home/franz/Projects/appleseed/archives/releases/1.1.0-alpha-14‌​‌​-0-g4e46ed9/appleseed/bin ldd ./appleseed.studio returns libappleseed.so => /home/franz/Projects/appleseed/build/linux-gcc4/appleseed/libappleseed.so (0x00007fc27cce5000). I am at loss here. It looks like the LD_LIBRARY_PATH mechanism is somehow disabled on my system.
Sep
13
comment Setting LD_LIBRARY_PATH before running an app from a terminal has no effect
Hehe, thanks for the link. I am actually the author of appleseed :)
Sep
13
comment Setting LD_LIBRARY_PATH before running an app from a terminal has no effect
Alright, no problem. Thanks a lot for you help. Seems like there may be a problem with how this version of Ubuntu handles LD_LIBRARY_PATH.
Sep
13
comment Setting LD_LIBRARY_PATH before running an app from a terminal has no effect
Here's what appleseed.studio says: "The application failed to start because it is not properly installed. Please reinstall the application. Specifically, it was expected that ld-2.12.1.so would reside in a bin/ subdirectory inside the main directory of the application, but it appears not to be the case (ld-2.12.1.so seems to be located in /lib)."
Sep
13
comment Setting LD_LIBRARY_PATH before running an app from a terminal has no effect
The dynamic linker seems to be called ld-linux-x86-64.so.2 on my system. So if I run the command you suggested, appleseed.studio starts but immediately complains that it isn't started from the bin/ directory of its installation.
Sep
13
comment Setting LD_LIBRARY_PATH before running an app from a terminal has no effect
Can't seem to find ld-linux-so.2, ld-linux.so or ld.so in the package list or via apt-get.
Sep
13
comment Setting LD_LIBRARY_PATH before running an app from a terminal has no effect
OK, it seems to be Linux's dynamic linker: kernel.org/doc/man-pages/online/pages/man8/ld.so.8.html. Seems like I should be able to install it via the package manager.
Sep
13
awarded  Student
Sep
13
comment Setting LD_LIBRARY_PATH before running an app from a terminal has no effect
Absolutely, the bin/ directory does contain the shared libraries I want to load. Is /lib/ld-linux.so.2 supposed to be an executable binary? I haven't got it in my system.
Sep
13
comment Setting LD_LIBRARY_PATH before running an app from a terminal has no effect
Everything is 64-bit: $ file ./libappleseed.so returns ./libappleseed.so: ELF 64-bit LSB shared object, x86-64, version 1 (SYSV), dynamically linked, not stripped, while $ file /home/franz/Projects/appleseed/build/linux-gcc4/appleseed/libappleseed.so returns /home/franz/Projects/appleseed/build/linux-gcc4/appleseed/libappleseed.so: ELF 64-bit LSB shared object, x86-64, version 1 (SYSV), dynamically linked, not stripped.
Sep
13
asked Setting LD_LIBRARY_PATH before running an app from a terminal has no effect