63 reputation
210
bio website
location
age
visits member for 2 years, 2 months
seen Feb 8 '13 at 15:38

Dec
17
awarded  Notable Question
Sep
22
awarded  Self-Learner
Sep
21
awarded  Custodian
Sep
16
awarded  Notable Question
Aug
17
awarded  Popular Question
Jul
3
awarded  Popular Question
May
13
comment Bad 3D Performance in Ubuntu 12.04
@fossfreedom - Apologies. I use the StackExchange websites a lot but I've never had to actually post until now. I'll keep it in mind in future. I originally thought that I didn't need to since I accepted an answer and he updated his answer to say the cause of the problem. Thanks!
May
13
revised Bad 3D Performance in Ubuntu 12.04
added 703 characters in body
May
12
awarded  Teacher
May
12
accepted Bad Performance With Games Under Wine
May
12
answered Bad Performance With Games Under Wine
May
12
comment Bad 3D Performance in Ubuntu 12.04
Though on a final note, it would be nice to know how to change the default WM in the Gnome-Classic session, since your other method didn't seem to work.
May
12
awarded  Scholar
May
12
accepted Bad 3D Performance in Ubuntu 12.04
May
12
comment Bad 3D Performance in Ubuntu 12.04
So I guess the problem is with Compiz in the end and I'll just need to find an alternative WM. Thanks very much for all your help!
May
12
comment Bad 3D Performance in Ubuntu 12.04
@TechZilla - Yes one of those choices is that. It's odd though. When using that there are no panels. I got the terminal up using a shortcut and found that even in that session Compiz was running so performance was the same. I however did openbox --replace and the windows changed. I still didn't have the panels but fgl_glxgears and glxgears gave the same results as when I was in LDXE. I managed to change the WM in the normal Gnome-Classic session with the same command and got the same results (except with panels).
May
12
awarded  Commentator
May
12
comment Bad 3D Performance in Ubuntu 12.04
Sorry for the confusion, I just didn't know how to check which WM I was using and Compiz did not show when using your instruction sudo update-alternatives --config x-window-manager. It rather indicated Openbox was the current choice, and Compiz wasn't selectable.
May
12
comment Bad 3D Performance in Ubuntu 12.04
@TechZilla - I meant that I get the same performance issues in Unity and Gnome-Classic. Sorry for the wording, it's just on the login screen it says "Ubuntu" rather than "Unity". No I am not sure if I'm using Openbox. As I said previously when I changed to Mutter with your instructions there was no visual change then either. I have a feeling that the alternative x-window-manager setting just isn't taking effect or is being ignored. I tried checking the running processes and compiz is a running process, so I think that is the WM in effect like you suggested a while ago.
May
12
comment Bad 3D Performance in Ubuntu 12.04
So it seems that it is something to do with the default Ubuntu DE and the Gnome Classic session I've been using. It might be worth mentioning that it's not just normal Gnome I've been using, but the Gnome Fallback version that gives Ubuntu the old style UI with Ambiance theme. Do you perhaps know the exact thing which is causing it and if there's a fix?