188 reputation
10
bio website astokes.org
location United States
age
visits member for 2 years, 9 months
seen yesterday

Work at Canonical and punches hamsters.


2d
comment can't bootstrap in Landscape OpenStack Autopilot
Are you able to juju bootstrap outside of the installer to a node in your MAAS environment? It'd be interesting to see if the bootstrap is failing and not the installer. Also are you behind any proxies?
2d
comment Node Enlistment for the Canonical Distribution of Ubuntu Openstack
Can you paste.ubuntu.com the /var/log/maas/maas.log and /var/log/maas/pserv.log preferably around the time that you attempt to have the node detected by MAAS. If pserv is not indicating that its actually attempting to communicate with that node then that usually means something with the network is misconfigured. At the very least it should PXE from the MAAS server. Also maybe a sosreport -o maas would help here as well.
Jan
25
comment openstack-install issues
FYI we've landed code that support preseeded configuration options.
Jan
25
comment Power type for nodes in MAAS cluster
possible duplicate of How to configure MAAS to be able to boot virtual machines
Jan
25
comment Node Enlistment for the Canonical Distribution of Ubuntu Openstack
Do you have another dhcp/dns service listening on that network? If so the network boot could be attempting to pxe from that rather than the maas provided dns/dhcp
Dec
6
comment openstack-install issues
looks like it is timing out attempting to connect to your MAAS machine. Was that setup prior to running the installer?
Nov
30
comment problem with juju on Ubuntu Openstack - Canonical Distribution
Looks like a possible error within Juju, can you pastebin the juju logs?
Nov
27
comment How to modify /usr/share/maas/preseeds/generic
@NebojsaKnezevic some logs would be helpful in determining what's not working. Check in /var/log/maas
Nov
22
comment Openstack Juno Juju Charms for Utopic
@user281985 1st A) Nope, Juno charms work fine on Trusty (14.04), 2nd A) im not quite sure on the status of nova-compute-lxc but wiki.ubuntu.com/OpenStack/LXC seems to indicate that someone has got it working in 14.04, You may want to open a bug against the nova package and add your error logs detailing your issue with nova-compute-lxc
Nov
22
comment Autopilot could not be installed on VMware ESXi 5.5
@chrone i dont think you have to rebuild openstack-install, just setup youre own squid proxy to cache what you need
Nov
21
comment How to Install Juno Openstack
@user281985 Correct!
Nov
21
comment Autopilot could not be installed on VMware ESXi 5.5
@chrone not sure i follow what you mean, once the MAAS_HTTP_PROXY has the boot images cached it'll just pull from there during the "Importing MAAS boot images" stage
Nov
21
comment How to Install Juno Openstack
@user281985 landscape is free up to 10 seats which is plenty to get openstack deployed
Nov
20
comment Autopilot could not be installed on VMware ESXi 5.5
@chrone You can set the MAAS_HTTP_PROXY before running openstack-install as described here: ubuntu-cloud-installer.readthedocs.org/en/latest/…
Nov
18
comment Autopilot could not be installed on VMware ESXi 5.5
@chrone yea since you're doing a landscape install it's a little more effort in uninstalling since it does affect several technologies. Essentially doing a apt-get purge of maas, destroying your juju environment, and moving ~/.cloud-install out of the way you can do a fresh install
Nov
1
comment Deploying Openstack on top of Juju+MAAS setup
If you follow the install directions from ubuntu.com/download/cloud/install-ubuntu-openstack that will get you the required installer. You can also do a dpkg -l to see what version you have
Nov
1
comment Deploying Openstack on top of Juju+MAAS setup
Make sure you're using version 0.21 of the installer. As the install option 'Multi with existing MAAS' should be an option
Dec
26
comment x230 tablet , realtek 8192ce connects to router but no internet
No luck unfortunately. When i strace a ping it returns a MSG_NOSIGNAL even though i can ping other devices on the network.