952 reputation
618
bio website tech-zilla.com
location Chagrin Falls, OH
age
visits member for 2 years, 11 months
seen 5 hours ago
  • GNU/Linux Systems Administrator

Distros:

  • Ubuntu/Debian
  • CentOS/RHEL

WebSites:


May
22
comment Touchpad not working on HP DV4 notebook
@Prateek: I rarely get any relevant answers at askubuntu, Thank you so much you really helped me out.
May
20
asked Cross compile packages, question regarding armhf dependencies
May
19
comment Extremely low 3D perfomance
make sure your 'vertical sync' is set to off, unless application requests it.
May
19
comment Extremely low 3D perfomance
@Andreas Mühlberg: I actually would expect both those settings would decrease performance, under usual conditions. Tear Free Desktop is a quality related configuration, and the default OFF is the better performance. As for the scaling, you would only want your adapter to handle scaling if you have a compelling reason. I say compelling because it theoretically lowers performance, as you move yet another task on your card.. which was previously handled by the display. You get the traditional acceleration when tasks would otherwise be handled by the CPU.
May
12
comment Bad 3D Performance in Ubuntu 12.04
perfect, glad to help out! Take it easy man.
May
12
comment Bad 3D Performance in Ubuntu 12.04
OOO wait, when you turn on your computer and get to the login manger (LighDM).. You should be able to list your session choices, is one of those choices somethings on the lines of "Gnome/Openbox". I might be wrong with the exact wording... But if it exists try it, and check your FPS. You will know if it works, because you will have Openbox window decorations. Not the regular style ones, actually if you right click on the window title you should even get an openbox window menu. ... Were almost a the finish on this problem, just hang in for a tiny bit longer.
May
12
revised Bad 3D Performance in Ubuntu 12.04
added 205 characters in body
May
12
comment Bad 3D Performance in Ubuntu 12.04
BINGO, That's the reason your performance is shoddy. I was on the right track after all. If the settings are not taking effect, try removing your other WM's. It should fall back to openbox. I'll put commands in my answer
May
12
answered Extremely low 3D perfomance
May
12
comment Extremely low 3D perfomance
@Focre, NO don't go with an old distro at this point. there may be no need to do that. I just wanted to see that your card worked as expected, sometime in the past. You have convinced me of that, so now read my answer.. follow its instructions.
May
12
comment Bad 3D Performance in Ubuntu 12.04
You threw me a curveball when you said your were using openbox, I assumed then composting was off and went another direction. Specifically trying to see if you had composting with another package, ... If it turns out you actually were not using openbox in gnome, which composting style effects would indicate, Then that is why LXDE performs better than Gnome-Classic.
May
12
comment Bad 3D Performance in Ubuntu 12.04
I also want to say, if you are using a regular non composting openbox. You should not have any transitioning effects at all. Not sure what you meant when you said "Transitions could be more fluid", can you fully disable Transitions in Gnome-Classic? Also LXDE uses openbox for its usual WM, when your in Gnome-Classic are you really getting the openbox window decorations? Meaning are you absolutely sure you are using OpenBox in Gnome-Classic. I ask because previously I was trying to get composting OFF, which should theoretically get you that LXDE style performance.
May
12
comment Bad 3D Performance in Ubuntu 12.04
Yes I fully understood what you meant, when you originally said "Gnome-Classic" ... What did you mean just now when you said "default Ubuntu DE" The default Ubuntu DE is unity, not gnome anything. Did you mean your also slow in unity? or did you mean your also slow in gnome-shell regular? BTW it's very unlikely to be related to FGLRX, as Phoronix just did a report which stated "The outlier to these results though is the AMD Catalyst driver, which for the most part performed the same regardless of desktop environment / window manager."
May
12
comment Extremely low 3D perfomance
I also want to know, have you ever used this card in another OS. Such as any version of MS Windows, or other version of GNU/Linux... Possibly an older version of Ubuntu? If so, did you get good performance? I don't really believe something is wrong with your card, but with reporting a correct configuration... and yet getting such low FPS scores... It makes me consider the possibility.
May
12
comment Extremely low 3D perfomance
This will tell us which FGLRX package you have installed, so we might know if choosing the other is preferred.
May
12
comment Bad 3D Performance in Ubuntu 12.04
I assumed you were a new user, with no extras installed... Right up until you told me you were using Openbox. Check for those Installed packages like this, dpkg -l | grep ^ii | awk ' { print $2 }' | egrep \(xcompmgr\|cairo-compmgr\|unagi\) report the results. If the packages are not installed, you should get no output. Regarding Mutter, I was expecting you had the default Compiz, I thought it was possible you would get better FPS. Unfortunately you did not get a better FPS, which is why I want to see if Openbox could be under-performing due to adding composting.
May
12
comment Extremely low 3D perfomance
Run this command, and report its output. dpkg -l fglrx* | grep ^ii | awk ' { print $2 }'
May
12
comment Bad 3D Performance in Ubuntu 12.04
OK you can uninstall mutter, sudo apt-get purge mutter. You can even clean up unnecessary dependencies with sudo apt-get autoremove --purge Openbox is what I use, it performs great IMO. Do you run Openbox with composting? Use any of these: xcompmgr, cairo-compmgr, or unagi??? I think I might be near the answer...
May
12
comment Bad 3D Performance in Ubuntu 12.04
@Force, I also want to say, You are 100% not experiancing the same problem as Pandem. You might have an incorrect configuration, as your scores are abysmal. Pandem has a correct configuration, his scores are just somewhat less than expected.
May
12
comment Bad 3D Performance in Ubuntu 12.04
sudo apt-get install mutter, after package is installed, sudo update-alternatives --config x-window-manager choose Mutter. Restart computer, log in gnome again. Then test out your FPS results. Report said results, if they differ up or down. If they remain the same, then report they are ~ the same.