Reputation
3,708
Top tag
Next privilege 5,000 Rep.
Approve tag wiki edits
Badges
11 34
Impact
~607k people reached

6h
comment Cannot install VLC on 15.04 - dependencies cannot be resolved
to avoid this in future leave only official repos enabled during distro/release upgrade. ;)
6h
comment Cannot install VLC on 15.04 - dependencies cannot be resolved
I'm glad you did this ;) And A.B.'s answer is exactly what I tried to tell you before and what was posted in the duplicated link in these comments that you have simply added a ppa/repo which contains conflicted packages with your current distro.
6h
comment Cannot install VLC on 15.04 - dependencies cannot be resolved
what is the output for apt-cache policy vlc?
16h
comment How to fix problems with following packages
look here askubuntu.com/questions/140246/…
17h
comment Cannot install VLC on 15.04 - dependencies cannot be resolved
To move the new generated list to its place in terminal run this command sudo mv /from/here/nameoffile /etc/apt/
17h
comment Cannot install VLC on 15.04 - dependencies cannot be resolved
if it was an upgrade that means it could went wrong or you haven't followed all steps to avoid upgrade issues like disable all repos except the official ones as to avoid package conflicts etc. You can generate yourself a new list for 15.04 from here repogen.simplylinux.ch but remove the current one it's located in /etc/apt you can simply open a terminal type sudo rm and drag & drop a file to a terminal window to remove it.
18h
comment Cannot install VLC on 15.04 - dependencies cannot be resolved
that is not complete output of uname -a as it doesn't state distro arch... something like generic #62~14.04.1-Ubuntu SMP Tue Aug and the question was how did you install 15.04? it means was it an upgrade or clean install? As in the output I can see that you are using sources with 14.10.
18h
comment Cannot install VLC on 15.04 - dependencies cannot be resolved
how did you install 15.04? What's the output for uname -a
18h
comment Cannot install VLC on 15.04 - dependencies cannot be resolved
and again issue is not in vlc ppa but some repository that you have added which contains conflicted packages. Disable that repo or remove it then run sudo apt-get update to update packages list.
19h
comment Cannot install VLC on 15.04 - dependencies cannot be resolved
your edit clearly refers to duplicated link that I posted above.
Aug
27
awarded  Popular Question
Aug
25
accepted How to lock the screen in XFCE?
Aug
25
comment Cannot install VLC on 15.04 - dependencies cannot be resolved
to reinstall vlc run sudo apt-get remove --purge vlc vlc-nox vlc-data then sudo apt-get install vlc
Aug
25
comment Cannot install VLC on 15.04 - dependencies cannot be resolved
it doesn't mean that you have added ppa for vlc the reason might be that you have added a conflicted ppa which contains the same packages as in the other repository... Follow the duplicated link above.
Aug
25
comment Cannot install VLC on 15.04 - dependencies cannot be resolved
possible duplicate of How do I resolve unmet dependencies after adding a PPA?
Aug
25
revised Cannot install VLC on 15.04 - dependencies cannot be resolved
improved formatting
Aug
24
revised Package Manager error 2015Aug24
improved formatting
Aug
24
accepted Cannot remove or update a package
Aug
23
comment How to lock the screen in XFCE?
it's xfce not unity or whatever you use. ;)
Aug
23
answered How to lock the screen in XFCE?