111 reputation
4
bio website
location Cedar City, UT
age 24
visits member for 3 years, 11 months
seen Feb 24 at 15:55

Feb
28
awarded  Popular Question
Jan
28
revised Ubuntu 12.04.5 LTS won't update libc6 to 2.15-0ubuntu10.10
added 353 characters in body
Jan
27
comment Ubuntu 12.04.5 LTS won't update libc6 to 2.15-0ubuntu10.10
Do you think I would have to uninstall the old version of libc/libc-dev? I wouldn't think so because dpkg said it was replacing those old versions.
Jan
27
comment Ubuntu 12.04.5 LTS won't update libc6 to 2.15-0ubuntu10.10
I have some 14.04 servers that have successfully been patched, and the C vulnerability checker prints "not vulnerable", so I'm pretty confident the code works.
Jan
27
awarded  Student
Jan
27
comment Ubuntu 12.04.5 LTS won't update libc6 to 2.15-0ubuntu10.10
I installed both deb packages, ldd --version shows Ubuntu EGLIBC 2.15-0ubuntu10, but the C program is still printing "vulnerable", which I recompiled and rebooted before rerunning. A new server is looking more and more likely...
Jan
27
comment Ubuntu 12.04.5 LTS won't update libc6 to 2.15-0ubuntu10.10
Thanks for your help, geoffmcc. We will be creating a replacement 14.04 LTS server for the code that's running on this server soon, and we might just abandon this server without patching this vulnerability.
Jan
27
comment Ubuntu 12.04.5 LTS won't update libc6 to 2.15-0ubuntu10.10
Please see my updated answer.
Jan
27
revised Ubuntu 12.04.5 LTS won't update libc6 to 2.15-0ubuntu10.10
added more details on answer
Jan
27
awarded  Editor
Jan
27
revised Ubuntu 12.04.5 LTS won't update libc6 to 2.15-0ubuntu10.10
added 42 characters in body
Jan
27
asked Ubuntu 12.04.5 LTS won't update libc6 to 2.15-0ubuntu10.10
Feb
5
comment Recursive grep fails for *.c files
Late to the party here, but I'm confused about what the . at the end of the command is for.
Jan
10
awarded  Supporter