141 reputation
17
bio website softwarecubes.com
location Vancouver, Canada
age 30
visits member for 1 year, 9 months
seen Oct 15 at 19:42

I am a web and mobile application developer from Vancouver, BC, Canada.

I have been developing web applications professionally since 2002. Most often I work with php5 (using Symfony + Propel + sfAltumoPlugin*), MySQL, html5, jQuery, AngularJS and css3 but I have looked and experimented with nodejs, Backbone, Google Closure, MongoDB, Redis, CouchDB and others.

I am also quite comfortable deploying and managing servers in both physical and virtual environments. I have been managing several production servers on AWS utilizing EC2, RDS, R53, S3 and their respective APIs to automate tasks.

*sfAltumoPlugin is an open source multi-purpose php 5.3+ library that I co-founded and regularly contribute to. It contains a set of high-quality, well-commented, tested "plumbing" code that I use to avoid writing the same general-purpose code over and over.

In addition to web applications, I recently got involved with mobile application development for iOS. My current focus in learning is Objective-C and relevant frameworks.


Mar
27
comment Ubuntu 12.04 boots into black blank screen
see my answer for details
Mar
27
comment Ubuntu 12.04 boots into black blank screen
Yeah.. reinstalling wasn't really an option for me.. I got it fixed tho :)
Mar
26
comment Ubuntu 12.04 boots into black blank screen
I'm running a software raid with mdadm, the drives are brand new and I specifically checked that they were in sync a few minutes before the reboot happened. I have tried booting from both independently and I get the same black screen.
Mar
26
comment Ubuntu 12.04 boots into black blank screen
I already have a bootable USB installer. How is re-installing a long term solution?
Mar
26
comment Ubuntu 12.04 boots into black blank screen
Video card is on-board.. Intel Graphics as per ca.asus.com/en/Motherboards/Intel_Socket_1155/P8H77I/…
Mar
26
comment Ubuntu 12.04 boots into black blank screen
yes, apt-get was fully complete.. nothing was running when I rebooted it.. I rebooted it from the console by typing (reboot now)
Mar
1
comment Installing 12.04 server as a software RAID 1 mirror fails to boot
did you find a way to fix a system that already tried to boot and failed? I already spent a bunch of time setting one up and it'd suck to do it again :/ I guess I would have to boot off the livecd again, mount the raid and install grub manually.