Hot answers tagged

21

Remove xscreensaver and install gnome-screensaver which has a more polished look: sudo apt-get remove xscreensaver sudo apt-get install gnome-screensaver You can also set a shortcut to lock the screen with the keyboard: Start > Settings Manager > Keyboard > Application Shortcuts > Add Command: xflock4 ShortCut: <Super>l ; (e.g. press the ...


9

I think you have to disable the "lock" in two different places. First, open the power manager. You can click on the power icon in the panel and select "preferences" or it should also be in Menu -> Preferences -> Power Manager De-select "Lock screen...." under the "Extended" menu tab. Second, open screensaver preferences. Menu -> Preferences -> ...


8

Tested and used in Ubuntu 13.04 As no answer has been marked as correct yet; this could be this issue with running xscreensaver on startup as @peterx14 says here, many of the tutorials for setting up xscreensaver provide incorrect information. They tell you to set up a screensaver.desktop file with the following command: sudo gedit ...


7

I managed to figure out a workaround, though I imagine there's a better solution out there. I looked at what was happening when my lid was closed and opened in /etc/acpi/lid.sh and found that xscreensaver was being called upon automatically. Not sure if different laptops have different settings and whatnot - I really don't know too much about this stuff. In ...


7

The closest you can come to theming is to change the colours/fonts & date-time format. Anything more will probably need to recompile xscreensaver and change the source. For example - can be changed to - how to Using leafpad (leafpad ~/.Xresources) create/amend the file .Xresources located in the home folder. Copy and paste the following for ...


7

GLSlideshow screensaver in xscreensaver is best for simply displaying your photos without distortions, animations, etc.


7

You need to specify in the advanced options of xscreensaver-demo the folder that contains your photos. Note - in previous versions of Ubuntu you could have used a screensaver called glslideshow - however this doesnt appear to work in 11.10. There are a number of other photo-screensavers available in xscreensaver: blitspin carousel decayscreen distort ...


6

Xscreensaver is a package which is an extensible screen saver framework, and locks the computer. According to this linuxfromscratch.org page. The XScreenSaver is a modular screen saver and locker for the X Window System. It is highly customizable and allows the use of any program that can draw on the root window as a display mode. The purpose of ...


5

I share your opinion on the Xscreensaver unlock screen. However, changing it requires quite a bit of skill and dedication. Some have also offered solutions in this related post: How do I theme the xscreensaver unlock screen?


5

You may try similar script to this one. Watch for player state through DBUS. I lower delay to 55 sec, work better with 1min screen saver idle time. Example VLC: BTW, VLC in Ubuntu 14.04 has DBUS interface enabled by default. Where in Ubuntu 12.04 is not. Check it from: Tools → Preferences → Advanced (or All) → Interface → Control ...


4

Do you like black? Try slock, it's the best example of the KISS principle. To install it: sudo apt-get install suckless-tools Then, the easiest way to configure it in xubuntu is: sudo apt-get remove xscreensaver This is because by default xscreensaver takes precedence over other screensavers, slock among them. Once removed, you can either kill the ...


4

One possible way is to introduce a short delay of (for example) 10 seconds before running the command. This should allow all the logon processes to complete before running the xscreensaver command. Use a startup application command line of: sh -c "sleep 10 && xscreensaver -no-splash &"


4

Ok I've resolved this issue now, and am posting the solution for anyone else that wants to do the same as I have. xscreensaver needs to be launched at startup via "Startup Applications" (hit Super and type "Startup"). Add a new entry to launch the xscreensaver daemon on startup as xscreensaver -no-splash. You need to bring up the xscreensaver config app. ...


3

I'm running Ubuntu 12.04 Classic (meaning Unity, I think), and had the same trouble. Here's what I wanted: When the screen is not locked, closing and reopening the lid should not cause the screen to lock. This is easily achievable by dconf-editor; simply browse to org > gnome > desktop > screensaver and uncheck the lock-enabled entry. PS: It seems ...


3

Since GTK3 i have used gsettings set org.gnome.desktop.lockdown disable-lock-screen 'true' This will prevent all lock-screens. If you still want to be able to lock the screen you can use 'Switch User Account...' as a substitute. For 11.10, just set up a keyboard shortcut for the command gdmflexiserver -xnest For 12.04+ its dm-tool switch-to-greeter ...


3

If you are familiar with svg image programmes (like Inkscape), you also could modify the logo to suit your own wishes. The logo is located in usr/share/pixmaps and is called xscreensaver.svg and xscreensaver.xpm. However, there is a remark on changing the logo. See this thread for more info: ...


3

From your Dash search for keyboard Then go to shortcuts tab Under System menu go to lock screen and change the associated shortcut to a new One. on Custom Shortcuts click on + and enter the command xscreensaver-command and associated it the Ctrl+Alt+L shortcut.


3

Try this. Select the GLSlideshow screensaver in xscreensaver, open the Advanced tab and under Image Manipulation select "Choose Random Image" and choose the photo directory. You may need to install xscreensaver again with these extras if the opition isn't available. sudo apt-get install xscreensaver xscreensaver-data-extra xscreensaver-gl-extra


2

Open the console (Ctrl+Alt+T) and type the following: cat > .screensaver grabDesktopImages: False grabVideoFrames: False chooseRandomImages: True imageDirectory: /home/<user>/Pictures/<choosen folder> mode: random selected: -1 and press Ctrl+D to save the file.


2

Following fossfreedom's example, I chose the following settings in a a newly created ~/.Xresources file, and I found the result quite attractive (a dark-background theme with gentle blues): xscreensaver.splash: false !font settings xscreensaver.Dialog.headingFont: -*-georgia-bold-r-*-*-18-*-*-*-*-*-*-* xscreensaver.Dialog.bodyFont: ...


2

I recommend you simply remove xscreensaver by typing sudo apt-get remove xscreensaver This will solve your problem, if you don't need a screensaver, your screen still turns black by your energy safe settings.


2

Simple answer: you currently can't. You can't use any program as screensaver but you need program written directly for use as xscreensaver module. You can see documentation on http://www.dis.uniroma1.it/~liberato/screensaver/ Currently there are only Mac OS X, KDE and Windows variants of asciiquarium screensaver but none has been probably written for ...


2

You should be able to disable the screensaver in fullscreen VLC from the Preferences > Video > Show all settings > Disable Screensaver. To disable it for other fullscreen video applications you can try the lightsOn.sh script from here. I'm wasn't sure what you mean by I do not want to have to run a shell script to disable the screensaver. ...


2

I found a forum at crunchbanglinux.org on how to either modify/change Xscreensaver. http://crunchbanglinux.org/forums/topic/18793/how-do-i-replace-xscreensaver/ Also here is a link to extra screen savers for Xscreensaver if you decide to stay with it. Included is a way to have an auto-disable script for Xscreensaver. ...


2

Execute this command to remove Xscreensaver sudo apt-get autoremove xscreensaver sudo apt-get --purge remove xscreensaver To disable, you've to go to: in gnome system->preferences->Sessions->Startup Programs and delete the entry of xscreensaver. Also give a look at System -> Preferences -> Screensaver in Unity Search Brightness and ...


2

OK I believe the exposed arguments are related to whether or not windows and there contents are displayed behind the screen saver (this will be relevant to certain screen savers that draw on the screen and the like). So it is in short if your desktop is exposed or not. This is a educated guess, the terminology used is strange I think. I do how ever ...


2

This is fixed in package whisker-menu but still not in package xfce4-panel. It appears that 'actions' is hardcoded to execute gdmflexiserver which only works if gdm is used instead of lightdm, which in turn is the xubuntu default. You have, as always, several options: Drop the actions item or disable user switch there and enable and use it in whisker-menu ...


2

The BoxFit screensaver you are after is available as part of the xscreensaver package: This can simply be installed from the Software Center or by typing the following in a Terminal window: sudo apt-get install xscreensaver More than enough beautiful screensavers there :)


1

On 12.04 you can install both xscreensaver and keep default gnome-screensaver, together, despite the "warnings" about how xscreensaver won't run unless you stop gnome-screensaver (which aren't true). If you have, in "brightness and lock" settings under system settings, the screen set to "require my password when waking from suspend", then, if xscreensaver ...


1

You could run it in a screensaver that could execute external commands. For instance, the apple2 screensaver that comes with xscreensaver-data-extra lets you do this. To see what it would look like try this: /usr/lib/xscreensaver/apple2 -program ./asciiquarium -fast -mode text It looks like other people have made screensaver versions of asciiquarium so ...



Only top voted, non community-wiki answers of a minimum length are eligible