Tag Info

Hot answers tagged

19

As of Ubuntu 12.10, the Unity 2D desktop interface ("Ubuntu 2D") no longer exists. Ordinarily, computers without adequate 3D acceleration use the llvmpipe software renderer. Unity 2d support dropped in 12.10, what now? Since Unity 2D used to be the easy way to xRDP into an Ubuntu system, its removal requires the use of a different technique. ...


19

Your steps are correct so far. The only thing that you should be aware of is that the xrdp solution is not working with the Unity Desktop Interface nor with the Gnome Desktop. You can still perform a remote session to your ubuntu through xrdp but you will need to install an alternate desktop environment. The one that seems to be the most used (probably ...


14

Well, I was unable to find a way to do this with pure xrdp, but I did find a nice writeup on how to go about getting this set up as an rdp-to-vnc gateway. It works well enough to suit my purpose. Taken from http://ubuntuwiki.net/index.php/Xrdp,_installing Install xrdp and vino sudo apt-get update && sudo apt-get install xrdp vino Configure vino ...


12

fyi... xrdp by itself uses VNC on the remote desktop/server to really take advantage of xrdp you also need x11rdp which is often is not provided in the software center etc. I've found and used the following scarygliders tool that automatically downloads & builds the latest/greatest xrdp and x11rdp on your machine and intalls it for you. It takes a ...


8

Lauchpad Bug #1251281 seems to be related with this issue - user208193, please add yourself as "Affects to me" if you agree.


8

Just to be clear in ubuntu 14.04 none of the following work as of right now: gnome-session --session=gnome-classic gnome-session --session=gnome-fallback gnome-session –session=ubuntu-2d Instead the only thing that does work is: xfce4-session This appears to be an issue with xrdp's support of Gnome, which I don't see listed as a bug on xrdp's git. ...


4

OK so taking a quick break and finding a slightly different set of instructions allowed me to get this working! (FYI I did a clean install of 14.04 first) Here's the link to the step-by-step instructions http://c-nergy.be/blog/?p=5305 The two differences in these instructions were: 1. Before installing xfce4, running an update 2. The .xsession file was ...


4

You may find that this is a more general issue with interception of the Tab key under remote XFCE4 sessions, rather than a problem with bash completion itself. I had a similar issue running XFCE4 over VNC and the workaround for me was to edit the ~/.config/xfce4/xfconf/xfce-perchannel-xml/xfce4-keyboard-shortcuts.xml file to unset the following mapping: ...


4

Gnome-fallback package seems to be broken.... You could still use xrdp if you install an alternative desktop environment.. We have installed xfce desktop instead of gnome-fallback and we can perform xrdp connection to Ubuntu 13.10 a good explanation can be found at http://c-nergy.be/blog/?p=4448 might be a good idea to fill in a bug report for xrdp, ...


4

I had this same problem this morning; attempting to install on an EC2 Ubuntu 12.10 instance. I solved it thusly... After installing gnome and xrdp, install gnome-session-fallback (instead of 2d or 3d) sudo apt-get install gnome-session-fallback Then update .xession... pico .xsession Add the this line to .xession (remove others)... gnome-session ...


3

Of course you can, that's been a central component of the Unix Time Sharing system since the day it was written circa 1970. So also is X Windows designed to be multi-user and network transparent. If you mean "how do I set this up?", you should ask a more detailed question.


3

There are many ways you could accomplish this, the first couple that are most often used would be ssh (Secure Shell - so, primarily command-line interface to start), and other graphical interfacing methods like rdesktop. You can also use a combination of ssh and rdesktop or other methods, depending on what you're trying to accomplish. As other users have ...


2

A very common way to do this is using ssh which gives you a remote shell. You can also use "ssh -X" to transparently forward X11, allowing you to run e.g. Eclipse or Firefox. This is however, somewhat slow, perhaps even more than you like. There is more than one way to do it. What fits you best, depends on what you work with, how fast a connection there ...


2

On further investigation this does seems to be a widely noticed issue with XRDP. It's probably not the client sending rubbish along as I previously said in my comment, rather that it's the server doing weird stuff for an unknown reason. Many people have documented that fixing this involves disabling the <Super>d binding for showing the desktop but ...


2

As root: cd /etc/xrdp cp km-041d.ini km-040b.ini This copies Swedish keyboard layout to Finnish keyboard layout. Now run in your actual X session (not xrdp): setxkbmap -layout fi Then connect to this machine via Windows RDP client and Finnish keyboard layout works.


2

Have a look at teamviewer.com. I'm just trying it after spending hours faffing around with guacamole and installing x11rdp-o-matic and getting nowhere. It's not the ubuntu-native solution, but if it works...?


2

I think that the xrdp.ini parameter that controls the listening interface IP is called 'address' not 'ip' i.e. in the globals section: [globals] address=127.0.0.1 At least, this works for me - however note that I am using a source-built xrdp from http://scarygliders.net/x11rdp-o-matic-central-downloads-page/ so I can't guarantee it is supported in the ...


2

While they manage to fix Unity with xrdp, I'd suggest to use the gnome desktop, there's a step by step procedure described here: http://c-nergy.be/blog/?p=3518


2

You are accessing a terminal, which is 80x25 characters by default. This will not change. Different RDP software can resize fonts, but still will be 80x25 chars. It is not clear if you ar eusing VNC protocol to access the server, but most probably yes. I will recommend to use putty (http://www.putty.org/) for Windows instead via ssh protocol, which allows ...


2

Theoretically, there are 2 ways to do this: [Source] Editing xrdp.ini to add a custom local login Make sure you have xrdp and vino installed sudo apt-get install xrdp vino Edit /etc/xrdp/xrdp.ini sudo gedit /etc/xrdp/xrdp.ini copy xrdp1 block and change its number to something else which is not already there in the ini file. Basically the number ...


2

To solve your issue, you could try to install the X11VNC package and configure xrdp to use this one. You can find detailed instruction on this post (see see http://c-nergy.be/blog/?p=5439) The guys is basically performing the following operations Download the latest xrdp package from sourceforge install some dependencies software so you can compile ...


2

Here's my own answer, or maybe it could be considered a slightly-adjusted, alternative solution. Upon further diagnosis, here is what I found: A) The command xset worked on both the Hyper-V Manager Connect session and the Xrdp session. Unfortunately, it only allows three mouse movement (not scrolling) parameters: acceleration multiplier, acceleration ...


2

X11rdp tries to improve on Xvnc by forwarding X11 draw commands as RDP draw commands instead of simply wrapping a vnc bitmap stream in RDP. http://sourceforge.net/p/xrdp/mailman/message/19278796/


2

I use the scareygliders script to install XRDP as it is more stable than the default ubuntu xrdp package and also gives you copy and paste functionality between the host and client. However, I had issues setting up XRDP with lubuntu and standard ubuntu desktops so I eventually went with xubuntu desktop: sudo apt-get update sudo apt-get upgrade # I'm not ...


1

I'm not sure that is can solve your problem but we have found the info on http://c-nergy.be/blog/?p=5305 To set Keyboard layout at the xrdp Login screen, perform the following steps As explained above, with no special configuration, the xrdp login screen keyboard layout is set to english by default. if you need to change it to another keyboard layout, you ...


1

I have experienced the same issue and for the longest time I was unsuccessful getting my Ubuntu to work like my Hyper-V 2008 R2 RDP to Win7, Win8 worked. In fact, I was so MS over the whole thing I never thought I'd get my Tablet using aRDP to connect with my RDP Services running on Server 2008 R2. But, thanks to this post and several others I put ...


1

For me it worked (system restart may be required): sudo apt-get install xrdp sudo apt-add-repository ppa:ubuntu-mate-dev/ppa sudo apt-add-repository ppa:ubuntu-mate-dev/trusty-mate sudo apt-get update sudo apt-get upgrade sudo apt-get install ubuntu-mate-core ubuntu-mate-desktop echo mate-session >~/.xsession sudo service xrdp restart source: ...


1

Already answered here: 13.10 XRDP problem with gnome-fallback As you know by now, the ability to fire up a gnome-session with xrdp broke with Ubuntu 14. Bug here: https://bugs.launchpad.net/ubuntu/+source/gnome-session/+bug/1251281 Ubuntu 12 does not have this problem. This might be your solution. However it will be soon out of support so that is not an ...


1

Create inside the /media directory the directory where you want to mount your dvd. In example mkdir /media/sasha Then figure out where your dvd can be found using the command lshw and look for something like /dev/srX where X is a digit. In my case the dvd was on sr0 so I needed to execute: mount -t iso9660 -o loop /dev/sr0 /media/sasha


1

Ok - so as it turns out, it DOES log in and provide the desktop if i haven't logged in locally - I just needed to wait... It seems to take 20 or so seconds for the gui to fire up - rather than the couple of seconds if i'm already logged in locally. All that's to say, it works out the box... :)



Only top voted, non community-wiki answers of a minimum length are eligible