Tag Info

Hot answers tagged

32

Modify /etc/lightdm/lightdm.conf to add the following options: display-setup-script > calls your mycustomloginvideo.sh before the login screen appears session-setup-script > calls your mycustomdesktopvideo.sh before the user desktop session starts [SeatDefaults] greeter-session=unity-greeter user-session=ubuntu # for your login screen, e.g. LightDM ...


16

Native resolution for Samsung SyncMaster B2030 is 1600 * 600 60 Hz Generate the modeline using cvt: cvt 1600 900 60 which will be: # 1600x900 59.95 Hz (CVT 1.44M9) hsync: 55.99 kHz; pclk: 118.25 MHz Modeline "1600x900_60.00" 118.25 1600 1696 1856 2112 900 903 908 934 -hsync +vsync Get the name of the output to which your display is connected: ...


11

NOTE: I also posted this answer here I found a very simple workaround that works perfectly for me running 13.04. on a laptop with a 24" external screen that is not permanently connected. I'll just copy from here log in use xrandr or the Displays control utility to configure your monitors how you'd like them to be configured in the login screen ...


9

I think you can add the display modes to /etc/X11/xorg.conf. If you don't have a xorg.conf, then you can use the following as a basis. You need to replace the entries with the names Modeline, Driver and Modes with the correct entries for your system. Depending on your hardware, you may need additional entries, for example if your system has more than one ...


7

The new version of gnome-settings-daemon stores its configuration information in dconf rather than gconf. To do the equivalent of what you were doing on 11.04, try the following: Install the dconf-tools package, and then run dconf-editor. In the tree on the left, navigate org -> gnome -> settings-daemon -> plugins -> xrandr. Uncheck the active checkbox.


7

I managed this little basic script below that answers my question. Now, whether the external monitor is connected or not, Lightdm uses the right resolutions at the greeter stage. Nevertheless, this same script needs to be modified to be generic, in a way that the user wouldn't need to specify manually resolutions of its laptop and monitor screens. (Parse ...


7

The trick is to use the newer --rotate instead of -o which needs to be used with a --output argument: xrandr --output "$internal" --rotate "$xrandr_rotation" Examples xrandr --output LVDS1 --rotate left xrandr --output LVDS1 --rotate right xrandr --output LVDS1 --rotate normal


6

I tried a similar thing and after some debugging I think I figured out what's going on. Your script probably is run and probably does set the resolution correctly. However, since it is run by the login manager, it runs before Unity has finished setting up your desktop environment and Unity reads its own settings and resets the resolution to what you had. So, ...


6

alt+f2 gksu xkill you click on the window you want to close. Also you could try with terminal lets say banshee is stuck when you tried to listen an online radio station.. sudo ps -A|grep bans 10304 bla bla bla ^ the result of the command sudo kill 10304 you could try sudo kill -s kill 10304. a more easy way gksu gnome-system-monitor this is ...


6

Issue xrandr on the console will show you the names of different outputs available on your system (LVDS, VGA-0, etc.) and resolutions available on each: If you see the desired resolutions available for the output that you want (tv screen), set it via xrandr --output <output> --mode <mode> (example: xrandr --output LVDS --mode 1360x768) If your ...


5

.bashrc (as it name may suggest) is only executed on startup of a bash shell. You have to edit ~/.profile to apply changes to your graphical session. Note that this file is intended for setting environment variables and such. You'd better create a startup script to accomplish this task.


5

This is still an issue as of Ubuntu 12.10 released October 18, 2012. A bug fix for this seemed to be in the works so that at least there is an easier way to re-configure the key bindings, but it has since been marked invalid because this was supposedly fixed in gnome-settings-daemon. Ultimately this problem is supposedly due to some hardware vendors ...


5

First generate a "modeline" by using cvt Syntax is: cvt width height refreshrate cvt 1680 1050 60 this gives you: # 1680x1050 59.95 Hz (CVT 1.76MA) hsync: 65.29 kHz; pclk: 146.25 MHz Modeline "1680x1050_60.00" 146.25 1680 1784 1960 2240 1050 1053 1059 1089 -hsync +vsync Now tell this to xrandr: sudo xrandr --newmode "1680x1050_60.00" 146.25 1680 ...


4

Disclaimer: I do not know if it works for all graphic drivers. Intel driver here, in 13.04. First of all get the normal screen you have active: xrandr --current My outout is: Screen 0: minimum 320 x 200, current 1024 x 600, maximum 32767 x 32767 LVDS1 connected 1024x600+0+0 (normal left inverted right x axis y axis) 220mm x 129mm 1024x600 ...


4

Rather than executing the script before session begins, you can execute it as soon as session begins. For an end user, this does not make difference as scripts would have started executing when you see your session.The steps are as follows. Create a shell script and provide it necessary permissions. Open startup applications by searching in dash or your ...


4

I found that problem with ATI video drivers, with deactivated driver all works. Use xrandr --verbose to determine your ctrtc number? And try correct output syntax, e.g.: xrandr --crtc CRT1 --output CRT1 --brightness 0.7 other outputs: the Intel driver uses LVDS, VGA, TMDS-1 (TMDS-2, ...), TV the ATI driver uses LVDS, VGA-0 (VGA-1, ...), DVI-0 ...


4

Ok, just solved it. I typed in the terminal: xrandr --output VGA1 --mode 1280x1024 --rotate normal If you have the same kind of problem, you have to change "VGA1" with the right output (just type xrandr in the terminal to have a list of your your video outputs) and "1280x1024" with the resolution you want.


4

I was trying to change the default resolution of LXDE on Ubuntu (LXDE is also used in Lubuntu) and I found a solution for this problem. I also have Lubuntu installed and I've checked that this file actually exists which it does (Ijust tried this fix as well and it worked). So, the fix.... Open up a terminal, press ctrl+alt+t I'm guessing you have a ...


4

Thanks to Geppetvs for his suggestion, but I have one that is up and running and working very well. I have a Sapphire HD6770 fleX Edition card. I believe any of the ATI "Eyefinity" cards would work. Most of them require a DisplayPort monitor to support 3 displays, or a DP->DVI adapter. The Sapphire fleX cards can work with 2xDVI + 1xHDMI (which can be ...


4

First list your monitors and resolutions: xrandr -q Take note of your monitors names, example (I truncated the output so as to not list all the resolutions) bodhi@zenix:~$ xrandr -q Screen 0: minimum 320 x 200, current 1920 x 1200, maximum 4096 x 4096 DVI-I-1 connected 1920x1200+0+0 (normal left inverted right x axis y axis) 520mm x 320mm 1920×1200 ...


4

$ xrandr --auto From xrandr man page: --auto: For connected but disabled outputs, this will enable them using their preferred mode (or, something close to 96dpi if they have no preferred mode). For disconnected but enabled outputs, this will disable them.


4

Let me answer my own question; the answer is bizarrely involved. The trick is that the desired desktop behavior (which held in 10.04) is now (in 11.04) controlled by Compiz, which has a notion of "outputs": that is, screens to draw on. These are configured in the CompizConfig Settings Manager (package compizconfig-backend-gconf or -kconfig), in the ...


4

I have been trying to solve a similar problem for a while now and found a solution that works for me so hopefully it will help... I have an old aspire one AOA110 that I have broken the screen on too many times and after buying a new laptop decided that I would try to turn it into a HTPC but the external display I have is not recognised by X so I have had to ...


3

There is a not very satisfying solution I found that blinks for .1 sec. sh -c 'redshift -o -t 1600:1500 -l 53:15&' ;sleep .1; redshift -l 53:15 -x But it would be nicer if it would phase in from red to normal like it normally does using redshift. Edit: Well well, this'll have to do for now I guess.


3

The nvidia binary drivers do not support XRandR 1.2, and so the xrandr tool is very limited when working with the nvidia binary. You can pretty much only query the list of available modes and set one, not add new modes. So the failure of the xrandr tool is entirely expected. Secondly, the nvidia binary driver abuses the reported refresh rate to work ...


3

First, you should try to change the resolution using System->Preferences->Monitors, and then reboot. It's likely that it's stored somewhere and it will be restored it at login. If it doesn't work you can add the xrand command to the items in System->Preferences->Start up Applications. You will only need to add the last line: xrandr --output VGA1 --mode ...


3

Laying them out left-to-right is not the xrandr default, but the gnome-settings-daemon default. From gnome-settings-daemon 2.32 onwards, the last configuration should just be loaded from monitors.xml; so if you've done the vertical layout once, then next time it would automatically pick that up without kicking out Compiz. So are you running 10.04 Lucid by ...


3

xrandr needs to know which display you're talking about, typically via the DISPLAY environment variable root (which udev runs as) has no default DISPLAY set; even if he/she did, su -c does not preserve the environment by default So pass it along explicitly to bash, and that should solve your problem, e.g.: su -c "DISPLAY=:0.0 bash -x /usr/bin/think-dock ...


2

After hacking away at it, I finally got it to work.. I was never able to get this to execute from LightDM but adding the sleep option and adding it to startup applications worked #!/bin/bash sleep 5 XRANDRexternal="xrandr --output HDMI1 --off --output LVDS1 --off --output DP1 --mode 2560x1600 --pos 0x0 --rotate normal --output VGA1 --off" ...


2

Having just gone through the horror of installing nvidia drivers, I'd venture a guess and say that they didn't install quite right. Some of the symptoms you describe are similar to what I battled. I Couldn't get the drivers to function properly using the nvidia-drivers package. I had to do a binary install. I used these instructions here: ...



Only top voted, non community-wiki answers of a minimum length are eligible