Tag Info

New answers tagged

0

You can find it in /user/share/X11/ If there is no xorg.conf file there, feel free to create one. In some cases xorg.conf is not needed.


3

Found an easy fix xrandr --output DVI-D-0 --mode 1920x1080 --rate 144


-1

Run glxinfo |grep string If you get this OpenGL vendor string: VMware, Inc. Then, it looks like I had exactly the same problem: the intel cpu-integrated graphics didn't use intel drivers. I fixed it with the following: Be sure you have installed intel proprietary drivers. In case you have the drivers installed - jump to step 2, in case you don't, go ...


5

Install the package xautomation, we need the command xte sudo apt-get install xautomation Install the package x11-utils, we need the command xev sudo apt-get install x11-utils Check the code for the two mouse buttons. Start the command xev in a terminal: xev Move the mouse in the new window Press your extra mouse buttons In my case, note the ...


1

Welcome to Linux! :) You can safely omit the two dashes in list and all other actions such as get and set. The program's behavior will stay the same and i find it more comfortable to write. Finally, a quick tip: read very carefully every output you get from your machine and read a lot of man pages, especially when you are unsure about the sintax of certain ...


2

You are getting all those "permission denied" messages because the directories are not readable by you and you are not running as root. xorg.conf would be in a readable/traversable directory anyway (/etc/X11), so if you didn't find it, it doesn't exist (but read on). If you don't want to see all the permission denied messages, just redirect stderr to ...


1

Use sudo: sudo find / -name xorg.conf sudo allows a permitted user to execute a command as the superuser or another user. For more info: man sudo (you can quit with Q)


2

Try vokoscreen. It's free, and you can get it from the Ubuntu Software Center or in a terminal: sudo apt-get install vokoscreen You can change the filetype easily, the files aren't too large, and it can also record the computers sound.


0

It is called "Kernel Mode Setting" or KMS or the kernel frame buffer Kernel mode-setting (KMS) means that the kernel is responsible for setting up and changing the display mode: resolution, frequencies and color depth. Kernel modesetting and memory management describes some aspects of KMS along with Fedora specific information. KMS as a Linux feature was ...


0

Welcome to the world of Linux :) Now, if I understand correctly, you just mis-typed the command. Take note that it is xsetwacom --list devices (note the two minus symbols and "list devices" has a space in between). Reading your question, you might want to look up how to set a keyboard shortcut to toggle between touch on and touch off. I believe that ...


0

I have exactly same laptop. There is a video driver, but it works only with xorg version not higher than 1.12. It means that it won't work on Ubuntu higher than 12.04. The driver works well, but without 3D acceleration. It appeared that it is not possible to make this driver for newer versions of xorg, since the adapter does not support some features. I have ...


1

Generally speaking it is done by installing packages like -lts-, e.g. linux-generic-lts-utopic for Ubuntu 14.04. With kernels it is quite easy. But with graphical stack it is not that straight forwared because of dependencies, especially on 64-bit systems. Commands given in that article are not quite correct in many cases and can remove a lot from you ...


1

I found a solution : I add a file called 10-monitor.conf into /usr/share/X11/xorg.conf.d/ folder with the following content : Section "Monitor" Identifier "Monitor0" Modeline "4320x900" 251.07 4320 4336 4352 4480 900 903 912 934 -HSync +VSync EndSection Section "Screen" Identifier "Screen0" Device "DVI-I-1" Monitor "Monitor0" DefaultDepth 24 ...


1

You can find packages containing a file using the web interface http://packages.ubuntu.com Here's the result for all packages containing Xlib.h: http://packages.ubuntu.com/search?searchon=contents&keywords=Xlib.h&mode=exactfilename&suite=trusty&arch=any


0

There might be a problem with your Desktop Environment. Use the tty login to install an alternative DE, such as gnome or KDE. Then try logging in via lightdm or gdm(whichever you use) and install the Desktop Environment that you are comfortable with. I had the same issue a while back and I managed to solve it. Hope this helps!


1

So, finally, the answer was following. Discovered that the driver could not get the EDID from my beamer as into /var/log/Xorg.0.log file I got it from windows 7 application Phoenix EDID Designer which can be run with wine, exported on a raw format in a file put into /etc/X11/myBeamerEDID.raw added it into my xorg.conf into the device section Section ...


0

There is actually an easier way of solving this. In your user profile set the displays exactly how you want them. Then copy ~/.config/monitors.xml to /var/lib/lightdm/.config This will force lightdm to use the exact same setup as your user profile.


1

Ah, the solution was relatively simple, instead of running $ startx /usr/bin/xterm -- :1 Running $ startx /usr/bin/xterm -- :1 vt$(tty | sed -e "s:/dev/tty::") Will prevent X from breaking when I switch TTYs.


0

The driver is being replaced. Run apt-cache search video-dummy xserver-xorg-video-dummy-lts-quantal - Transitional package for xserver-xorg-video-dummy xserver-xorg-video-dummy-lts-raring - Transitional package for xserver-xorg-video-dummy xserver-xorg-video-dummy-lts-saucy - Transitional package for xserver-xorg-video-dummy ...


0

I have tried several re-installs since posting the original question and I have been able to get my system running with 3840x2160@60hz. This post is to help others who might have the same problem. One of the things that concerned me about my setup is that I can't make the displayport output the primary monitor on the system if the DVI ports are used. The ...


0

try the following command: sudo dpkg-reconfigure lighdm a screen will appear asking you to choose between display managers (if you have more than one).


0

Why are you using xorg.conf to set the resolution and not Settings -> Display? To get it working again press ctrl+alt+F1 to open a tty, then login. Remove the xorg.conf file you created and reboot. If the resolution you want is missing use: cvt 1920 1080 60 to create a new modeline. xrandr --newmode "1920x1080_60.00" 173.00 1920 2048 2248 2576 1080 ...


0

Luckily, I could fix it myself. First I purged the nvidia drivers again. Then I did a sudo apt-get install --reinstall lightdm xserver-xorg-lts-utopic xserver-xorg-core-lts-utopic Rebooted; and at least the nouveau driver is up and running again.


0

I solved it my self.It is due to my user old profile.The old profile uses old ubuntu settings and it have problems so I have rested profiles with help of following forum http://ubuntuforums.org/showthread.php?t=1105433.I have also reinstall lightdm


1

You can use grub to enter a root shell: Press e when in grub and edit the line looking something like: linux /boot/vmlinuz root=/dev/sda4 ro quiet splash to linux /boot/vmlinuz root=/dev/sda4 ro single. Alternatively you can use ubuntu recovery and launch a root shell from there. Then just revert the changes you made to /etc/X11/xorg.conf and reboot.


0

Try sudo apt-get install nvidia-current As that will install nvidia drivers.


0

I've got an ASUS laptop with Nvidia Optimus GM820 and I installed Kubuntu 15.04 with Plasma 5.2 (5.3 version seems buggy in my computer, with several crashes in configuration options and others...). According with Kubuntu Drivers Settings, my nvidia recommended drivers was 340.47. If I selected this choice, I've got a black screen instead of my login screen, ...


0

Not sure if you are using DVI or HDMI to connect (my machine reports both as HDMI in xrandr), but it seems that Intel HD graphics is limited to DVI single-link. As you noted, the highest it will report is 1900x1200@60Hz. As far as I can tell, current Intel HD graphics do not support DVI dual-link. However, it may be possible to enable 2560x1440@30Hz over ...


0

I finally fixed this problem. The problem came from the grub.This is my found way. #/etc/X11/xorg.conf Section "Device" Identifier "card0" Driver "intel" VendorName "INTEL Corporation" #Option "NoDDC" EndSection Section "Monitor" Identifier "fake_monitor" VendorName "Unknown" HorizSync 30-83 VertRefresh 56-75 Modeline "1920x1080_60.00" ...


1

With Xorg 1.17 and later, -nolisten tcp is the default, and you need to explicitly state -listen tcp to enable tcp connections.


0

Try to rebuild your kernel image: $ sudo update-initramfs -u Sometimes it usefull. Is there also old kernel on your installation to boot? Please try to boot with old kernel version and image.


1

I guess since you have a blank screen you have little information to give us. Here's how I suggest you start: CTRL-ALT-F1 should get you to a virtual console so that you can actually see stuff (even if X is not working). If this doesn't work, then the problem is likely more than just the X server. You should see something like: Ubuntu 15.04 hostname tty1 ...


0

I have found the command, because now the graphic manager is not Lightdm or KDM anymore. The new graphic manager is SDDM and the command to stop it is: sudo systemctl stop sddm.service


1

From howtogeek.com which has a good answer for any OS. For Linux (including Ubuntu): setxkbmap -option <OPTION> Where <OPTION> can be for example of: caps:none – Disables Caps Lock. caps:super – Caps Lock becomes an additional Super (aka Win key). caps:ctrl_modifier – Caps Lock becomes an additional Ctrl. caps:numlock – Caps Lock becomes an ...


1

Try running xhost +localhost in your terminal, and then running the command again. This lets all users on your system (i.e. root) open windows on your screen. Make sure to use +localhost and not simply +, as it's more secure to just allow connections from localhost than from anywhere. To make this permanent, edit the ~/.xinitrc file like this: Run gedit ...


0

It is recomended to purge before installing new drivers. For example, for a 343: sudo apt-get remove --purge nvidia* sudo service lightdm stop sudo add-apt-repository ppa:xorg-edgers/ppa sudo apt-get update sudo apt-get install nvidia-343 sudo service lightdm start sudo reboot You are not explicit on this, so I am just checking. If you do not come up ...


2

The 'solution' for me is disabling the Intel integrated GPU. There are two ways to go about this: UEFI/BIOS Disable the Intel GPU in your UEFI/BIOS settings. How to go about this differs per motherboard. For an Asrock Z77 Pro4 it meant setting: Advanced > North Bridge Configuration > IGPU Multi-Monitor: Disabled On other motherboards it can ...


0

Try to run nvidia-xconfig after nvidia drivers installation. Then reboot.


3

First I switched to a console (CTRL-ALT-F1). Then I removed all nvidia stuff with sudo apt-get autoremove --purge nvidia-* and reinstalled the nouveau driver using sudo apt-get install --reinstall xserver-xorg-video-nouveu then sudo reboot I know this is probably not what both of us want but it is still better than no desktop at all... My Setup ...


0

Anyone looking to fix this, read on. In the gridengine-qmon package I do not find the old SGE help file called qmon_help.ad. There is just the manual page. The manual page lacks the context of the old dialogs, and it seems to be missing specific information I need for configuring the queue instances or the host resources (not sure which). There is an X11 ...


0

It turned out I hadn't looked hard enough. In my Xorg log file, I found the following entries: [ 23.735] (II) LoadModule: "glx" [ 23.762] (II) Loading /usr/lib/x86_64-linux-gnu/xorg/extra-modules/extra-modules.dpkg-tmp/libglx.so [ 23.822] (EE) Failed to load /usr/lib/x86_64-linux-gnu/xorg/extra-modules/extra-modules.dpkg-tmp/libglx.so: ...


1

First enable the Ubuntu Partner Software sudo add-apt-repository "deb http://archive.canonical.com/ $(lsb_release -sc) partner" Then update your software list sudo apt-get update You can get a list of installable fonts by searching for packages beginning with fonts- and xfonts-. apt-cache search fonts | grep '^xfonts-' Now you can install what you ...


0

Through trial and error, I managed to fix this on my own, although I'm not sure what my exact steps were. I identified a total of 7 different nvidia-* packages, and decided to try each one, starting with the most recent, nvidia-349. I installed the xorg-edgers PPA, which contains more recent versions of these drivers, and manually checked to see if they ...



Top 50 recent answers are included