Tag Info

Hot answers tagged

10

Excellent question. Workloads The /usr/share/xdiagnose/workloads directory has a set of workloads designed to exercise your graphics system to trigger lockups. $ ls /usr/share/xdiagnose/workloads/ README do_monitor_rotation_loop do_chws_loop* do_screensaver_loop* do_cpu_spin_loop do_video_loop* ...


3

There is no syntax to refer to individual monitors in a screen in a display string. However, you might be able to use the --geometry option to do what you're after. If you have two monitors side by side and the first is 1920 pixels wide, then the following should position a terminal window at (50,50) on the second screen: gnome-terminal ...


2

Until the compiz xinerama bug is solved, select classic ubuntu (no effects) on logon to make xinerama work.


2

I found the answer myself. It is: CTRL+ALT+F5. Then sudo aticonfig --xinerama=o


2

When starting gnome-mplayer, you can try exporting the display: export DISPLAY=0.0; gnome-mplayer (change 0.0 to the desired display).


2

Sorry to say, but Xinerama no longer works on the -intel driver, since the Feisty/Gutsy timeframe when the Intel developers introduced XRandr. Maybe if you explain what you're trying to achieve with the dual displays, someone could suggest an alternative approach.


2

I doubt it. nVidia Optimus simply does not work on Linux distributions because of the design of the X server which cannot handle it (yet). The issue that nvidia has fixed possibly applies to certain hybrid graphics setups with a hardware mux or detection of the nvidia card on certain muxless machines ...


2

Have you tried disabling the "Place windows" plugin in the Compiz configuration? This plugin was responsible for a similar issue in my two-monitor configuration. See also this question.


2

There is an error in your xorg.conf: EndSectiSection "Monitor"


1

Presumably ldconfig is being called somewhere, and libXinerama.so.1.0.0.back sorts after libXinerama.so.1.0.0 so it is being selected as the newest version of the library. Why exactly do you need to patch the Xinerama extension's client library in the first place?


1

it turns out that Unity and Xinerama do not play nice together anymore, as Xinerama and Composition cannot be run simultaneously. until rrandr takes over multi-gpu stuff, or until twinview gets much smarter, multi-gpus will not be possible for most newer window managers (Gnome3 suffers from this same problem). i tried backing down to ubuntu classic to get ...


1

i was able to get this working thanks to a coworker. here is my xorg.conf file. this required gnome2 and the proprietary nvidia drivers. Section "ServerLayout" Identifier "Layout0" Screen 0 "Screen0" 0 0 Screen 1 "Screen1" RightOf "Screen0" Screen 2 "Screen2" RightOf "Screen1" InputDevice "Keyboard0" ...


1

There is no way for Xinerama to work with 3d acceleration right now, it may possibly work in the future. For the second monitor, the window manager is active, but I'm assuming your using unity, unity can't be forced onto two screens, neither can gnome shell to my understanding. There just to new right now, in the future this will be different. What you can ...


1

It's a workaround for themes not applying in Cinammon with Xubuntu, but you could try: setting a GTK3 theme as default in XFCE configs, and, login again in Cinnamon from here. Different problem, but it might work to get the theme to apply. I don't know what DE you're using, but it's definitely not Unity.


1

Try including option "RenderAccel" "true" in your "Device" sections.


1

It works I updated to the latest drivers and updated my xorg.conf. This is my xorg.conf file: nvidia-settings: X configuration file generated by nvidia-settings nvidia-settings: version 302.17 (buildd@rhenium) Sun Jun 17 23:26:33 UTC 2012 Section "ServerLayout" Identifier "Layout0" Screen 0 "Screen0" 0 0 InputDevice ...


1

Well I did a lot of search and it seems that Unity doesn't work with ATI Drivers for the moment. So I went to KDE... I have downloaded kUbuntu and installed. After, I went to terminal by typing Ctrl+Alt+F1 and downloaded the files needed: sudo apt-get install module-assistant sudo m-a prepare I have stopped lightkdm sudo /etc/init.d/lightdm stop ...


1

Well, in the end, the answer was stupidly simple. cp /etc/X11/xorg.conf ~/xorg.backup sudo rm /etc/X11/xorg.conf sudo shutdown -r now And, after this, I can change the screen layout normally.


1

if you wanted to try another easy/reversible option, you could make a copy of your xorg.conf, and then change "true" to "off" for xinerama. these commands should do it: cp /etc/X11/xorg.conf ~/xorg.conf cat ~/xorg.conf | sed 's/true/off/g' > ~/xorg.conf.new sudo cp ~/xorg.conf.new /etc/X11/xorg.conf if something goes wrong, you can copy the original ...


1

Xfce 4.10 has only limited support for multiple monitors. The upcoming 4.12 is better at that (see design/xfce4-settings/display for details). You can try installing the (unreleased) 4.12 from ppa:xubuntu-dev/xfce-4.12 to see if it fixes your problems. Additionally, did you try to set up the monitors properly by using arandr? Or perhaps you simply need to ...


1

It sounds like you have used the option "New X screen (requires X restart)" in the nvidia-settings when configuring your monitors. That would explain the "x" cursor. Indeed, you have 3 "Screen" sections in your xorg.conf. If you're looking for a single desktop that spans all 3 screen, you only need a single "Screen" section. Bascially, what your current ...


1

You can determine if it is enabled by viewing your /etc/X11/xorg.conf file. It will look something like this: Section "ServerLayout" Identifier "Layout0" Screen 0 "Screen0" 0 0 InputDevice "Keyboard0" "CoreKeyboard" InputDevice "Mouse0" "CorePointer" Option "Xinerama" "0" EndSection Notice the second last line ...


1

I have a dual monitor setup too and I'm using the open source nouveau driver. I haven't seen any performance issues when playing flash and it works like Twinview. If you don't want windows to open on your secondary monitor you can disable it temporarily via System->Preferences->Monitors.


1

In the ServerLayout section in your xorg.conf you should add something like this: Section "ServerLayout" Option "Xinerama" "on" Option "Clone" "off" EndSection That should be enough to make sure xinerama works properly. If you don't have it already, you should add something like this aswell: Section "ServerLayout" Screen 0 "first-screen" ...


1

As far as I know this is a limitation of the DBE and double buffering is not possible with Xinerama There is a discussion here with a link to the source code http://www.nvnews.net/vbulletin/showthread.php?t=110660 I've not found anything more up to date.



Only top voted, non community-wiki answers of a minimum length are eligible