Hot answers tagged

19

I too had this problem after upgrading to 14.04 The solution mentioned here worked wonders for me, https://bugs.launchpad.net/ubuntu/+source/xorg-server/+bug/1278012/comments/12 A workaround for ubuntu 14.04 with nvidia driver is to disable backing store in xorg: Make sure you have the "-bs" option in lightdm config file: cat ...


15

Basic Support The remote itself is recognized out of the box with no set up, however if you are running 10.10 the X server needs to be patched or it crashes (see below for instructions). Unfortunately there is no support at all for versions earlier than 10.10, which includes older versions of XBMC Live. If you use 11.04 and later all you need to do is ...


11

We can create a shell script which would simulate mouse movement at a specified interval (only when XBMC is running) and prevent your screen from turning off. Follow the steps: Install necessary tools: We would need xdotool to do this job for us. Install it by running the following command in terminal: sudo apt-get install xdotool The Script: Save ...


9

For Ubuntu 12.04 and newer Click on the button: or by simply opening a terminal and typing sudo apt-get install xbmc. After the release of Ubuntu 12.04 updates should be available in the stable XBMC PPA above and XBMC can be updated by adding the PPA and updating your system. sudo apt-add-repository ppa:team-xbmc/ppa sudo apt-get update && ...


8

The main XBMC PPA has been updated with the latest stable releases. What are PPAs and how do I use them?


8

A very simple solution is caffeine. Caffeine is a 'status bar application able to temporarily prevent the activation of both the screensaver and the "sleep" powersaving mode.' Enabling it is as easy as clicking the status bar indicator, but you can also set it up such that it automatically disables the screensaver when you start xbmc. See the screenshot ...


8

Just to sum up to the Brenden's answer, the real problem is with the libsdl1.2 package, as stated in this bug report. The solution is ready, but somehow isn't available on default Ubuntu package sources yet (at least not for me). So, a way to solve this is to import the developer PPA and install the patched package directly: sudo apt-add-repository ...


7

Run: gedit ~/.config/autostart/xbmc.desktop write in file [Desktop Entry] Type=Application Exec=xbmc -d 5 --standalone -fs Hidden=false NoDisplay=false X-GNOME-Autostart-enabled=true Name[en_En]=xbmc Name=xbmc Comment[en_En]= Comment= save file and restart system. XBMC will start with five second delay, in standalone mode and full screen mode.


7

Remap the Power button on the home screen to quit xbmc instead of showing the shutdown menu: You should modify the Home.xml file in your skin folder in /usr/share/xbmc. For me (Frodo RC3 with the Confluence skin) this is /usr/share/xbmc/addons/skin.confluence/720p/Home.xml. In this file you need to replace the line (in my case line 1067, see bottom of the ...


7

This seems to be a bug in the XBMC package for ubuntu I'm not sure what version you have installed, but the version from the PPA* doesn't seem to have it on my system. This can be because I have different settings in ubuntu of course, so your milleage may vary. If you don't, you can try to use XBMC as a session (on your login-screen, press the ubuntu logo ...


6

I was searching for the same. I found you question first, but after searching a bit more I found a working answer and came back here to share. The page that has the answer is located: http://blog.burlock.org/xbmc/77-fullscreen-xbmc-without-locking-the-mouse A copy and paste of the basics: First, you'll need to install a clever little application called ...


5

It seems it is a problem of mapping, or something. Just run sudo dpkg-reconfigure lirc, and in the first screen (Remote control configuration:), select Windows Media Center Transceivers/Remotes (all). In the second screen (IR transmitter, if present:), you can select None. Now, irw can output text: $ sudo irw 000000037ff07be1 00 KEY_UP mceusb ...


4

Follow this answer to add the Software Source ppa for XBMC. Then edit the software source and change the distribution from natty to maverick as per this picture.


4

XBMC is now included in the Ubuntu Software Centre for Ubuntu 12.04. Linked Question: How do I install XBMC?


3

The fix: sessionfile=`find "${HOME}/.dbus/session-bus/" -type f` export `grep "DBUS_SESSION_BUS_ADDRESS" "${sessionfile}" | sed '/^#/d'` Now, try running your command again. gsettings set org.gnome.desktop.screensaver idle-activation-enabled false Stack Overflow is awesome. :)


3

The easiest way to get the fix is to use the xorg edgers PPA: https://launchpad.net/~xorg-edgers/+archive/ppa The PPA is built for testing and for fixing obscure bugs with certain releases. It currently has xorg version 2:1.9.2.901+git20101129 and you may be looking for 902 instead of 901, but try it because it'll get you most of the way there and it's ...


3

I am not sure who to point the finger at, but what essentially happened is that NVIDIA provided one API to do this with their cards and ATI provided one for theirs. As you can guess they are not the same, so in order for programs to take advantage of this, they have to be coded to support it. From what I can find, this is not currently in the stable ...


3

create .xprofile in your home directory. gedit .xprofile and paste line, xrandr --output TV --mode 1024x768 --rate 60 Save file now give execution permission chmod +x .xprofile


3

Search for Display in Unity. You can set your screen resolution here.


3

For Ubuntu precise (12.04), raring (13.04), saucy (13.10), trusty (14.04) use version 0.27: sudo add-apt-repository ppa:mythbuntu/0.27 For Ubuntu precise (12.04), quantal (12.10), raring (13.04) and version 0.26: sudo add-apt-repository ppa:mythbuntu/0.26 For Ubuntu lucid (10.04), natty (11.04), oneiric (11.10), precise (12.04), quantal (12.10) and ...


3

I had a small issue getting it to run automatically too, doing the same thing. My issue was that it would not start full screen, even when passing it the -fs argument. As Bruno Pereira has suggested, using the XBMC session works great. Click the little Ubuntu symbol next to your username when you log in and select XBMC. If you have set your computer to ...


3

A better option is to make XBMC your session. You won't get into unity etc, so it's all a bit cleaner. if you auto-log in, then logout of your current session. on the log-in screen, press the ubuntu logo next to your name choose 'XBMC' log in. This makes XBMC go all fullscreen when you (auto?) log in.


3

I believe NTFS and exFAT are your only solution. exFAT wasn't working on my Ubuntu at first, but it only needed to be installed to work. sudo apt-get install exFAT The linked Wikipedia article has some good information about it. In your comment you said: NTFS isn't an option when creating the partitions in the XBMCbuntu installation wizard. ...


3

I had the same problem, that's why I wrote a little script to start xbmc that first gets the current volume, then sets the system volume to 100%, starts xbmc, and after exiting, resets the volume to the original level. That way controlling the volume in xbmc is the same as controlling the system volume since the system volume is on max. Here is the script: ...


3

You can create a script and put it in the /etc/NetworkManager/dispatcher.d folder; the scripts in that folder will be executed every time a connection is (dis)established. The number with which you start the filename determines the order of execution, so we will give our script the number 99 to make sure that it is executed last. Run the following command ...


3

Screen tearing can also be caused by xfce compositing or window manager with compositing that doesn't suppport vblank sync! To fix the issue i used compton, which completely stops the tearing, it's also quite easy to configure, i followed this guide and i haven't had any problems.


3

xset -display :0 s off xset -display :0 -dpms xset -display :0 s noblank I run this on startup (add it to /etc/rc.local) and it works fine. ;) :0 of course has to be the display you want to keep from turning black.


2

If you want to compile xbmc in Ubuntu, the following worked for me: Dependencies sudo apt-get install git-core make g++ gcc gawk pmount libtool nasm yasm automake cmake gperf zip unzip bison libsdl-dev libsdl-image1.2-dev libsdl-gfx1.2-dev libsdl-mixer1.2-dev libfribidi-dev liblzo2-dev libfreetype6-dev libsqlite3-dev libogg-dev libasound2-dev python-sqlite ...


2

i got the same remote, im working on getting it to me seen in lirc but in the mentime, you can start mapping the keys right away in the keyboard.xml the power key is called KEY_SLEEP if you add this to the xml under global, - - - ActivateWindow(shutdownmenu) you will now notice that pressing the button not brings up the shutdown menu. You can find all ...


2

I don't know if you are still having issues with LIRC, but I found a device that acts as a IR Receiver and works without using LIRC. It is called FLIRC and you can set it up with an easy GUI. I would recommend using the full keyboard layout and you should be able to map every button on your remote to a keyboard command supported by XBMC. It is about $25, but ...



Only top voted, non community-wiki answers of a minimum length are eligible