Tag Info

Hot answers tagged

11

On a standard Ubuntu installation using GNOME and network-manager the WPA key is stored in the GNOME keyring. This will be restored with /home. You can test if this is so in your settings by temporarily deactivating keyrings in ~/.gnome2 (make a backup before you do so!). The only other location I can think of where Wicd could get a WPA key from is ...


9

Install the dconf-tools package and then open dconf Editor: Navigate to desktop ➜ unity ➜ panel and add 'Wicd' to systray-whitelist : Log out and then back in. You should see the wicd icon the panel:


8

If you did not format your system, and installed on top of an old installation, then it is quite likely that your old settings were brought over (including settings in /etc). Whatever is not installed on the live CD would have been left alone, which is explains the apparent magic bunnies result that you experienced. It's less of a mysterious answer :( - but ...


5

This might be a symptom of this bug: https://bugs.launchpad.net/ubuntu/+source/wicd/+bug/1132529 The solution that worked for me was to run the following commands from the command line (see comment #22 from above link): sudo service wicd stop rm /etc/resolv.conf rm /var/lib/wicd/resolv.conf.orig ln -s /run/resolvconf/resolv.conf ...


4

Please verify that your driver is iwlwifi. lsmod | grep iwl If you wish to disable N speeds in order to connect seamlessly, add to one file: gksudo gedit /etc/modprobe.d/iwlwifi.conf At the end of the file, add a new line: options iwlwifi 11n_disable=1 Proofread, save and close gedit. After a reboot, you should be all set. If you are able to connect ...


3

Not fixable and no workaround. Only way out is to dump unity and go to Gnome classic. See the bug report. Update: Now marked "Fix released" but still doesn't work.


3

The problem is with your software sources and specifically where you are trying to get them from, the first error gives you the clue. Could not connect to archive.ubuntu.schoolnet.lk:80 (103.29.60.18). - connect (111: Connection refused) Open Ubuntu Software Center -> Edit -> Software Sources. Try changing your software sources to another server and ...


2

It all depends on what type of VPN you want to connect to, and they are not as integrated as NetworkManager. In my experience, kvpnc tends to work well and supports a few VPN systems, although it requires the installation of additional dependencies from a standard GNOME desktop because of QT and KDE libraries. If you're having issues with NetworkManager, ...


2

Your wireless device uses the driver rt73usb. Some drivers have trouble with mixed mode WPA and WPA2 networks. Please try setting your router to WPA2 only. Some drivers have trouble with 80211N; try setting your router to B and G speeds but not N. Finally, you might do: gksudo gedit /etc/modprobe.d/rt73usb.conf Add a single line: options rt73usb ...


2

A little late, but as promised, here's the edited encryption template. name = TUSecure author = atiketemola version = 1 require identity *Username password *Password protected password *Password ----- ctrl_interface=/var/run/wpa_supplicant network={ ssid="$_ESSID" proto=RSN key_mgmt=WPA-EAP pairwise=CCMP eap=PEAP ...


2

OP has answered the question in a comment; Finally found out how to get network manager to run. The command is nm-applet for any one else who has trouble. network manager works! I have never seen it working before. it is quite exciting. I have filled a bug on evolution not seeing the network when WICD is used.


2

If the only common thing between the old computer and the new computer is within $HOME then the key must be in $HOME somewhere. So the question is really, which file is it in? You could find out by getting a list of the file common to both machines (find $HOME -type f should do from your description). First backup these files and then remove them. Check ...


2

I'm having the same problem, i believe the culprit is dhclient, which gets run automatically by wicd. whenever the dhcp lease expires, dhclient overwrites /etc/resolv.conf with what it gets from the the dhcp server. to verify that this is indded your problem, do "ps aux | grep dhclient", you should an entry pop up, referencing a configuration file for ...


2

You can add your command in the file /etc/rc.local (before the exit 0) or create a startup script and put it in /etc/init.d


2

I suggest you do: sudo vim /etc/network/interfaces Add the wireless stanzas similar to: auto lo iface lo inet loopback #auto eth0 iface eth0 inet dhcp auto wlan0 iface wlan0 inet static address 192.168.1.100 netmask 255.255.255.0 gateway 192.168.1.1 wpa-ssid <your_network> wpa-psk <your_secret_key> dns-nameservers 8.8.8.8 192.168.1.1 ...


1

The wicd-daemon package should add a hook for pm-utils to handle this with the file: /usr/lib/pm-utils/sleep.d/55wicd I'm pretty sure pm-utils gets pulled in by default as part of ubuntu-desktop (via some other things) but if you removed network-manager and/or other gnome parts then perhaps you lost it somewhere along the way. Try: sudo apt-get ...


1

I had the same problem with Natty and that was just a dhcp problem. A static ip adress fix the problem in my case. Hope that will be helpful for someone ...


1

Apparently this is a limitation of the Unity design. See this bug report.


1

First of all, the loopback entries must be included. I suggest this /etc/network/interfaces file: auto lo iface lo inet loopback auto eth1 iface eth1 inet dhcp wpa-ssid <my_wifi_name> wpa-psk <my_pass_HEX> Now get the system to re-read and use the changes: sudo ifdown eth1 && sudo ifup -v eth1 The '-v' is for verbose; some ...


1

Dear Mathieu Thank you for your reply. The problems I have are bugs that are widely reported. Network manager does not see wireless networks. On every machine I have put it on after every install of Ubuntu network Manager reports there are no wireless networks visible. If i remove network manager and install WICD then those networks are visible and ...


1

Try restarting the network manager: sudo service network-manager restart


1

For Ubuntu 12.04 use ['All'] in desktop ➜ unity ➜ panel (delete all others) worked for me :)


1

If you run sudo dhclient -r sudo dhclient do you get a new IP address? This will drop your current lease and attempt to acquire a new one. You might also be able just to restart networking, rather than your whole machine: sudo /etc/init.d/networking restart


1

I had a similar issue that I think I finally resolved. I did several things to try and fix the issue but I think I finally got it. I uninstalled then reinstalled Network Manager. I was able to get connected without it but I didn't really care for the alternatives or using the command line. I also, not totally recalling the reason for this, removed eth0 ...


1

WICD has a configuration file for all of the networks that have ever been connected to in /etc/wicd/wireless-settings.conf this will contain a set of entries for every bssid (base station MAC address) that you have connected to. So when wicd sees a network that it has connected to before it will get the key values from this file. There is also ...


1

I'm having the same issue. I've found that if I disconnect and reconnect to my wifi network, or if I reboot the machine, I can get one or two webpages to load, but then DNS stops working again. For the record, just because you can ping by IP, that doesn't mean that DNS is working. DNS is the service that turns names into IP addresses. Something odd that I ...


1

Unfortunately this is another "not an answer". It is just a problem isolation suggestion. You've already confirmed via ping that IP networking appears to be working correctly on your laptop. The next thing I would try is using someone else's DNS servers. I do not know why the default DNS servers provided by an ISP sometimes tend to flake out, just that they ...


1

Resolution discovered. /etc/resolv.conf is being deleted. How or why is undetermined. It may be due to the fact that changing DNS in WiCd does not result in resolv.conf being changed. Thanks to all for the suggestions.


1

Same problem, router and local DNS addreses were OK but I could only access websites through direct IP adressing. Somehow /etc/resolv.conf was patched and the first (of 3) nameservers had an IP6 adres while my internetprovider does not offer IP6 yet. After deleting the IP6 address the issue was solved.



Only top voted, non community-wiki answers of a minimum length are eligible