Tag Info

Hot answers tagged

81

For WebGL to work in Google Chrome (and Chromium), Here are the steps to enable WebGL in Google Chrome. Step 1: Open Google Chrome Step 2: Type chrome://flags in the address bar Step 3: Press Ctrl + f and type ” Rendering list “, “Override software rendering list” should come up, Now click on Enable and restart the browser. Step 4: Completely kill ...


8

Install driconf from the software center . Press Alt + F2 and type driconf and press enter . Change Enable limited ARB_fragment_shader support on 915/945 from No to Yes by clicking on the button next to it


8

WebGL on Google Chrome, it is available BUT not on Linux, actually there's a lot of questions regarding this in Google groups and the Chromium issue tracker. This happens in both x86 and x86-64 versions. Running google-chrome --enable-webgl --in-process-webgl or google-chrome --enable-webgldoesn't have any effect on the browser. get.webgl.org Mentions ...


7

As the title does not mention NVidia, (and for those who can run WebGL on Firefox but can't on Chrome) another option is to try enable Override rendering software list in chrome://flags Hope it helps


6

Actually it says there you need a Browser that supports WebGL, not openGl. As you can see in the following links, no officially released version of Firefox, Chrome or Opera support WebGL at 100%. The nightly builds do but they still need work: http://www.khronos.org/webgl/wiki/Getting_a_WebGL_Implementation http://wakaba.c3.cx/w/webgl.html ...


5

It is my understanding that it is already enabled. I have checked the aquarium out with Firefox 5 right now. Works perfect. It was in Firefox 4 that you needed a command to activate WebGL (Although the programs ran horribly). On Firefox 5 WebGL is much better. Not as good as Chrome of course but it is catching it up very fast. If you are still having ...


4

Firefox has WebGL enabled for Linux but only the NVIDIA proprietary driver is on the whitelist. Reference: https://wiki.mozilla.org/Blocklisting/Blocked_Graphics_Drivers#On_X11 You could try bypassing that block or use Chromium if you want to see if WebGL is possible on your hardware.


4

I don't know why the driver is on the blacklist, but you can do what's suggested: try running MOZ_GLX_IGNORE_BLACKLIST=1 firefox. If this works, you can modify the .desktop file /usr/share/applications/firefox.desktop and change the line Exec=firefox %u` to Exec=env MOZ_GLX_IGNORE_BLACKLIST=1 firefox %u


3

Successfully have it running with both intel and nvidia graphics running by following instruction from here: http://askubuntu.com/questions/36930/how-well-do-laptops-with-nvidia-optimus-work/36936#36936 Did a test on glxinfo | grep OpenGL and optirun | grep OpenGL, both working. Eventually the webgl issue for chrome is by misconfiguring the ...


3

no. your display has (nearly) nothing to do with the video playback speed. It's more that the free drivers don't speed up video decoding, while the proprietary does. It'd be good to know which graphics chip you actually have.


3

It already does. As ohaal commented, it's already supported. Supported operating systems Windows Vista/ Windows 7/ Windows 8 (Windows 7 or later recommended) Mac OS 10.6 or later Linux Chrome OS [...] Check to see if WebGL is enabled by by navigating to chrome://gpu/ in your Chrome browser. Try out some of the demos to see ...


2

How about just enable "Override software rendering list" in chrome://flags, it works in my chromium 18.0.1025.168.


2

Friends, Fixed the issue. 1 - Did a clean re-install of ubuntu 12.10 Started with the login screen problem first, but now i am not an amateur anymore so handled it with nomodeset. 2 - Unity was really slow. Yeah I know this so installed Gnome. 3 - Installed the NVIDIA*.173.14.36.run downloaded from Nvidia drivers website. Lost the login screen again. ...


2

There are a bunch of successful reports for the Asus 1215N with bumblebee. You can use the nvidia card for chrome or any other application you use to, and leave the desktop to run under the Intel card. Have a look here: https://launchpad.net/~hybrid-graphics-linux The bumblebee-disablecard.1215n and bumblebee-enablecard.1215n files will switch on/off the ...


2

I have been able to get WebGL working by passing the aticonfig --initial command in the terminal. This is an installation step for the driver that I have initially missed.


2

This is not a limitation of your hardware, but relates to no precision having been set for the float data type in the shader. See http://code.google.com/p/glsl-unit/issues/detail?id=9 It's entirely possible that WebGL works for you. Have a look at the demos from http://www.khronos.org/webgl/wiki/Demo_Repository


2

Indeed this seems to be an issue linked to Firefox blocking graphics card drivers: I have Kubuntu 11.04 and Firefox 6 and Chromium 12.0.742.112 (90304) Ubuntu 11.04 and in FF I get a grey page, in Chromium I get to see some fish. Performance is not very good, I get 16-22fps even with 1 fish. UPDATE: actually the number of fish does not seem to link in any ...


2

Have you installed the proprietary drivers or are you using the default ones that come with Ubuntu. Nouveau for what I know does not support the requirements for WebGL... yet. But if you install for the time being the nvidia Proprietary ones you will get full support. If i may ask, what video card are you using. You only need one that support OpenGL ES 2.0. ...


2

The following steps allow me to run demos on threejs.org: On the page chrome://flags/ Override software rendering list (select enable) Disable WebGL. (select disable) You can check that WebGL is enabled by using the following page: chrome://gpu/ For reference, I am running: Chromium 24.0.1312.56 Ubuntu 12.04 (x64, Desktop) ATI Radeon HD 4800 ...


2

First go to: How do I browse a site that uses WebGL? where i answer a similar question. After that do the following: Run chromium using the following parameter: chromium --enable-webgl Chrome might or might no work with the parameter mention above, at least in the last 3 versions it failed for me on some PCs.


2

Ubuntu 10.10 should contain the drivers for the GMA 3150. This seems a slightly odd situation, with the Intel website saying: Intel® Graphics Media Accelerator 3150 supports OpenGL* 1.5 with Microsoft* Windows* and OpenGL* 2.0 with Linux* I would suggest you report a bug, by pressing Alt+F2 and entering ubuntu-bug xserver-xorg-video-intel. This will ...


2

In order to check whether your browser supports WebGL, visit http://get.webgl.org/ Linux and WebGL have teething problems, and in many cases it just does not work. Whenever there is a support question, you need to provide what graphics card you have which driver you are using (mostly if they are the free/closed ones for ATI or NVidia). Newer Intel ...


1

In Chromium (or Google Chrome) you can type about:flags and search (ctrl + f) to WebGL. Activate it then restart your browser.


1

It is the same in Chrome. It is a problem with the code, not your browser or WebGL.


1

This worked for me with Firefox 5 and Ubuntu 11.04, although the aquarium demonstration link you provided ran extremely slowly on my machine, which admittedly isn't set up for gaming or multimedia. YMMV.


1

jbicha is spot on. Using the latest proprietary amd drivers for my HD 5550, I opened firefox 4.0 from terminal using: "MOZ_GLX_IGNORE_BLACKLIST=1 firefox" Voila! Web o' Wonder! Planetarium had some lag (compared to same card and machine running windows). Everything else ran just as well. Obviously, your results may vary. FWIW, Google Chrome 10.0.648.151 ...


1

The answer here will help a little with this question: How do I browse a site that uses WebGL? But to have WebGL support you need: Video Card that supports OpenGL ES 2.0 which is the base for WebGL. If your video card supports OpenGL 2.0+ then you already have OpenGL ES 2.0 support and so WebGL will work fine although I recommend video cards that support ...


1

I find out that Chromium works with some things that Chrome doesnt, if this help you, WebGL works here.


1

Even if the browser you are using is capable of running webgl your computer may not be able to If you run this command in a terminal glxinfo | grep "OpenGL version" You should get back some thing like this OpenGL version string: 1.5 Mesa 7.9-devel If the first number is lower than 2.1 you wont be able to run webgl in any browser unfortunately This is ...


1

It is a known issue with FGLRX and Ubuntu. I thought it only happened with Unity-2D but according to what you're saying it also happens with classic desktop. All OpenGL windows suffer from this problem. Take a look in here: https://bugs.launchpad.net/ubuntu/+source/unity-2d/+bug/800599 To disable webgl in Firefox you can type about:config in the address bar ...



Only top voted, non community-wiki answers of a minimum length are eligible