Hot answers tagged

100

If you want to interact with NetworkManager from the command line you can use the "nmcli" command. list all NM connections: nmcli con start connection (wifi, vpn, etc): nmcli con up id ConnectionName down connection: nmcli con down id ConnectionName (more nmcli commands in the nmcli manpage). Also note that regular users usually don't have permission ...


49

If you don't need the "official" Cisco AnyConnect VPN software, I highly recommend installing the "network-manager-openconnect-gnome" package in the Ubuntu Repository. It uses OpenConnect which is an open source client for AnyConnect. Anyhow, that package allows for you to configure and manager your AnyConnect VPN connections through the normal network ...


12

The solution suggested by con-f-use should work but doesn't, due to a long-standing bug: https://bugs.launchpad.net/ubuntu/+source/network-manager/+bug/280571 There are workarounds though. For recent NetworkManager versions, there is a commandline utitility, nmcli, that can be edited and saved as something like /etc/NetworkManager/dispatcher.d/vpn-up: #! ...


12

On Ubuntu, you don't need to install the Cisco VPN Client: NetworkManager includes support for Cisco IPSec VPNs. The following steps will walk you through a successful installation and configuration of your VPN client. 1) Ubuntu ships by default with the plugin for the Point-to-Point Tunneling Protocol (PPTP), but we need the plugin for the Cisco Compatible ...


7

sudo apt-­get install network­-manager­-pptp sudo apt­-get install network­-manager­-vpnc sudo apt-­get install network­-manager­-openvpn exit If prompted for your password, type it, and press Enter. If you're told that a package “is already the newest version,” ignore it and continue with the next command. If asked to “continue [Y/n],” press Y, ...


6

In Ubuntu Trusty 14.04 VPN auto connect store on GUI on individual saved wi-fi settings. System settings - Network - check interested Wi-Fi or Lan - Settings (General tab) - select "Auto connect to VPN... "


5

The nosuid mount option is used when the eCryptfs mount is set up. This is done for security reasons to prevent privilege escalation attacks. You can move the ncsvc binary outside of your home directory (just like you did with /opt/juniper/) and create a symlink from your ~/.juniper_networks/network_connect/ncsvc to the new location.


4

I encountered a similar issue earlier. I observed that vpnagentd does not load because of libatk1 and vpnui does not load because of libxml2. Installing the 32-bit versions of these libraries resolves the issues. You should install ia32-libs to resolve the issue using sudo apt-get update sudo apt-get install ia32-libs This should resolve the issue for you ...


4

Here's how I got this working with Ubuntu 12.10: First install the following sudo apt-get install vpnc sudo apt-get install network-manager-vpnc sudo apt-get install network-manager-vpnc-gnome Using the network-manager create a new VPN connection, set at least the following: Gateway User name Group name If the given group password is encrypted you can ...


3

I got "address", "netmask", and "gateway" in this way: 1) connect to VPN normally 2) run "ifconfig" command. output is somthing like this: eth0 .... .... lo .... .... ppp0 Link encap:Point-to-Point Protocol inet addr:172.16.11.15 P-t-P:172.16.11.1 Mask:255.255.255.255 .... .... ...


2

I found that in my case the plugin was failing because vpnc was not happy about the encryption method peer selected (single) DES as "encryption" method. This algorithm is considered too weak today If your vpn concentrator admin still insists on using DES use the "--enable-1des" option. This message could be only discovered by stracing the vpnc process. ...


2

ihashacks's answer with Matt's comments worked for me... almost. Had to tweak one line. my password-flag line actually read: "Xauth password-flag". The accepted answer wouldn't work for me until I changed to the following [vpn] ... Xauth password-flag=0 IPSec secret-flags=0 [vpn-secrets] Xauth password=<my pw> ## This is the one I changed. IPSec ...


2

Is this bug your problem? I ran into this and ended up doing a distribution upgrade to 12.10 to get passed it... Can’t connect to VPN from GNOME Shell It's been a while since this happened and I don't entirely recall what I ran into, but your problem seems very familiar to me.


2

Looks like there must be a bug in libgcrypt11=1.5.0-3ubuntu2.2. After rolling back to libgcrypt11=1.5.0-3ubuntu2.1 things are working again... sudo apt-get install libgcrypt11=1.5.0-3ubuntu2.1 I've filed a bug report on launchpad.


2

If I remember correctly it worked for a while and doesn't anymore. This might be obvious, but sometimes I don't think of it. Did you try reinstallation like: sudo apt-get purge network-manager-vpn sudo apt-get install network-manager-vpnc Then: Now I want this VPN connection to automatically activate when I'm in a certain wireless network. ...


2

You will first need to get the vpnc package and install it. Fire up a terminal and enter this command: sudo apt-get install vpnc You will then need to make a text file with the following information: IPSec gateway *gateway.to.use* IPSec ID *groupname* IPSec secret *passwordforgroup* Xauth username *myusername* Xauth password *mypassword* This file ...


1

I'm getting exactly the same thing happening. My Cisco VPN was working last week, but fails now. I downgraded libgcrypt11 to 1.5.0-3ubuntu2.1 but that doesn't resolve the problem for me. Anybody else having issues with this?


1

For me the cause of VPN not working anymore was that my stored passwords where somehow wrong although I didn't change them. I found that out by starting NetworkManager VPNC in the shell using the following command (in Siduction, that is, but I guess it might be similar in Ubuntu): sudo /usr/lib/NetworkManager/nm-vpnc-service --debug Then I started the ...


1

I had the same problem, and tried the downgrade of libcrypt11 ... fresh install of 14.04.2 LTS 64-bit, and so the downgrade was not in the repository and I had to download the deb and use dpkg to install it: curl http://launchpadlibrarian.net/122471093/libgcrypt11_1.5.0-3ubuntu2.1_amd64.deb >lc.deb sudo dpkg -i lc.deb The downgrade didn't work, however ...


1

By default VPNC uses an ifmode of virtual point to point interface(ie tun). But it also has another mode that you can use, virtual ethernet interface(ie tap). Try using that, ie: sudo vpnc example.conf --local-port 0 --ifmode tap


1

You need the Gnome package as well. So the magical incantation is this: sudo apt-get install network-manager-vpnc network-manager-vpnc-gnome Then you can simply add a VPN connection by launching the configuration of Network Manager and importing a .pcf file with the settings. Or by using a drop-down dialog in the settings of Network Manager and adding the ...


1

I managed the solution, I did not have to install neither vpnc nor openvpn nor pptp. I had to install openconnect. Then, the process is similar to others, add the VPN in the connection editor but selecting openconnect instead of the other ones. If I do this, I am only asked for gateway, username and password, so the data I was given is enough.


1

Add the result of a test to your prompt If the command ps ax -o comm| grep [v]pnc gives no output whatsoever when there is no active vpn connection, but it does when there is, you could edit your .bashrc file by: adding the following small section to it: if [ -z "$(ps ax -o comm| grep [v]pnc)" ]; then test="no vpn active" else test="vpn active" ...


1

First off, you need to run netstat with sudo to see all available PID's and program names, then you can use PID's to kill them. My example xieerqi:$ sudo netstat -tulpan Active Internet connections (servers and established) Proto Recv-Q Send-Q Local Address Foreign Address ...


1

vpnc is pretty ancient, try openconnect instead. http://www.infradead.org/openconnect/index.html it supports smartcards


1

I can only think of two work around for the encrypted /home partition. If you connect to a VPN via a website, start firefox with: sudo firefox since it is likely your /root is not encrypted. After network connect starts you can close the browser and leave the client running in the background. This is from what was mentioned before. Basically have the ...


1

I'd probably look at something as simple as: #!/bin/bash pgrep vpnc STATUS=${?} if [ ${STATUS} -ne 0]; then /usr/sbin/vpnc configname fi That'll then launch vpnc if it isn't already running.


1

In my casevpnagentd would not load. Installing the packages sudo apt-get install lib32z1 lib32ncurses5 however, resolved the problem for me. The terminal promted the message to install these, when I tried to install ia32-libs, which seems to be obsolete.


1

Here are procedure that worked for me on Ubuntu 64 bit desktop 14.04.3 sudo apt-get install -y lib32z1 lib32ncurses5 lib32bz2-1.0 libxml2:i386 libstdc++6:i386 libgtk2.0-0:i386 libpango1.0-0:i386 Now, I can ./vpnui to launch.


1

Your /etc/resolv.conf looks correct both before and after you connect, assuming that you have a local forwarding nameserver running which listens at 127.0.0.1. In Ubuntu 12.04 Desktop such a nameserver is running by default. To see the nameserver process, run ps -elf|grep dnsmasq The reason your colleague's /etc/resolv.conf looks different is that your ...



Only top voted, non community-wiki answers of a minimum length are eligible