New answers tagged

0

this should work: nmcli --ask con up id MyVPN to get this working over ssh i also had to add rules in /etc/polkit-1/localauthority/90-mandatory.d one called 90-ssh-network-control.pkla with content: [Network Manager - Control network nmcli] Identity=unix-user:yourusername Action=org.freedesktop.NetworkManager.network-control ResultAny=yes ...


0

I don't know if this is going to be helpful or not, but I spent a couple of days thrashing about with this on my Raspberry Pi openvpn setup, and my understanding of the solution is tenuous at best. I found this page: https://charlesreid1.com/wiki/OpenVPN/Static_Key to be what actually got things working for me, specifically the firewall iptables ...


2

Looking at your tshark capture and your routing table. I supposed that your vpn network is using the same subnet as the docker0 interface. This will shutdown the docker0 interface: sudo ifdown docker0 But the problem will come back after a reboot. To properly fix it you should remove docker, or change subnet settings of docker, or change your vpn ...


2

Please make sure you have the following packages installed: network-manager-openvpn network-manager-openvpn-gnome network-manager-pptp network-manager-vpnc You can install them on the command line by copying and pasting the following command: sudo apt install network-manager-openvpn network-manager-openvpn-gnome network-manager-pptp ...


0

John`s tip helped me. I had a similar problem. I was able to create a VPN-connection through import *.ovpn file. But after the connection was add, I was not able to edit it in the Network Manager. I have completed: nmcli connection modify "<VPN-connection name>" connection.gateway-ping-timeout 100 Then I open the properties of VPN-connection and ...


0

I think the issue appears to be that the openconnect plugin is missing a library that network manager now requires. If I examine the files in /etc/NetworkManager/VPN I see that all of the plugins except openconnect have a section that looks like the following: [libnm] plugin=/usr/lib/x86_64-linux-gnu/NetworkManager/libnm-vpn-plugin-vpnc.so ...


3

I had this very same issue with connection.gateway-ping-timeout. Forcing a value different from default 0 from a shell worked for me: nmcli c modify "Wired connection 1" connection.gateway-ping-timeout 10 I was then able to configure a manual IP address from the KDE Connection Editor.


1

Since you use killall at the end of your script you can detach your openvpn task from the terminal by adding a &: #!/bin/bash echo "ich logge mich jetzt beim VPN ein " sudo openvpn /etc/openvpn/magicbox1.ovpn & echo "warte auf den server" sleep 5 echo "bin eingeloggt, hole jetzt die Daten" sudo ncftpget -DD -T -R -v -u <username> -p ...


1

To supplement Morteza Pourkazemi's answer, the answer works for me, but I need to install the following packages which are required by the configure command. sudo apt-get install intltool libxml2-dev libgtk-3-dev libsecret-1-dev libopenconnect-dev network-manager-dev libnm-util-dev libnm-glib-dev libnm-glib-vpn-dev


0

It is not at all difficult to do this with a CLI instead of a GUI: openconnect -c ~/path/to/your/client_cert.pem \ -k ~/path/to/your/private_key.pem \ -b #for background $VPN_Address There are also options for giving it your username / password - so throw those in and add the script to startup, and you'll never even ...


4

I had same problem. use package in this page (or build it if you don't trust) http://tomtomtom.org/networkmanager-openconnect/ It works for me


0

I had the same problem and the following approach worked for me: "Use Point-to-Point encryption(MPPE)" must be selected Note: one or more of MSCHAP authentication methods should be selected before. Of course this is dependent to your VPN server settings as well.


1

I am having the same problem on fresh install of Ubuntu 16.04. You can however connect via terminal : sudo openconnect https://<remote.host.here> after that you should be prompted for user name and password.


0

Okay boys and girls this is how I fixed my problem. Install Ubuntu Software Center and use this to install any of your third party programs. It worked for me so I will keep using it. I know 16.04 is still brand spanking new, but there are bugs that should have been fixed before this. This is one of them, hope they can get it right it looks like it could be ...


3

To get the VPN connection to show up in Network Manager, ensure that all these packages are installed: network-manager-openvpn network-manager-openvpn-gnome network-manager-pptp network-manager-vpnc It may be overkill but it works. Even with this, it worked a little flakey on 16.04. One of my PCs threw an error when I tried to open the .ovpn file. I ...


1

I have the same problem as Mookey but I can confirm that the solution by 2707974 is working for me! Let's see this step by step. If have Gufw set to incomming:deny and outgoing:allow with logging on. Then if I switch VPN on, the first contact to my VPN provider is allowed normally without any rules. When the VPN provider is calling back his call is ...


1

Let's start. I preferOpenVPN solutions OpenVPN Access Server supports a wide range of configurations, including secure remote access to internal network and/or private cloud network resources and applications with fine-grained access control. It has a mobile app for Android and iOS, so that you can access the VPN server from your smartphones too. Install ...


1

The problem here is evident in this log line: Thu Mar 17 16:13:37 2016 /sbin/ip route add 192.168.1.0/24 via 10.0.254.21 Openvpn causing traffic for your local LAN to be routed via the tunnel interface. The following log line shows that 10.0.254.21 is the remote end of your tunnel connection: Thu Mar 17 16:13:34 2016 /sbin/ip addr add dev tun0 ...


0

It is possible to route ALL traffic through a VPN. It will depend on the setup of both machines. You will almost certainly need to pay for a good VPN, there are free options, but they usually have some catch, limited speed, strange software, time limits. Try this link http://www.thetop10bestvpn.com/best-free-vpn-service Also be aware that some web sites ...


0

Most common usage of VPN is to tunnel entire internet connection on system on which it's set. I've no idea how you did it only for browser... Did you perhaps meant Tor Browser? It's a different network. There are some free VPN's, but for good one you will need to pay. You can redirect entire connection with free Tor network, check "TORtp". Don't know how ...


0

since all ovpn files are all simple plain text files, you can create a python scripts with the following logic: (1) read the contents of ovpn text file; (2) grab relevant text between tags using regular expression; def grabBetweenTag(tagName, fileContents): betweentag = re.findall('<'+tagName+'>.*\n(^.*$.*\n[\S\n]+.*$\n)</'+tagName+'>', ...


0

This applies if your remote VPN is running on a different computer than the SMB share. I think that what you want is the following to your OpenVPN config file. push "route 192.168.1.0 255.255.255.0" This allows your remote computer to see the rest of the Remote 192.168.1.* network, if you don't have this line, then it will only be able to access remote ...


0

When you connect to OpenVPN from Windows you must have profile/configuration file somewhere with .ovpn extension, quite sure it can be found from C:\Program Files\OpenVPN\. When you open-up your configuration file at Windows you will see where certificates are located at your computer. You can copy-paste your configuration from Windows to Linux (aswell ...


0

Check your Iptables, maybe there are some rules that aswell block your VPN connection. iptables -L ACCEPT VPN connections for INPUT aswell to OUTPUT at Iptables. iptables -A INPUT -p tcp --dport 47 -j ACCEPT iptables -A OUTPUT -p tcp --dport 47 -j ACCEPT If VPN connection works, then save rules iptables-save


1

PPTP vpn user port 47 aka GRE. To allow this traffic edit /etc/ufw/before.rules and add at the end of file sudo nano /etc/ufw/before.rules this # gre -A ufw-before-input -p 47 -j ACCEPT -A ufw-before-output -p 47 -j ACCEPT Then disable, enable ufw sudo ufw disable sudo ufw enable EDIT 1 Rules must placed in /etc/ufw/before.rules before segment # ...


0

To undo the specific command you included in the question post, run: sudo mv /usr/local/sbin/openvpn /usr/sbin/ Explanation: The original command moved the file openvpn from /usr/sbin/ to /usr/local/sbin/, and then it created a script called openvpn in /usr/sbin/. To undo this, we need to move the original file /usr/local/sbin/openvpn to /usr/sbin/, ...


0

Sergey Prokhorov has not created a version for Wily (yet?). You can see this in the link you have posted. The plugin works up to Ubuntu 14.X (tested on 14.04). By the way, do you need L2TP over IPSec or not? Strongswan is for the one and Prokhorovs plugin for the other I think. Not an expert though. Cheers, Oliver



Top 50 recent answers are included