Hot answers tagged

2

Looking at your tshark capture and your routing table. I supposed that your vpn network is using the same subnet as the docker0 interface. This will shutdown the docker0 interface: sudo ifdown docker0 But the problem will come back after a reboot. To properly fix it you should remove docker, or change subnet settings of docker, or change your vpn ...


2

Try something like this You wish to change ufw rules based on interface status. Nice place for this kind of action is in /etc/network/if-down.d/ and /etc/network/if-up.d/ You can in this folder put some script and make action. For example put this script in /etc/network/if-down.d/ to change ufw rules every time when tun0go down. Make script called ...


1

You can write-update a password to a seperate file. This works for me: echo "vpn.secrets.password:MY_PASSWORD" > /my/vpn/password nmcli con up uuid MY_UUID passwd-file /my/vpn/password If you can't do that, you can also "simulate" keyboard, run sudo apt-get install xautomation and try this script (works for me at 16.04 as well): #!/bin/bash nmcli con ...


1

VPN Autoconnect states that "It seems that NetworkManager fails to obtain the user's VPN password from gnome-keyring-daemon." it also states a possible workaround.


1

You do it the same way you block websites for users on your company network: Run a proxy server and force everyone's web traffic through it. Source: http://serverfault.com/questions/518374/website-filtering-for-openvpn-clients


1

There seems to be a known issue about this. Error message when starting network manager from Terminal: $ nm-connection-editor ** Message: vpn: (strongswan,/etc/NetworkManager/VPN/nm-strongswan-service.name) cannot load legacy-only plugin


1

I just switched to Ubuntu so I can't double-check, but was use KDE before. I'm think the package you're looking to install is network-manager-l2tp and then use the network manager GUI to create a new VPN connection. At least that's what I remember doing.


1

Here is some useful info for vagrant boxes using host vpn. Basically you need to set natdnshostresolver1 option Note that this will NOT work when using the Vagrant's public_network setting though. config.vm.provider :virtualbox do |vb| # ---- other options.... vb.customize ["modifyvm", :id, "--natdnshostresolver1", "on"] end ...



Only top voted, non community-wiki answers of a minimum length are eligible