Tag Info

New answers tagged

0

Turn off Nested Paging in the System tab and restart the guest.


0

The proplem was I wasn't part of the vboxuser group. For those with the same problem: First make sure you have the Virtualbox Extension Pack, this allows use of usb 2.0. usb 3.0 is not yet supported. Added yourself to the vboxuser group: sudo usermod -a -G vboxusers <useruame> Log out then back in for the change to take effect Enable USB 2.0 ...


1

Try this. Go to your VirtualBox VM setting / Shared folder tab (open VirtualBox -> select the Android/Genymotion virtual machine -> Settings -> Shared folders) Add a shared folder with the folder you want to share, and check the "auto mount" and "permanent" options Start your VM as usual from the Genymotion software Your shared folder is available in the ...


0

There was the same error for me on Ubuntu 14.04.02 LTS. I have opened log file /var/log/lightdm/lightdm.log and see message like ...not enough disk space for .Xauthroity.... Then I have found that there is really zero space on disk. So I have removed some files and bug disappeared.


0

When your VM is shut down, change the available video memory to something higher. (I use 128 MB - the max allowed)


1

I had to do three steps: Install Virtual Box extension pack in host http://download.virtualbox.org/virtualbox/4.3.28/Oracle_VM_VirtualBox_Extension_Pack-4.3.28-100309.vbox-extpack Activate shared clipboard in menu http://askubuntu.com/a/438204/245048 Install Virtual Box guest extensions in ubuntu guest sudo apt-get install virtualbox-guest-dkms ...


0

I've had a similar issue with Bodhi Linux. Something in the installer for vboxedition fails. You can temporarily work around the problem but running vboxuser If that corrects the issue, then you need to set the system to run vboxuser on start up. You can do this by adding the command to the /etc/rc.local file.


0

You are right VirtualBox is not the only process that needs to be contained, but it's more than just a front end. Short answer: Try binding VBoxSVC. Long answer: You should probably use top (or better htop) in your computer to find the component that is doing the work in your situation, Virtualbox spans at least two background processes VBoxSVC, that at ...


0

I had this problem in Kubuntu Vivid. I was struggling for a long time with the error "Your kernel headers for kernel 3.13.0-36-generic cannot be found.", and apt-get was unable to find it in the repositories. The solution was to add a repository from trusty deb http://security.ubuntu.com/ubuntu trusty-security main to /etc/apt/sources.list, and ...


0

I ran into the same problem, and these steps fixed it: 1) On the host, use the latest version of VirtualBox from virtualbox.org. (I used 4.3.26). 2) On the guest (Ubuntu 14.04.2), run sudo apt-get install linux-headers-generic 3) On the guest, do not use the Ubuntu repositories to install the guest additions. Instead, press Host+D to use the guest ...


0

There is a great answer at this post to create a host only connection for your Virtualbox that can be seen by Ubuntu to be used for connecting into your VM for network connection sharing. In VirtualBox, how do I set up host-only virtual machines that can access the Internet? Before you follow those directions you need to create the virtual connection. ...


0

1) You have to enable a shared folder between the host and guest operating system. 2) Put you ms office executable or folder in the shared folder. 3) Go to the shared folder from the guest os (windows7 in this case ). 4) Copy ms office folder to any folder other then the shared one (in you guest os,this happened to me personnaly ms office was not working ...


1

If you run Ubuntu in Virtualbox, then you do not need to setup wireless connections there. It will use host system connection. Guest system does not directly use network hardware, unless it is a USB dongle, which you passed through to the guest system.


-1

I'm not sure you can. However, you can create a dynamically allocated VHD instead. Here is how to create it: Click settings, and then Storage and click Controller: SATA. Then click the Blue square with a green +. Click Create new disk: Chose VHD and click Next: Chose Dynamically allocated, and click next: Chose a name, a size and click Create: ...


-1

Try to install the "linux-firmware-nonfree" by typing: sudo apt-get update sudo apt-get install linux-firmware-nonfree And then reboot. (it's worked for me)


0

Any chance that a kernel update has disabled the vbox guest additions? Do you tried reinstalling the guest additions?


0

Ok I found the solution. I just had to start a DHCP server with VirtualBox. It's well explained in this video: https://www.youtube.com/watch?v=lhOY-KilEeE


0

First make sure that you are in vboxuser group. To do this run following command: sudo usermod -a -G vboxusers YOUR-USER_NAME then force VirtualBox Module compilation by running following command: sudo /etc/init.d/vboxdrv setup then try to restart virtualBox from command line /usr/bin/VirtualBox restart This should help


0

Fixed by upgrading the server to 14.04LTS. Don't know why 12.04LTS was having that issue, but everything is up and running now.


0

This is a problem caused by VirtualBox, not by Ubuntu. Your best shot might be to try the VirtualBox Guest Additions. Installing the VirtualBox Guest Additions (Oracle)


1

I could resolve this issue by updating to VirtualBox 5.0. I removed my old VirtualBox 4.3, then downloaded 5.0 from here (trusty package). Then I installed 5.0 and I can finally start a 64 bit VM over the VirtualBox GUI! Unfortunately current Vagrant 1.7.2 doesn't support VirtualBox 5.0 according to this documentatioin. I got this error message: $ ...


0

In addition to the good description of the vboxautostart-service above, you can do VBoxManage modifyvm server --autostop-type savestate to automatically stop the guest at shutdown. For Ubuntu 14.04 I had to add a sleep 30 to the vboxautostart-service stop section, so that it waits until guest has been saved completely.


2

Your error indicates that gcc - the GNU C Compiler - is not present on your system. To get it, you should install build-essential which is a meta package which will pull in the compiler and most of the standard libraries it needs for compiling things as dependencies. Run this command to install it: sudo apt-get install build-essential


0

I just bumped into this issue on Ubuntu 15.04 with a Windows 7 guest. In my case the solution was to enable 3D Acceleration (Settings > Display > Extended Features).


0

Use: sudo chown root.root /usr /usr/lib Do you need guarantee that /usr and /usr/lib are with root owner for user and group, usually you can found user 501.501 in this directories.


1

you need to install the headers first: sudo apt-get install linux-headers-$(uname -r) you have to recompile the kernel module and install it by sudo /etc/init.d/vboxdrv setup If some error appears then try this solution: sudo apt-get install virtualbox-ose This will take care of dependencies like the kernel headers which is included in the package ...


0

quoted from http://colotronics.blogspot.com/2014/08/msp430-toolchain-in-ubuntu-1404-with.html cd ~ mkdir mspgcc_install cd mspgcc_install Dependencies sudo apt-get install patch ncurses-dev build-essential bison flex zlib1g-dev sed automake gawk mawk libusb-1.0.0 libusb-1.0.0-dev dos2unix srecord Downloads: wget ...


0

Go into your BIOS (Usually Delete, F1, or F12 on boot) and Enable VT-x. This should be a setting somewhere in your BIOS. Depending on the type of computer you have it could be under hardware settings, advanced settings, or something similar. Look around for it. It might also be called CPU virtualization. EDIT: See my comment below. Nested virtualization ...


0

I know this is old, but here's a suggestion for anyone else who finds this post. You said ... I am still unable to get any USB device working ... which suggests you you need to add the user to virtualbox users with the command sudo usermod -a -G vboxusers username Then you need to activate USB support, disable support for the specific device(s) for ...


0

The Unity interface in my Ubuntu 14.04 guest OS became very sluggish recently, even though my Guest Additions were up-to-date with the VBox version at 4.3.26. I read through this and several other answer pages and contemplated switching from Unity to Gnome and other changes, but I knew nothing significant had changed and I remembered getting perfectly good ...


1

you can easily in simple method, just create another VDI hdd in your virtual machine and attach it to your machine, then boot your ubuntu, once you login you can see the icon of an external hdd on your unity launcher. click it and thus it's mounted now so you can easily copy or move whatever you want to it. This tricky method as you are using external hdd ...


3

In the ifconfig of the ubuntu machine the ip range is: 46.4.21.65 - 46.4.21.126 (use http://www.subnet-calculator.com/ if you cant work it out) The ip you specified on the windows server is in the 192.168 range, which is not on the same subnet. You need to specify the IP in the windows server (to one that is free) something like: IP address: 46.4.21.80 ...


0

I think it is driver problem you should install android usb driver. For install usb driver : Linux : Install driver in linux Windows : steps: Download Google USB Driver. please find your device USB Driver from this link. Then open devices in windows. After that right-click on devices open property. select update device driver. Then select pickup from ...


2

This is no problem. You can simply delete the folder VirtualBox VMs. Inside this folder are the configuration files of VirtualBox and the virtual HDDs. You can also leave that folder and reuse the virtual machine later if you want.


3

Removing Virtual Box means you remove the application. Still some apps keep files even after uninstalling, and VBox is one of them. The directory you see includes the hdd of the old machines and the configuration files so you can rerun your old machines if you install VBox again. So, for you its up to you, if you don't need that machine anymore you can ...


0

The following will set a static ip that network manager will respect. I have copied this from personal ubuntu 14.04 ltsp install instructions so you may not need some of it. I tried to modify the addresses based off your information in the linked questions. I substituted the local nameserver IP addresses with Google's. Modify as needed. I also set an ...


0

Windows 7, VBox 4.3.12 r93733 (current version does not play nice with Avast) I spent hours trying to get this working full screen, these 3 steps worked, thank you! System settings menu item not working, so I had to sudo apt-get install unity-control-center all working now.


1

Ok, so anyone else who happens to come by this issue, my boss managed to figure it out: I had the wrong version Python running. After switching back from Python 3.4 to Python 2.7.8, the problem was fixed.


1

@Takkat is spot-on. The problem is the version of X Server on the GUEST in relation to what the HOST's version of Virtualbox will support in order to get full-screen. You can get the version of X Server with X -version. Run this on the GUEST to see which version is installed. Of note, there is one - rather than two --. Also, this command outputs to stderr ...


-1

You probably have an hard time using the terminal. Don't worry it's quite simple, just follow those steps: Start the machine Now, on the top menu, go on Devices and click Insert Guest Additions CD image ... In Ubuntu 15.04 you can just run it, it does everything by itself. If it doesn't, follow those steps. Open the terminal from the launcher Write cd ...


0

There isn't much of a need to use the command line so long as you've installed the Guest Additions Pack into your virtual machine. From there, it's as simple as adding a shared folder in the machine's settings:


2

you have to recompile the kernel module and install it by sudo /etc/init.d/vboxdrv setup If some error appears then try this solution: sudo apt-get install virtualbox-ose This will take care of dependencies like the kernel headers which is included in the package linux-headers-generic But if you've a PAE kernel, you need to install the headers first: ...


1

Virtualbox needs to load a module to the host's kernel. It seems you're missing that vboxdrv module, or it can't be loaded for some reason. Normally the vboxdrv is compiled and installed while installing Virtualbox. If you just installed Virtualbox and didn't reboot your machine since then, it might be enough to reboot. Because the kernel modules are ...


0

My mechanism for this: vagrant global-status | grep virtualbox | cut -c 1-9 | while read line; do echo $line; vagrant halt $line; done; global-status lists all boxes filter that for lines containing virtualbox (Filters out the help text, will break if you're using some other provider) Filter that to display only the first 9 characters (the global unique ...


2

All of the memory will be dedicated to the virtual machine when it is started. (I recommend that you buy more RAM if you want to use this VM regularly though.) It is enough to just press Delete. That will delete the virtual machine entirely from your system. Oracle VM VirtualBox is easily the best choice for running Windows 8.1 in a virtual machine. Just ...


0

The program /usr/bin/pyclean seems to be missing. Make sure the package python-minimal is installed.


0

Try these commands in the terminal: sudo add-apt-repository ppa:langdalepl/gvfs-mtp sudo apt-get update sudo apt-get upgrade Not really sure, but it might work for you. OR you can try this too.


0

This is due to extension pack's different version than other VB packages. Fix 1) Removing extension pack - sudo apt-get remove virtualbox-extension-pack 2) Disable USB 2 support from VM settings It will works ! If you want to use extension pack , reinstall the correct version. You can download it from here.


0

First i set the machine "attached: NAT" and start up the server the reload the network sudo /etc/init.d/network reload then i shutdown the server and set the attached the "bridge Adapter" and start up the machine and type the following command: sudo virsh net-destroy default sudo virsh net-undefine default sudo service libvirtd restart sudo ...


0

I think you what you need is Clonezilla which can backup the whole disk or only the selected partition (cant say it is a "Live CD/USB"). There are many tutorial available in the internet like this one. There is also Clonezilla live that allows you to use CD/DVD or USB flash drive to boot and run clonezilla. As alternatives you can try Systemback which will ...



Top 50 recent answers are included