Tag Info

New answers tagged

1

the first rule for migrating to systemd At this point, in 2015, it's most likely that someone has already done it. systemd has been around for some years. And there has been a whole cottage industry of people writing unit files and publishing them. GitHub, in particular, seems to attract repositories of collections of service units. Indeed simply ...


2

Upstart scripts need to end in .conf. To rename your file, run: sudo mv /etc/init/minecraft-server /etc/init/minecraft-server.conf ...followed by: sudo initctl reload-configuration


0

In my case, upstart service depended on the script located in vagrant synced folder. Solved the problem using the following line: start on vagrant-mounted More info: http://razius.com/articles/launching-services-after-vagrant-mount/


4

Autostart an application for all users To autostart an application, either which user logs is, you can store a .desktop file in /etc/xdg/autostart. Automatically start up an application from a launcher in/etc/xdg/autostart will also: give individual users the opportunity to unset autostart. The .desktop file will be automatically copied from ...


0

I did the following, which to me seems less invasive than the other answers. Remove the startup of transmission-daemon: sudo update-rc.d -f transmission-daemon remove Add the following to /etc/profile: if [ -f "$HOME/.autostart" ]; then $HOME/.autostart fi Create ~/.autostart: #!/bin/bash if [ -z "$(pidof transmission-daemon)" ]; then ...


0

I found the problem for fail2ban was an error in the configuration file: /etc/fail2ban/jail.local In the pam section, the port variable is listed twice [pam-generic] ... port = all banaction = iptables-allports port = anyport Even though this section is disabled (enabled = false) in my configuration, this causes an error. I simply commented ...


0

The Ubuntu MongoDB upstart script now checks for the presence of the numactl binary and adjusts accordingly. The NUMA warning can be fixed as follows with Ubuntu 14.04 LTS and MongoDB 2.6: sudo apt-get -y install numactl sudo restart mongod


1

The service management system has changed. Every system management toolset has own utilities. The utility that you are used to using is one of the ones that come with upstart, which is a trivial shim for initctl restart. But this is Ubuntu version 15. You aren't using upstart any more. You're using systemd, and the service control commands are ...


0

As of 15.04, Ubuntu is now using systemd, not upstart, similar to most other distro releases now. Do not install upstart and run upstart commands to manipulate services unless you really know what you're doing. If you have upstart installed, I'd recommend uninstalling it. To restart network manager as non-root, since it runs as a daemon process: sudo ...


0

what i figured out: i tried to re-order the /etc/init/rc.local script, which runs /etc/rc.local, so it would run first. but upstart runs /etc/init/nsd.conf in parallel and ruins that idea because nsd tries to bind one of these addresses too fast. so i ended up prefixing a script before nsd to set up the addresses just before running nsd. now it's ...


1

Defining virtual interfaces in /etc/network/interfaces: auto eth0.10 iface eth0.10 inet static address 192.168.1.61 netmask 255.255.255.0 gateway 192.168.1.11 auto eth0.10:1 iface eth0.10:1 inet static address 10.20.100.100 netmask 255.255.255.0 auto eth0.10:2 iface eth0.10:2 inet static address 10.20.100.200 netmask ...


1

Add braces around the variable. I assume you are trying to use the $HOSTNAME environment variable. env CONFIG_NODE_NAME=my_${HOSTNAME}_node


2

This line in the output: Synchronizing state for plexmediaserver.service with sysvinit using update-rc.d... suggests that systemctl is calling update-rc.d, and the only plausible line that does this is: systemctl disable plexmediaserver.service Commenting it out or cancelling out the error from it should do the trick.


1

The plex messages are a red herring. That's just stuff that is also wrong with your system. See questions such as Problems starting plexmediaserver on Kubuntu 15.04 for starters. Use the systemd unit. You don't say what list of instructions you are following in order to install SickRage on Ubuntu, but somewhere in those instructions it told you to run ...


2

Ubuntu switched to systemd as its service framework starting in 15.04 for all flavors, including Desktop and Server. The recommended practice is to change your upstart jobs to systemd jobs (see the wiki article for more info). You can also switch back to upstart if you want, which is certainly the quicker fix. I recommend you read the first few sections of ...


0

The root cause was a change I did in fstab based on recommendations for solid state drives (SSD). I removed these lines and was able to reach the login screen with systemd: # ramdisks tmpfs /tmp tmpfs defaults 0 0 tmpfs /var/lock tmpfs defaults 0 0 tmpfs /var/log tmpfs defaults 0 0 tmpfs /var/run tmpfs defaults 0 0 tmpfs /var/tmp tmpfs defaults 0 0 My ...


2

EDIT with more details: My problem was incorrect device uuids in file /etc/fstab. (the red one is incorrect,the green one added by me and the red one is commented out) After correcting the uuids in /etc/fstab for / and swap (with infos from blkid), it works for me!


1

Could anyone adequately explain to a non-technical user how and if this affect us at all? In theory, this shouldn't affect the non-technical end user who doesn't get involved in the nitty gritty of how the system actually works. In practice, there are a lot of things that you're going to see. Here's an incomplete list: If you had add-on softwares ...


1

The headline news this week is that Ubuntu version 15.04 doesn't use upstart. It uses systemd. You can go back to upstart, which is a question all to itself; or you can write a systemd service unit for your service; or you can swipe an already-written one. There are plenty of already-written ones about. This mbpfan.service unit by Ismail Khatib has been ...



Top 50 recent answers are included