New answers tagged

0

There are two options: 1) Use --force-yes. But read the below lines taken from man apt-get: --force-yes Force yes; this is a dangerous option that will cause apt to continue without prompting if it is doing something potentially harmful. It should not be used except in very special situations. Using ...


0

Your question is twofold - how (or if) you can downgrade from 16.04 to 15.10/14.02, and how to upgrade correctly to 15.10. Downgrading is possible, but a tedious and risky process, with no guarantee of restoring your system as it was. See this question for more details. If you want to upgrade (after the downgrading) to 15.10, it can't be done directly, ...


0

I had the same problem: sudo pip install --upgrade <package> ran correctly but the packages didn't actually get upgraded. I just tried sudo easy_install --upgrade numpy sudo easy_install --upgrade scipy sudo easy_install-3.4 --upgrade numpy sudo easy_install-3.4 --upgrade scipy and it worked: I now have numpy 1.11.0b3 and scipy 0.17.0 in both ...


3

Not water-proof but another possibility, if the entry was not removed: $ grep cdrom /etc/apt/sources.list # deb cdrom:[Ubuntu-GNOME 15.10 _Wily Werewolf_ - Release amd64 (20151021)]/ wily main multiverse restricted universe That means, you probably have installed your system with a Wily DVD.


8

I doubt there is a perfect method. A method could be to check the date of creation of the filesystem: sudo tune2fs -l /dev/sda1 | grep 'Filesystem created:' Filesystem created: Thu Mar 5 15:51:50 2015 The system I pulled this from was created on March 5th 2015. Of course it is entirely possible to install 14.10 on March the 5th and then upgrade ...


0

apt-get From Debian: upgrade Upgrade will attempt to gently upgrade the whole system. Upgrade will never install a new package or remove an existing package, nor will it ever upgrade a package that might cause some other package to break. This can be used daily to relatively safely upgrade the system. Upgrade will list all of the packages ...


0

apt-get install python3 this should do it. remember python3 takes input as string and used function to parse it to another format.


2

In General It is not recommended and therefore not possible to change the python version of your system (i.e. with apt-get update python), since many scripts rely on a specific version. You can brake your system and it may cause problems with future updates. Instead, you may want to have a look at virtual environments as answered here. If you are searching ...


3

You don't need to upgrade. Specify the standards version to g++. For example, to compile an example program from cppreference.com: $ g++ --version g++ (Ubuntu 4.8.5-2ubuntu1~14.04.1) 4.8.5 Copyright (C) 2015 Free Software Foundation, Inc. This is free software; see the source for copying conditions. There is NO warranty; not even for MERCHANTABILITY or ...


0

If I have understood your question correctly I believe you need to install the Flash player plugin as follows: sudo apt-get install flashplugin-installer This is in the 'Multiverse' repository so make sure you have enabled this in Software Sources.... Google Translate: Si he entendido bien su pregunta creo que es necesario instalar el reproductor ...


0

You'll have to install libcheese first. Then try this one. Hope that helps :)


0

These commands did the trick: $ sudo dpkg -r youtube-dl (Reading database ... 332796 files and directories currently installed.) Removing youtube-dl (2015.06.04.1-1) ... Processing triggers for man-db (2.7.4-1) ... $ sudo rm -rf /usr/local/share/doc/youtube_dl /usr/local/lib/python2.7/dist-packages/youtube_dl* /usr/local/bin/youtube-dl $ sudo pip install ...


1

On the mailinglist, one of the Sage developers mentioned that this is a known issue with 7.0 and should be fixed soon. That was posted on 2016-02-04. It appears that it has since been fixed with the 7.0~aimsppa1~qa201602060140061 release, (i.e. on 2016-02-06). I just ran apt-get update && apt-get upgrade and this problem was indeed fixed.


1

Since you didn't update the package manager's view of your system when you "manually reverted to an old version of thunderbird", it thinks you're running the current version. Rather than trying to tell the package management system about your old version, you could simply reinstall the current version with: sudo apt-get install --reinstall thunderbird ...


0

Try this method for login flash back: Start the computer, Press Alt + Ctrl + F1 to login the terminal $login: $password: sudo chown -R $USER:$USER $HOME This resolved my problem in ubuntu 15.04. All the best.


0

I solved it: I did sudo apt-get update && sudo apt-get upgrade -y then restarted - and sound is now playing again! But now the sound notification icon is missing. I just did a sudo apt-get install indicator-sound and after a restart everything was back to working again.


2

Remove the Wily repo now! Quickly before something does an automatic upgrade and you end up with a system that is completely boned. Evolution relies on dozens of Gnome packages and systems so upgrading one will need you to upgrade another, which will need you to upgrade another. Do you see what I'm saying? You'll need to upgrade most of Gnome. Because of ...


2

You've got the lot: Logical volumes, overlapping partitions, unknown file systems, ... So: the best thing you can do right now is to stop using your hard disk! Then boot from an Ubuntu 15.10 Live DVD and: (increasing numbers means increasing difficulty and less of your data will be recovered) Restore your latest full system back-up. If you don't have a ...


0

you should reinstall your desktop. prees ctrl+alt+f1 login with your user and pass. if you use uinty write in terminal: sudo apt-get install --reinstall ubuntu-desktop if use Gnome : sudo apt-get install --reinstall ubuntu-gnome-desktop


0

Upgrading from 14.04 LTS to 16.04 LTS No. Why Its is my understanding that 14.04 is entirely different from 16.04. Top to bottom. 16.04 has a single code base for all devices, and on top of that snappy packages, systemd etc.. etc... If 16.04 is out, I will be doing a clean install, because there is too much deep rooted packages/services to remove ...


0

I found the solution: Go download and install a newer DEB package from the Texmaker website. NOTE : Simply trying to overwrite the package using dpkg -i will fail with an error. You first need to uninstall the texmaker-data package (which will also remove texmaker and a few more dependencies): sudo apt-get remove texmaker-data Then install the downloaded ...


0

This solution worked for me https://help.ubuntu.com/community/Boot-Repair 1) Launch ubuntu on the live USB 2) follow the procedure to install Boot-Repair 3) Restart and your system will boot 4) From terminal update, upgrade and dist-upgrade and reboot 5) repeat 4) id you find some issue


0

In the highly unlikely event you haven't done so, shut down - NOT simply reboot your computer. Next, again assuming that you haven't done so: sudo apt-get autoclean && sudo apt-get autoremove Then: sudo apt-get update && sudo apt-get upgrade Even though you've just upgraded your computer, some of the older config files occassionally still ...


0

Firstly, I generated a clean and minimal sources.list from repogen having only main and universe sections. Then, I made a thorough reset of my apt system by following: sudo apt-get clean sudo rm -rf /var/lib/apt/lists/ sudo apt-get update --fix-missing But even that didn't solve the problem. Then I located the problem source to the universe section of the ...


1

My install completed successfully, but I got the same error. Turns out that a new update (which reintroduces an old bug) causes network manager to crash. See here for the fix: Last upgrade crashes network manager (no internet connection, no applet)


0

Try the startx command to open the GUI after having logged in.


0

In April this year, the next LTS version (16.04) will be issued. You will be able to upgrade to it directly from 14.04 LTS. It will contain up to date versions of btrfs and the kernel. Upgrading to 15.10 (non-LTS) will require you to work through the intermediate upgrades (> 14.10 > 15.04 > 15.10). Are you able to wait 2-3 months?


1

This is True / False? This is true. If yes, why do I need a PPA if I have already installed Gnome Shell? Because Gnome 3.18 is not in the repositories. 3.18 is not 100% compatible with 3.16, and so they don't want to release it as an update. Instead, Which PPA is the most Stable? Well you don't have a PPA for 3.16, so this is a non question. If ...


1

Yes, it is true. Ubuntu 15.10 was released with Gnome 3.16, and Gnome 3.18 will not be officially available until Ubuntu 16.04 There are two gnome sites on Launchpad: if you sudo add-apt-repository ppa:gnome3-team/gnome3 then you can sudo apt-get update && sudo apt-get upgrade and will be at gnome 3.18. There is also a repository ...


1

The link provided by @AndersOlsson above held the answer to my problems. The commands I ran to fix my issue were: sudo mv /var/lib/dpkg/info/rpm-common.* /tmp/ sudo dpkg --remove --force-remove-reinstreq rpm-common sudo apt-get remove rpm-common sudo apt-get autoremove && sudo apt-get autoclean After running these commands, I was able to ...


3

There is a github for gnome-shell , which you could clone git clone https://github.com/GNOME/gnome-shell And build the new version form source to stay up to date. There's also git for the gnome packages, for example for gedit you'd do this git clone git://git.gnome.org/gedit


3

You can install GNOME 3.19.x from those PPAs (though it may not fully be in the PPAs yet) if you install one of the Ubuntu GNOME 16.04 daily-builds. Otherwise you will have to wait for GNOME 3.20 to be available from them once Ubuntu GNOME 16.04 has been released. As you can see though the GNOME 3.19.x versions are in the PPAs though:


0

I have this too, and this is probably because you have bookmarked a network drive, the fact you mention previously using Samba is very telling. Nautilus seems to want to secure "a network touch" in the "Window Renderer Thread" for every bookmarked device before it renders the window to the desktop environment - not only is this suboptimal, but also it means ...


2

Try uninstalling then reinstalling the package: sudo apt-get remove rpm-common sudo apt-get install rpm-common If the removal of the package gives you problems, try following this. You will likely be forced to remove some more, dependent packages, in the first step. Please take note of them, and reinstall them after you've successfully reinstalled ...


1

You can either upgrade pip globally using sudo: sudo pip3 install --upgrade pip sudo pip2 install --upgrade pip Or you can upgrade it for your user only using the --user option: pip3 install --upgrade --user pip pip2 install --upgrade --user pip Note that I upgrade both pips for Python 2 and Python 3. It's important to upgrade the version for Python 3 ...


0

When you talk pre-released this is almost always going to be more of a headache as it is being used to test (so less bugs will be in the actual release) You are better off installing 14.04Lts that is supported tell April 2019. Then updating to the new release when it is supported (In April 2016) *Note as @EduardoLopez pointed out even when 16 is released ...


0

You may be able to recover it by decrypting the file /home/username/.ecryptfs/wrapped-passphrase using your login passphrase. ecryptfs-unwrap-passphrase /home/username/.ecryptfs/wrapped-passphrase Type your login passphrase to reveal the mount passphrase. If your login passphrase matches the passphrase used to encrypt the wrapped-passphrase file, your ...


-1

When I update 12.04 to 14.04, the same problem. Finally solve it by following command. sudo apt-get install procps ln -s /bin/ps /usr/bin/ps


0

If you want to use dpkg-reconfigure, you can set the value with "debconf-set-selections", and then reconfigure it in a noninteractive way. echo "unattended-upgrades unattended-upgrades/enable_auto_updates boolean true" | debconf-set-selections; dpkg-reconfigure -f noninteractive unattended-upgrades


1

the command apt-cache showpkg <package> will tell you the packages "reverse depends" i.e. what other packages - in your configured repositories (not necessarily installed packages) - depend on that package. In the case of gdm there are alot, so I wrote this script to iterate through all of the reverse dependencies to check if any were installed - ...


5

Just a minor addition to two great answers: the most annoying thing for me about using an unsupported version is that a few months after the support window ends, apt-get stops working. The main apt repositories delete references to your version. Of course you can find archives and add them to your sources list and it starts working again, so this isn't a ...


-1

Its supposed to. What it is doing is replacing all of the old versions of your apps. In other word, Run the upgrade and don't worry, you lose nothing. What's happening is that Ubuntu needs to use a differernt repository for the newer version. Next, I checked my PPA's to see if THEY updated their base and found that most had. I used YPPA, its a ...


0

There seems to be a fundamental problem with synchronization of the Intel and Nvidia video components in (certain?) laptops. See http://askubuntu.com/questions/tagged/tearing for many proposed solution to the issue. Also, the xorg-edgers ppa has an alternative, sudo add-apt-repository ppa:graphics-drivers/ppa which should be the latest drivers.


14

Well, better be concise: Yes No, there will be no updates. You will be able to install obsolete software from the EOL repositories, but nothing there will be updated and you will not receive help from this or other official help websites. Also, when the distro version becomes EOL you will have to follow a particular procedure to upgrade it to the ...


7

mate! Hope this helps you: Yes, it means there will be no official support from canonical for 15.10. That is the reason why LTS is always recommended for people who need stability. You can still keep using 15.10 normally, tough. Yes, you can patch and update your system from other sources and/or repositories, but I wouldn't recommend it. You can even ...


0

I will suggest you install 15.10 fresh from the live USB. At the time of installation it will give you an option what all you can do. I would say stay with 14.04 LTS(Long term support). Ubuntu Desktop LTS releases are launched every two years, refer to this LTS release cal


0

Simple way: apt-get install dynare-matlab=4.4.3-1~trusty1 Best way: Using priority like: Assign higher priority to PPA


0

After a while looking around , I decided to do a fresh install but making backup of data is so boring! so i didn't do anything, grub works fine. theme is changed to Kali but core is fine. by using Ubuntu default desktop environment, I have removed Xfce and many extra packages installed before. then by cleaning up the system I installed them again. errors are ...


0

I reinstalled Ubuntu 14.4 from a USB and have taken a mental note only to use the Software Centre unless doing so is impractical.


0

The root of the problem appears to be that I was trying to use Synaptic Package Manager to do the install. Running the following commands: sudo apt purge postgresql-9.1 sudo apt-get install postgresql-9.1 sudo pg_createcluster -d /path/to/existing/data 9.1 main cleared up the installation problem.



Top 50 recent answers are included