New answers tagged

0

This solved the problem I think. Saw the related thread in the column on the right, "How do I get software updater to update?" Followed this thread, and tried a suggestion: In a terminal run the following three commands, sudo apt-get update sudo apt-get install linux-generic sudo apt-get dist-upgrade Then reboot. And voila! Now when the ubuntu software ...


0

You lose the kernel module not after each update, but only after a kernel update. You do not need to download drivers and copy firmware each time. If you keep the source of the driver you can only run: cd mt7601/src sudo make install Maybe you will need to start the module if it does not start automatically by sudo modprobe mt7601Usta This does not ...


0

Replace apt-get upgrade with apt-get dist-upgrade and try again if you like.


2

"software updater" is the generic updater. It will scan for updates for all your repositories and PPA's you added. It will scan based on a period set in "settings": If you do not care about what gets updated this one is good enough. And you can set this to silently update. Ubuntu Software has its own version on this. Basically it uses the same method but ...


0

Give the following a shot: sudo rm /var/lib/apt/lists/* -vf sudo apt-get update This will delete corrupted packages and reupdate.


1

@cucujoida, The old muon-updater has been superceded by plasma-discover-updater. If you ensure that plasma-discover-updater has been installed, you can uninstall muon-updater if you still find that in your system. I hope this helps.


0

If you offer services to the internet, which i think you do with webservers, you should patch promptly. What promptly means depends on the value of your data and the visibility of your Services. You dowload the updates from canonicals repository, the packages are signed and you have to trust your os vendor, if not you should change the vendor. Be aware ...


1

It looks like you are trying to use a CD as a repository. You can't do that in this way, because the CD doesn't have the necessary structure. If you want to make a CD accessible to APT, you have to use apt-cdrom. You can find further information on apt-cdroms man page man apt-cdrom And, no offence meant, but the error messages you quoted in your question ...


0

I had the same problem. I DO NOT have Apache, and nothing else was blocking my port 80. I could NOT install nginx with sudo apt-get install nginx nor with sudo apt-get install nginx-common nginx-full After one week I stumbled over this little blog: https://etc.banana.fish/?p=75 In this blog, the solution is: Install nginx-common: sudo apt-get ...


0

You might have trouble getting ttf-mscorefonts-installer to accept the EULA. These commands will accept the EULA and reinstall the packages (assuming you downloaded the individual font .exes): echo ttf-mscorefonts-installer msttcorefonts/accepted-mscorefonts-eula select true | sudo debconf-set-selections sudo dpkg-reconfigure ttf-mscorefonts-installer


1

I fixed it. Had suspected a brightness problem - as it had happened to me with android. I tried the development chNnel and was able to very dimly see the screen. Turned the brightness up from minimum, and problem solved.ta


0

I had the same issue and simply installed an archived version of libjsoncpp0 for Ubuntu Trusty. Just download and install it with Ubuntu Software Center from: http://packages.ubuntu.com/trusty/amd64/libjsoncpp0/download


0

During installation, uncheck these two check boxes. Then after installation, restart your machine and run these commands in the terminal: sudo apt-get update sudo apt-get upgrade sudo apt-get install ubuntu-restricted-extras Related Links: Ubuntu installation guide Top things to do after installing Ubuntu Google search


3

sudo apt-get update doesn't actually update anything. It just refreshes Ubuntu's repositories, so it knows if updates are available. You need to run sudo apt-get upgrade to actually update any packages. As for that error, it shouldn't affect much in terms of upgrades. Since it's obviously an invalid PPA, you can just remove it. Do that by running sudo add-...


0

This PPA you have added does not provide packages for Xenial; you should remove it.


0

Try to execute the following commands sudo apt-get autoclean sudo apt-get update sudo apt-get upgrade You can also check the log files: Use tail -f /var/log/dpkg.log In one terminal, and use the update command in another terminal, you should get the error which is not letting you update.


0

It often depends on whether you have a separate /boot partition, if you're running out of space in that partition, you'll need to clear old kernel files to make room for the new ones. The recommended way to do this is to use: sudo apt-get autoremove This should leave you with your current kernel, and the previous one as a fallback. I tend to do this after ...


2

This repository does not support Xenial. If you need codeblocks, add the official PPA for the latest version (https://launchpad.net/~damien-moore/+archive/ubuntu/codeblocks-stable) or install it from the official repositories. If you need builddeb, just install it from the official repositories (bzr-builddeb). If you need DoUML, run: git clone https://...


0

Summary of long discussion in comments: do-release-upgrade failed to run because the locales package was not present. So the solution was to install locales, which is a required package. The OP handled a dependency problem when attempting to install locales via apt-get install by using aptitude instead, which suggested solutions rather than just refusing ...


0

Do this and it should be fixed worked for me when i had this problem. sudo apt-get clean cd /var/lib/apt sudo mv lists lists.old sudo mkdir -p lists/partial sudo apt-get clean sudo apt-get update


3

The latest version of the gimp package in the 16.04 repositories (which is 2.8.16-1ubuntu1.1) includes a fix for the XCF vulnerability (CVE-2016-4994). From the Ubuntu changelog: gimp (2.8.16-1ubuntu1.1) xenial-security; urgency=medium * SECURITY UPDATE: multiple issues in XCF channel and layer properties - debian/patches/CVE-2016-4994.patch: ...


-1

GIMP 2.8.18 has not reached Ubuntu repositories yet. If you need 2.8.18 now so badly, you can install it from PPA this way sudo add-apt-repository ppa:otto-kesselgulasch/gimp sudo apt update sudo apt install gimp At the moment of writing this, Gimp will be upgraded to 2.8.18.


0

Instead of getting a fresh version from the Dropbox site, i removed it and reinstalled using the Ubuntu software center, and now it works.


0

If you get the 4.4-31 update today, and install it and realize that your WIFI and other components are not working, perform the following steps after you install the package. sudo apt-get update sudo apt-get install -f sudo apt-get autoremove At this point you'll notice that a bunch of dependencies on previous kernels is being reported, and fixed sudo ...


1

Try getting a fresh release from: https://www.dropbox.com/install?os=lnx Make sure that your browser is logged out from dropbox.com when you visit this link; otherwise download links are not shown.


2

Short answer: yes. Ubuntu 16.04 still includes all its packages for the i386 (32-bit) architecture. Just do a normal release upgrade once the upgrader offers it (once 16.04.1 is released).


1

When your computer boots up, after the BIOS loads, press the Esc key, to see all available Ubuntu boot options. Choose Advanced options for Ubuntu and then choose the Ubuntu, with Linux ... (recovery mode), preferably the one with the oldest version of the kernel. If you can safely login to Ubuntu, backup all your files. If this is all you need, then you ...


0

Well, I took the sledgehammer approach and upgraded to 16.04 LTS. Everything runs as expected. Bummer I couldn't find out what the cause was.


0

When you try to update/upgrade your system at the end of the console output you can view the package name which were unable to update/upgrade. Note the package name and go to /etc/apt/ Inside the directory you will find sources.d directory, go inside the directory and look for the files referring to those packages which were mentioned in the error ...


1

In Ubuntu 15.10, 16.04 or 16.10, open the terminal and type: sudo apt-get install --only-upgrade sqlmap


1

I just solved my problem. I had to untick one of the software sources from my update manager settings. That was after reading about the causes of the error I received. My system was then able to update and is now running fine.


1

You have enabled the saucy-updates repository, however clearly the above two links don't make any sense, since saucy (13.10) can't match with xenial (16.04). You need to edit your /etc/apt/sources.list/ and comment out the two lines that caused you to get the E: Failed to fetch error messages by inserting a # character at the beginning of both of the lines ...


5

Because the first point release of Ubuntu 16.04 is not out yet, attempting to upgrade from Ubuntu 14.04 LTS to Ubuntu 16.04 LTS without using the -d option will fail. The -d option is needed to specify that you want to "upgrade to the latest devel release". In short, you need to specify the -d option: sudo do-release-upgrade -d


0

I had a simalar issue with "cuda-repo-ubuntu1504-7-5-local_7.5-18_amd64.deb" on Ubuntu 16.04LTS after removing the package with: sudo dpkg -r cuda-repo-ubuntu1504-7-5-local Solved it with the next command: sudo dpkg --purge cuda-repo-ubuntu1504-7-5-local


3

A few relatively easy steps are required to get the very latest version of Warzone 2100 under Xenial Xerus: 1. Activate the Source Repositories: Follow this path to activate software sources: Dash > Software & Updates > Ubuntu Software > Source Code After clicking on 'Source Code' allow the repositories to reload. 2. Download the ...


0

I had similar issue, don't know how to solve it permanently, but what I do to connect to the internet is going to System Settings -> Network -> Mobile Network[or sth like that, I don't have english software], then in the select you choose to add new connection proceed normally. It should connect to the internet, and you should be able to ping 8.8.8.8


0

I found the problem: it seems that permissions were misconfigured on my session, all I had to do was to open the terminal (Ctrl+Alt+F2) and change permissions with a chmod 0766 -R *.


0

WARNING: Back up all your data before going any further. The problem is, almost undoubtedly, that you are using third-party repositories while trying to upgrade. Every linux distro seems to break when doing that. So, the solution is to disable those repositories, remove all their software, upgrade, and then re-add any repositories and software you want. ...


1

I had this same problem. Here's how I fixed it: First, I executed this shell command in order to add [arch=amd64] back into the Chrome Remote Desktop repository file: sudo sed -i -e 's/deb http/deb [arch=amd64] http/' "/etc/apt/sources.list.d/chrome-remote-desktop.list" Then I did the same to the Chrome Remote Desktop cron file: sudo sed -i -e 's/deb ...


1

If you are willing to ditch the GUI way of installing updates altogether, then you can just install them using the terminal. Start a terminal by pressing Ctrl+Alt+T and then type in the following commands: sudo apt update sudo apt upgrade


1

sudo update-alternatives --config python There are 2 choices for the alternative python (providing /usr/bin/python). Selection Path Priority Status ------------------------------------------------------------ 0 /usr/bin/python3.5 2 auto mode * 1 /usr/bin/python2.7 1 manual mode 2 ...


0

Before running apt-get install -f see if the postinst script of the kernel package completes its setup. To do this type: sudo /var/lib/dpkg/info/linux-image-extra-4.4.0-21-generic.postinst configure This should complete the postinst process before trying to remove the package, I think.


3

I figured it out phewww - the system was basically useless! Instead of reporting what did not work (e.g. looking at x-0-greeter.log), I will try to summarize what worked. I assume not many people having this issue as it is caused by fingerprint-gui. $ sudo cat /var/log/lightdm/lightdm.log At some point I started comparing my (buggy) log to one in which ...


0

Try adding: [arch=amd64] after deb , but before the URL in /etc/apt/sources.list


2

You can add WebUpd8's PPA at https://launchpad.net/~nilarimogard/+archive/ubuntu/webupd8, which provides Audacious 3.7.2 (and plugins too) for Ubuntu 16.04: sudo add-apt-repository ppa:nilarimogard/webupd8 sudo apt update sudo apt upgrade


0

My workaround has been to disable 3D acceleration in VirtualBox, which seems to be the culprit for this problem. I hope a fix will come out on the VirtualBox side soon. More information is available in this thread a the virtualbox forums Some people have had success running chromium without GPU acceleration using the following steps, although this didn't ...


1

Upgrading directly should work fine (14.10 and 15.04 are EOL anyway). However, LTS to LTS upgrades won't show up until the first point release ("first point release" in this case meaning 16.04.1). You can override this and upgrade anyway by running do-release-upgrade -d in the terminal, but it's typically better to wait for the first point release, which is ...


0

You can directly upgrade from a LTS version (14.04 in your case) to the first point release of the next LTS version (16.04.1) by running: do-release-upgrade Note that, however, the first point release of 16.04 is not out yet. If you still want to upgrade to 16.04 before then, you add the -d option to the previous command: do-release-upgrade -d


2

How to make my package updatable via update manager? How I can make my software installable via apt-get? I want to keep source on my server. For both of these things, you'll need to create a repository to host your package, so that it can be downloaded. The easiest way to do this is to create a PPA on Launchpad. You will then have a PPA / repository,...


0

First of all, I have solution on 11.10, on Ubuntu 11.10 current firefox version is 20. Probably work all versions of Ubuntu. Download latest version of firefox archive from mozilla https://www.mozilla.org/en-US/firefox/new/ extrack on tmp or some other directory. Just use extracted directory. Open new terminal and kill firefox killall firefox Get a root ...



Top 50 recent answers are included