Tag Info

New answers tagged

1

Your problem is not with U1DB, but with the OptionSelector. Let's consider a simpler example: import QtQuick 2.0 import Ubuntu.Components 1.0 MainView { OptionSelector { model: ListModel { ListElement { name: "Item 1" } ListElement { name: "Item 2" } } delegate: OptionSelectorDelegate { text: ...


0

Click packages are the new packaging format used in Ubuntu Touch, and by Ubuntu 14.10, on the desktop version of Ubuntu as well. Some of the features they provide are: Simplified packaging for the developer. The Ubuntu SDK can automatically create Click packages of your Ubuntu Touch apps. If you want to create your own, the format is very simple, ...


2

You should open the file that is mentioned in the error with sudo rights. And you should replace all of these: exports: ["UbuntuColors -1.-1"] exportMetaObjectRevisions: [-1] With something like this: exports: ["UbuntuColors 1.1"] exportMetaObjectRevisions: [1] Save the file and restart qt creator.


1

I found a workaround, although it may not be the best way to do it but it works. first, animations should be changed to PropertyAnimation { id: animationOne; target: bigLike;alwaysRunToEnd: true; property: "opacity"; to: 1; duration: 500 onStopped: animationTwo.start()} PropertyAnimation { id: animationTwo; target: ...


0

AFAIK the recommended way is to use pkcon. Copy your .click file to the device and run the following command on the device itself (by using adb shell or SSH): pkcon --allow-untrusted install-local com.ubuntu.developer.abc.def_0.123_armhf.click This does not require root privileges.


0

You can use the click command to install packages on your device. First copy the .click file on your device. Then use the following commands (e.g after creating a remote session with phablet-shell): sudo click install --all-users ./com.ubuntu.foo_1.0.click --allow-unauthenticated click register com.ubuntu.foo 1.0 Just change the name of the package for ...


0

The problem is not in building, but that your emulator doesn't have the 15.04 framework on it. You might try downloading a newer emulator image, but I'm not sure if the 15.04 framework has made it onto them yet. The --force-missing-framework option is meant for the install command running on the emulator, not your build command. If you copy your click ...



Top 50 recent answers are included