Tag Info

New answers tagged

0

Did you install the qt sdk, you have a lot libqt unmet dependencies sudo apt-get install qt-sdk And try again


0

Have you associated your emulator with you kit? To do this, go to Tools > Options > Build & Run > Kits and select your kit ("UbuntuSDK for i386 (GCC ubuntu-sdk-14.04-trusty)", judging from the error message. Make sure "Device Type" is set to "Ubuntu Device (i386)". Then select the correct emulator instance from the "Device" options. Here are the ...


0

I think what you need is the ListItem.Expandable SDK component. It was added in the 14.10 SDK Framework which is at the time of writing this answer is a development framework. It provides the capability to collapse and expand the listitem on clicking it. I would recommend you read the API documentation here to learn more about the component and see how to ...


1

It is quite simple to do the above. To set automatic focus to the TextField component, you can call forceActiveFocus() from within your TextField component as shown below, Component.onCompleted: { forceActiveFocus() } This sets the focus to the textfield immediately after it is loaded. As for showing the numpad, you can do so by setting the input ...


2

You can make a Flickable scroll to a specific point by setting the contentY property of a Flickable. Quoting the official documentation from qt-project.org, ContentY holds the surface coordinate currently at the top-left corner of the Flickable. For example, if you flick an image up 100 pixels, contentY will be 100. So if you want to scroll a ...


0

This is because you are running an out of date version of the Ubuntu SDK. The Ubuntu SDK is no longer updated on Ubuntu 14.04 (Trusty) even if you have added the SDK PPA. This is because the Ubuntu SDK requires Qt 5.3 which is only available in Ubuntu 14.10. You can solve this by, Using the Emulator for testing your applications. So you code on Trusty, ...


3

The simplest solution would be to set width: parent.width/4 for each of the checkboxes. If you want to keep the checkbox width set at some known value, you could instead set spacing: (parent.width - 4 * checkboxwidth)/3 on the Row. Note that this will cause the elements to overlap when the parent is narrow. If you're targeting Qt 5.1 or higher, you may ...


0

Just use visibility: visibility: "Maximized" The doc reads as: visibility : QWindow::Visibility The screen-occupation state of the window. Visibility is whether the window should appear in the windowing system as normal, minimized, maximized, fullscreen or hidden. To set the visibility to AutomaticVisibility means to give the window ...


2

Component.onCompleted runs as soon as the interpreter has read the QML file and parsed it into objects. Your "page 2" object is created at this time, but it has visible: false so you can't see it. That doesn't keep the onCompleted code from running. I know of three ways to get code to run only when the page gets pushed to the stack: Create a custom ...


2

Use this instead: onCurrentlyExpandedChanged: { flickable.DragOverBounds flickable.contentHeight += itemHeight console.log(itemHeight) }


1

Try this: Go to Tools > Options > Build & Run > Qt Versions. Check if there is a version mentioned there. If not, select Add... and choose /usr/lib/i386-linux-gnu/qt5/bin/qmake and try to build again. Note: Please adjust the above path according to your installation, especially i386-linux-gnu, which might be something like amd64-linux-gnu if you're ...


0

Remove "opacity" and use semi transparent colors: color: Qt.rgba(0.239, 0.237, 0.237, 0.3) http://qt-project.org/doc/qt-4.8/qml-color.html Thanks for the hint http://stackoverflow.com/a/17244302


3

You need to set the useDeprecatedToolbar property of your MainView to false. This is temporary because we are currently supporting an old API (tools for toolbar), and a new (actions to go in the header). For Ubuntu.Components 1.1, the default value of useDeprecatedToolbar, which is now true, will be changed to false in the very near future (this week or the ...


1

Since Unity 8 (and unity-scope-tool by extension) are designed so they can run under both Mir and X11, there is some ambiguity in the dependencies. The error you got indicates that it is trying to use the Mir backend. You should be able to fix the problem by installing the unity8-fake-env package, which provides some of the needed APIs to run the tool ...



Top 50 recent answers are included