Tag Info

New answers tagged

0

You can use xclip to get clipboard text to/from your x server to/from the remote system if you used -X in your ssh command when you made the connection. You have to have xclip installed on the system to which you are attaching. I imagine other clipboard apps can do it to. But anyway, configure tmux to call xclip, and you should be good. For example: ...


1

For proper installation, follow this order: Install zsh Run zsh from your terminal/bash Set zsh as default terminal/bash Setup tmux to run as default After zsh is installed, run it from terminal $ zsh now set zsh as default Shell with $ chsh -s /bin/zsh Note that you must be on zsh when typing this command (tested this on my Ubuntu 14.04.2 LTS - ...


1

In the gnome-terminal.desktop file, you need the Exec to contain the command exactly as you would run it via a shell. In this case, the gnome-terminal executable e parameter needs a quoted string to execute: Exec=gnome-terminal -e 'tmux -2'


2

Sorry, gnome-terminal doesn't support this. The actual emulation is handled by the vte widget. In its source code, src/caps.c contains the table where matching/parsing the incoming escape sequences begins. \e] is called OSC here, and OSC "52..." is not defined here.


1

First of all I'd like to confirm what you've already figured out, namely that directly under gnome-terminal (that is, outside of tmux or screen) you should set TERM=xterm-256color, whereas inside tmux or screen it should be set to TERM=screen-256color. Apparently your .zshrc segment properly sets it for the shell that's run directly by gnome-terminal. I'm ...



Top 50 recent answers are included