Tag Info

Hot answers tagged

26

Instead of ntpdate (which is deprecated), use sudo service ntp stop sudo ntpd -gq sudo service ntp start The -gq tells the ntp daemon to correct the time regardless of the offset (g) and exit immediately (q).


21

Any idea how I change from IST to GMT? To switch to UTC, simply execute sudo dpkg-reconfigure tzdata, scroll to the bottom of the Continents list and select Etc; in the second list, select UTC. If you prefer GMT instead of UTC, it's just above UTC in that list. :)


20

As a regular user run this in a terminal when using gnome-shell: gsettings set org.gnome.shell.clock show-date true For 12.10, use this instead: gsettings set org.gnome.desktop.interface clock-show-date true Hope this is what you're looking for!


19

Probably the ntp service is running, that's why ntpdate can't open the socket (port 123 UDP) and connect to ntp server. Try from command line: sudo service ntp stop sudo ntpdate -s time.nist.gov sudo service ntp start If you want to put this in /etc/rc.local use the following: ( /etc/init.d/ntp stop until ping -nq -c3 8.8.8.8; do echo "Waiting for ...


15

Because of the way the two operating systems set the hardware clock. by Default ubuntu uses UTC, and windows localtime. So when you shut down, your hard ware clock is set to say "13:00". When you boot, windows sees "13:00" as localtime, so 1 PM, but Ubuntu sees that as UTC and so converts the time back from UTC to local time. You can fix this by either ...


12

The normal way : Go to System -> Administration -> Language Support On the Text Tab, choose your prefered language to display numbers, dates, ... The advanced way for your Desktop Applet : Press Alt+F2 Type: gconf-editor & Hit return Navigate to “Apps > Panel > Applets > Clock_Screen0 > Prefs” Double-click on the ‘Format’ value. Change it to ...


11

Yes, run this command in a Terminal: gsettings set org.gnome.shell.clock show-seconds true And you can verify with: gsettings get org.gnome.shell.clock show-seconds Or you can install dconf-tools and use dconf-editor to browse to org.gnome.shell.clock


10

Sounds like you have a timezone issue. The easiest way to fix this is to reconfigure the tzdata package sudo dpkg-reconfigure tzdata There are alternative ways, like symlinking the correct zonefile from /usr/share/zoneinfo to /etc/localtime which will inform the system of the proper time: ln -sf /usr/share/zoneinfo/America/New_York /etc/localtime ...


10

After mucking around for most of the day, I have come to the following conclusion: ntpdate-debian is the version to use if you want to use a config script, and in that case, you would edit the /etc/default/ntupdate file. ntpdate cannot be used without arguments nor does it have a config file. If you want to use this to update, you have to state the ntp ...


9

I don't think you can achieve exactly the same effect without modifying the bash source. But you can get close, hopefully close enough for you. You can combine bash's hacky precommand hook and the SECONDS variable to show the wall clock time in a non-intrusive way. Here's a simple implementation due to Ville Laurikari. The functions timer_start and ...


9

Reference: http://www.maketecheasier.com/date-time-missing-ubuntu-1310/ 01) Reinstall indicator-datetime. It should be installed by default, but just in case you have removed it unknowingly, it is best to run the install command again. sudo apt-get install indicator-datetime 02) Next, we are going to reconfigure the date time: sudo ...


8

I'd switch to a virtual terminal at the GDM login screen (Ctrl+Alt+F1), log in and start iotop (you maybe need to install it first). Then switch back to GDM (Ctrl+Alt+F7), log in, and immediately switch back to iotop using Ctrl+Alt+F1. You should now see, which process is responsible for the heavy IO. Forgot to mention an alternative: you could try using ...


7

You'll have to do some manual editing using nano, or your editor of choice: sudo nano /etc/default/ntpdate and change the NTPSERVERS="ntp.[your-server-here]" If you restart your computer this change will be made active. If you're feeling impatient and don't want to wait for the server to automatically update you can do it manually: sudo ntpdate-debian ...


7

As mentioned in another answer, if you are running Ubuntu as a Guest under VirtualBox then you should be aware that the system time is automatically kept in sync by the Guest Additions (i.e., not through an option in the motherboard settings). Your solution in that case is to disable the Guest Additions, which can be achieved by executing sudo service ...


7

If you want to change the time format to German , you must install the German language from the Language Support and then set the "Regional Settings" in German If you want to change the format in Date and Time , you must install dconf-tool . From terminal do sudo apt-get install dconf-tools Find it through Dash by writing dconf open it and goto Com ...


7

ntpdate is a program different from the net dameon. NTPDate is probably erroring out on boot because ntpd is running on that socket. From the command line, run # sudo service ntp stop ; sudo ntpdate -s time.nist.gov ; sudo service ntp start You could also uninstall ntpd all together (apt-get remove ntp) and add a cron script to use ntpdate every hour or ...


6

You can set the hardware clock with the command (for example) sudo hwclock --set --date="2012-12-15 20:49:00" You then need to syncronise the system clock to the hardware clock: sudo hwclock -s Reference: $ man hwclock


6

In fact, the GNU date command (which is the standard implementation in Ubuntu) can add date offsets directly - for example to add 3662 seconds (1hr, 1min, 2sec) to a given date $ date '+%d.%b.%Y %T' --date="2012-06-13 09:16:16 EDT + 3662 seconds" 13.Jun.2012 10:17:18 However, some care is required with timezones and daylight savings - a safer option is ...


6

ntpdate is deprecated as of September 2012; apparently ntpd now has the ability to do one-time updates if needed, and ntpdate is based on "long-neglected" ntpd code. (News to me, since my system has ntpdate but not ntpd! I'll be fixing that presently; thanks for asking this question.) As for the difference between continuous versus periodic updates, I think ...


6

Click on the clock, and then select time and date settings, and then select "Manually" You can also ensure the ntp package is not installed (clicking on the button will show if you if you have it installed or not:


6

Edit the file /etc/default/rcS with your favorite text editor, ie: sudo nano /etc/default/rcS Look for the UTC=foo (yes/no) line and change it to UTC=yes. From the rcS(5) man page: UTC This is used to govern how the hardware real time clock is interpreted when it is read (e.g., at boot time, for the purpose of setting the system clock) and ...


6

The clock loosing time is most likely to be caused by a fault CMOS battery. You can work around it by running ntp. You can do this easily via the clock. Click on the clock and choose the bottom option of "Time & Date Settings..." You have to "unlock to change these settings" and enter your password. Near the bottom, where it says "Set the time", ...


6

There are a couple of shutdown timers available on Launchpad that look interesting. Easyshutdown - simply shuts down your PC ComplexShutdown - it has much more options such as hibernate/suspend etc.


6

You want -P, not -p. It's case sensitive. Also realize that you'll have to be root to shutdown like that. For the time, there are different ways to enter. Taken from man shutdown: TIME may have different formats, the most common is simply the word 'now' which will bring the system down immediately. Other valid for‐ mats are +m, where ...


6

If you install the tzdata source package, you will find all your answers: sudo apt-get install apt-src mkdir tzdata && cd tzdata apt-src install tzdata Specifically: posix and right: Two different versions are provided: - The "posix" version is based on the Coordinated Universal Time (UTC). - The "right" version is based on the ...


5

There is no easy way of achieving this. cron uses the local time. /etc/default/cron and other TZ specifications in the crontab just specify what TZ should be using for the processes started by cron, it doesn't impact the start time. Most solutions I have seen involve a utility in the middle, so cron would kick off something that would then determine when to ...


5

Launchpad bug #863341 has the solution to my issue: $ sudo dpkg-reconfigure --frontend noninteractive tzdata After I ran the above command, "Time" disappeared and the current time is now displayed in my menu bar. The bug also notes that this question has previously been discussed on askubuntu.


5

To set the language for menu's and windows, perform the following steps: Goto XFCE->Settings Manager-> Language Support It might ask to install a few things, allow this. Press install / remove languages. Check the language which you want to use Drag your language to the top of the list and press Apply System Wide. Done To set the time correctly, perform ...


4

Look at date --help: Usage: date [OPTION]... [+FORMAT] and it gives a list of date format specifiers. To get the format you want (assuming you want local time, and all fields padded with zeroes, 24-hour time), use the format specifier [%d-%m-%Y/%H-%M-%S]. That is, run username@host:/path$ date '+[%d-%m-%Y/%H-%M-%S]' [19-12-2012/17-16-16] To redirect ...


4

Ok, solved it: 1) Make sure you have the locale you need, can't say which you specifically need but when you know you create it like this (using en_DK.utf8) sudo locale-gen en_DK.utf8 2) To make sure this locale is in effect for thunderbird you add it to the script that starts thunderbird, so first find that script: 2a) find the right script which ...



Only top voted, non community-wiki answers of a minimum length are eligible