New answers tagged

1

See https://bugzilla.kernel.org/show_bug.cgi?id=109051 The following eliminated the problem for me. Edit /etc/default/grub. Change the line GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" to GRUB_CMDLINE_LINUX_DEFAULT="intel_idle.max_cstate=1 quiet splash" then do sudo update-grub and reboot.


-2

I was experiencing the same problem. This worked for me: http://www.cyberciti.biz/faq/debian-ubuntu-building-installing-a-custom-linux-kernel/


0

I have an x1 carbon 4th gen which has the same fingerprint reader. I looked through the upstram libfprint source, and it doesn't look supported yet, so that's why it's not working. You will likely have to wait till someone creates a driver for it.


1

Try installing newer kernels. In some cases, it fixes the problem of freezing that caused by bad high precision timer code. This is binary for Linux 4.5.2: http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.5.2-wily/ Download appropriate 3 .deb binary packages, install them, and reboot to the new kernel.


0

It looks like Ubuntu 16.04 does not install unsigned third party packages if Secure Boot is enabled. You need to disable Secure Boot in UEFI settings to get wl work. But that is a problem, because on some systems Secure Boot can't be disabled. Update: This issue can be fixed. You can disable validation of modules by: sudo apt-get install mokutil sudo ...


2

I have a Lenovo T440p and my wireless works perfectly. lspci -nnk | grep 0280 -A2 03:00.0 Network controller [0280]: Intel Corporation Wireless 7260 [8086:08b2] (rev 6b) Subsystem: Intel Corporation Wireless-N 7260 [8086:c262] Kernel driver in use: iwlwifi


1

I haven't had any issues with WiFi on a T530 and a new T560 (16.04) in the past. Be sure to get the Intel WiFi option, the modules should be the same in the 14 inch models. From the T560: 04:00.0 Network controller: Intel Corporation Wireless 8260 (rev 3a)


0

It seems to have been a connection issue - I took the machine apart, re-seated the keyboard and trackpad connectors, and haven't had any problems since. Hopefully will stay that way.


0

For my Thinkpad T530, and Ubuntu 15.10. Just use: sudo -i gedit /etc/udev/rules.d/10-trackpoint.rules and then add the following content on, then restart. The setting value will be kept. ACTION=="add", SUBSYSTEM=="input", ATTR{name}=="TPPS/2 IBM TrackPoint", ATTR{device/sensitivity}="190", ATTR{device/speed}="180", ATTR{device/inertia}="6", ...


1

There isn't enough information to diagnose this so you should file a bug. I'm assuming when you mention 'freeze' the computer needs to be completely power cycled to use it again. With that it is most likely a kernel issue. The following link explains how to file a bug against the Ubuntu kernel: https://wiki.ubuntu.com/Kernel/Bugs Another approach is to use ...


0

I'm experiencing a kernel bug with the Intel Baytrail processors that this line of laptops use: https://bugzilla.kernel.org/show_bug.cgi?id=109051 There seems to be a workaround, but it isn't proven reliable.


2

My T460s shipped with the graphics memory turned down to 256MB in the BIOS setup. Go in there and crank it up to 512. When I did that, the UI sluggishness I experienced went away.


2

Modifying the file /etc/default/grub and inserting i8042.reset in the quote on the line starting with GRUB_CMDLINE_LINUX_DEFAULT. Then save your modification and start sudo update-grub. It should work.


2

This device is used for harddisk shock prevention, and its detection as a joystick is an error. You get this error message because testing a non-joystick with the joystick tester doesn't work for obvious reasons. To get it to work, at least on other thinkpads, you can install hdapsd. It needs to be run as a daemon - it reads the accelerometer data and parks ...


1

I suggest updating to latest-ish kernel. I also had to add "intel_pstate=no_hwp" to my grub cmdline


0

Make sure your cpu usage is not too high. Disable bluetooth, and if you can, put your cpu in low power mode.


0

So I eventually found the problem, in fact @M.Luethi was right, intel_pstate was causing this. So, in the boot screen, instead of directly launching Linux, I pressed 'e' to edit the command before executing. At the end of it, I added intel_pstate=disable and it worked fine afterwards.


1

As has been said earlier, software can't control what power is sent out to what USB ports, however depending on the spec, to which the port was build, will depend on what the electroncis will kick out of it. It sounds like you need to get back to basics to work out what power you have/need. I've had similar problems with USB and Raspberry pi. The ...


0

It is probably Synaptics touchpad, you can change your preferences in Mouse & Touchpad settings. If this doesn't help you can play with specific Synaptic settings by synclient command. Type synclien -l to list all possible settings You can also check this: https://help.ubuntu.com/community/SynapticsTouchpad#Control_touchpad_features_using_synclient


1

The Lenovo variant of the EM7455 has a feature we know as "FCC_AUTH" turned on. This disables the radio until the driver sends a "magic message" to the modem. This feature is well known from older Sierra modems. ModemManager supports the magic message for modems in QMI mode, but we have so far got away with ignoring it in MBIM mode. The EM7455 changes ...


0

I am going to go ahead and answer my own question, and hopefully this will help someone! Well, it turns out that if you hold down the power button for around a second, the menu comes up!


1

You might try the tlp package for Thinkpad power management, it provides some USB options: http://linrunner.de/en/tlp/docs/tlp-configuration.html#usb Read the install instructions carefully, it is incompatible with laptop-mode-tools (uninstall first). # tlp stat| grep -i USB shows the info about USB device manamement then.


-1

same issue for me with a x1 4th generation. i am able to make the installation of ubuntu by adding intel_pstate=no_hwp to the kernel parameters but at reboot, shift or esc keys does not help me to reach grub menu to add kernel parameters for normal boot. With shift press it gets hanged on "lenovo" logo and release/hold shift does not help. Any idea ?


2

Solution So the very problem was that for some reason, intel_pstate is not supported. As explained in the Reddit thread. The solution was to deactivate intel_pstate in the kernel boot parameters. What I did not get, was how to modify the boot parameters manually for the Ubuntu Startup-USB. This is done by entering the F6 menu and exit the menu right away. ...


0

Here $ synclient TouchPadOff=0 worked. I'm not yet sure, whether it is necessary to add this to ~/.profile as described in my source http://thinkwiki.de/Debian_Schnelleinstieg#Touchpad_deaktivieren (german).


3

First set the UEFI/Legacy Boot Priority in BIOS to UEFI First. Boot Windows and create the USB using the diskpart tool. Open command prompt as administrator and execute : diskpart list disk select disk * clean create partition primary active format fs=fat32 quick assign letter=** Note: * = number of USB drive | ** = select a free drive ...


1

I have ThinkPad yoga260 with Ubuntu14.04. Before that i had a Windows 10 with system encryption by TrueCrypt7.1. And I had the same problem with the internal keyboard. Sometime i could not input password for TrueCrypt bootloader. I was needed to plug usb keyboard to input TrueCrypt password and start Windows. In Windows internal keybord worked normaly. And ...



Top 50 recent answers are included