Hot answers tagged

2

I found this looking for the solution to the same problem (this is still happening on Xubuntu 16.04, so updating to a supported release does not solve this issue). I don't know how to prevent this, but I can reliably recover the mouse cursor without rebooting. Open the display manager (Super + P) and make any change you want (change the screen resolution, ...


2

You should be able to create a script in the /etc/pm/sleep.d/ directory (or supposedly the /lib/systemd/system-sleep/ directory if you are running 15.10+) which executes that restart command on system resume. Make sure to make that script executable. Create a network_restart file in said directory with these contents: case "${1}" in resume|thaw) ...


2

I have the same card but I am running 14.04 and using the open source drivers. There is a bug in the driver which prevents the system from waking up after suspend operation. I believe the bug just got carried forward to the new drivers.


2

For me, both poweroff nor reboot needs a password on Ubuntu 16.04 . However, for this to occur, I had to create a user account called "foo", for example, and then ssh to localhost as either that user or as myself. When I do this, I do need to authenticate myself. It seems to recognize another user is logged in. For example, I get this message: User ...


2

If you don't mind using a terminal, you can do it this way. Execute : sleep 2h 45m 20s && systemctl suspend -i It suspends your system in 2 hours, 45 minutes, 20 seconds. I wrote a script for getting a GUI like this: Copy the content of the script below and save it in your home directory as fast_suspend.sh. #!/bin/bash # Tested on : ...


2

I figured it out so I'm posting an answer for those who are stuck like me. Since pm-suspend worked perfectly for me, I edited this file: /etc/default/acpi-support Looked for this line: SUSPEND_METHODS="dbus-pm dbus-hal pm-utils" Changed it to this: SUSPEND_METHODS="pm-utils" Now it works like it should!


1

I had the same issue with my Dell with ATI grapics. I installed the 4.4.8 kernel release and fixed sleep and flaky wifi issues. To check if you have older kernel: uname -a Steps to install 4.4.8 kernel: http://linuxdaddy.com/blog/install-kernel-4-4-on-ubuntu/


1

Sounds like it's a very new laptop. Maybe it's not fully supported just yet. You could try one of the mainline kernels, with better AMD support by amdgpu. Get the files from here: http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.6-yakkety/ download linux-headers-4.6.0-040600_4.6.0-040600.201605151930_all.deb, ...


1

This could solve your problem. I once had this problem and i solved it using this method: Open a terminal: Ctrl + Alt + t Open logind.conf by running command sudo vim /etc/systemd/logind.conf and remove the # before HandleLidSwitch=suspend. You can also change the option suspend to hibernate or poweroff Fix from Launchpad Bug #863834, comment #30: ...


1

I have had a nearly similar problem with NUC's specifically with wireless K/B combo's. Use an USB extension cable for the K/B & Mouse Wireless receiver. I have had 2 separate situations where the inputs from the K/B & mouse were freezing the NUC, and had to reboot via power button - admittedly running W10 though..To test my theory I used a wired ...


1

Q1. How do I know if pressing the Suspend button in Ubuntu 16.04 will lead to S1, S2, S3, S4, or S5? Ans1: On my system, I found the information in the file /proc/acpi/wakeup. Also, the commands acpitool -w or acpitool -e present the same information as that found in /proc/acpi/wakeup. Q2. Is this (i.e. ACPI Global State) determined by settings in the ...


1

It depends on Ubuntu (and the BIOS capabilities). It couldn't be any other way because the operating system needs to coordinate a great deal of things to enter any state above S2. The BIOS may however inform the operating system that it would like to enter a particular state. There are two suspension modes in Ubuntu, Linux and modern PCs in general: ...


1

After an apt-get update; apt-get upgrade; apt-get dist-upgrade yesterday, suspend started working again. And booting from the default kernel stopped the "failed to disable graphics turbo" messages. And I haven't had any crashes since then either --- so I think all is well again. TL/DR: 'apt-get update; apt-get dist-upgrade' fixed everything


1

Unfortunately, I am experiencing the same problem and I do not have a solution, however, I do have a work around this. When you open your laptop lid, bring up a virtual terminal by pressing control, alt, and f1. Then exit the virtual terminal by pressing control, alt, and f7. This will lead you to your normal login screen. However, after I do this, another ...


1

I had the same problem after upgrading from 15.10 to 16.04: Closing the lid did not do anything Manually suspending with the menu item in the system tray resulted in a half suspended state with the only way out to reset the system. I solved these issues by upgrading the kernel to 4.4.8 (after this suspend from menu worked for me) Adding the line ...


1

An easier way would be to put your startup commands in a script, and invoke that: # You could put the file in any other directory that is mounted # early in boot time (not your HOME directory) cat >>/var/local/foo <<EOF #!/bin/bash # Suggestion: use absolute path: /usr/local/bin/rtl_tcp rtl_tcp sleep 4 # Warning - MUST specify absolute path! ...


1

You are likely experiencing this bug. To fix, try installing a new kernel. Commands for 64 bit system: cd /tmp wget \ kernel.ubuntu.com/~kernel-ppa/mainline/v4.5.2-wily/linux-headers-4.5.2-040502_4.5.2-040502.201604200335_all.deb \ kernel.ubuntu.com/~kernel-ppa/mainline/v4.5.2-wily/linux-headers-4.5.2-040502-generic_4.5.2-040502.201604200335_amd64.deb ...


1

I have no idea why great Ubuntu team did not implemented "power off when lid is closed" option. I have laptop with cooler powered trough the USB and my USB port is always ON when laptop is in suspend state, so suspend is not good option for me. Anyway finally I found solution and is working for me (Ubuntu 16.04 with two internal HDD's and external monitor). ...


1

Same problem here. I have to force shutdown by pressing the power button and start again to get back the system working. I discovered this problem after upgrading my Xubuntu from 15.10 to 16.04 amd64. After that, I have done a zero installation for Xubuntu 16.04 amd64, cleaning all the disk, but the problem with the suspend was kept. $ lspci | grep VGA ...


1

I had the same problem running Ubuntu 16.04 on the same laptop (both with and without the power connected). In desperation I updated the kernel from 4.4 to 4.5.3 (see here and here for instructions) and the problem seems to have gone - both for closing the laptop lid and selecting 'suspend' from the menu.


1

The setting only affects the logged in user. To set it system wide you need to edit the file /etc/systemd/logind.conf and modify the line: "#HandleLidSwitch=suspend" to HandleLidSwitch=ignore Then either reboot or use: sudo restart systemd-logind or sudo systemctl restart systemd-logind.service For the newer systemd.


1

Edit this file /etc/default/acpi-support (sudo your favorite editor) Change the line SUSPEND_METHODS="dbus-pm dbus-hal pm-utils" to this SUSPEND_METHODS="pm-utils"



Only top voted, non community-wiki answers of a minimum length are eligible