Tag Info

New answers tagged

0

There seems to be more than one issue: 1. Bug #1276348 ssh-agent is missing in backintime-kde in versions <= 1.0.34. Please install this patch with sudo patch /usr/bin/backintime-kde4 < backintime-kde4.diff 2. sudo vs. kdesudo sudo doesn't change $HOME but kdesudo does. $ sudo env | grep ^HOME HOME=/home/germar $ kdesudo env | grep ^HOME ...


1

That guide unfortunately uses pretty quotation marks “” instead of just "". See the difference? So go back, check each file you have edited, and each thing you have copy-pasted and change the pretty quotation marks to "". Oddly enough, it adds a couple of aliases to your .bashrc, which I do not see in this file that you posted (which you call dot.bashrc - is ...


1

Make the script executable with: chmod +x ./OculusConfigUtil_i386 Then run it with ./OculusConfigUtil_i386. Both errors result from the missing execute premissions.


1

According to sudoers manual: It is generally not effective to "subtract" commands from ALL using the ’!’ operator. A user can trivially circumvent this by copying the desired command to a different name and then executing that. For example: bill ALL = ALL, !SU, !SHELLS Doesn’t really prevent bill from running the commands ...


0

You can freely type your password and press enter when done. It does not show anything. If your password is PASSCODE, then you'll type exactly that and press enter after E. It's not "letting you not to type," it's just not showing that.


9

Passwords are NOT visible when typed. At the prompt you need to insert your sudo password and then the commandline will come back. There could be some information about the command you issue but in general nothing is shown unless there is an error.


2

With the sudoers mechanism you can give specific privilege to a specific user or group. To edit the /etc/sudoers file you need to use visudo. e.g. to give or negate only some specific commands to the user igor you can add the line igor ALL=(ALL) /bin/kill, /usr/bin/, !/usr/bin/apt-get in this example the user igor can execute with sudo all the ...


0

It sounds like it is asking for the root password. Are you the administrator on the computer? If you are, try using passwords like Root or Password because it sounds like it isn't using your password. Sadly since you are messing with system files when installing software, there is no way to disable the password. Hint: Instead of typing Sudo in front of ...


0

Your sudoers configuration is right, in fact when you exec: sudo -u www-data /usr/bin/php test.php it work as expected. In normal operation, your apache runs as root and use mpm-itk module. Here is the problem. According to mpm-itk documentation: Since mpm-itk has to be able to setuid(), it runs as root (although restricted with POSIX ...


0

Try this command to trace where sudo is hanging strace sudo Why this happens This happens if you change the hostname during the install process. To solve the problem, edit the file /etc/hosts http://serverfault.com/a/65377 Another Link to a similar question: Sudo hangs without prompting for password


0

A couple of questions: Have you changed your hostname recently? Can you run any other sudo command without a hang? e.g. can you run "sudo vi /path/to/file" or (my favorite) "sudo bash"? Do you still notice that sudo hangs in those cases as well? Here is what you can try: (from here: ...


1

Well, your pasted data has all some useful info: COMMAND=/usr/bin/env -u LANGUAGE LC_MESSAGES=C /bin/sh /tmp/tmpBHXhYV/:script: So env was called to execute ~/tmp/tmpBHXhYV/:script:` with sh. If that file is still there, it might help you. It was not called from a TTY, so probably from within another running application.


1

The problem is that ownership of your file is: user=root group=erelsgl. User root belongs to root group. So to fix your problem: chown root:root <filename> chmod u+s <filename> After that you can remove sudo directive in your script. I tested this on lubuntu 12.04. Another better approach to this kind of problem is configure ...


0

$ exec su -l kev /// refresh group membership without logging out (source) $ newgrp groupname /// make groupname your default group for the entire session $ groups /// print current group membership to verify (source)


0

Finally I solved it using gnome-system-tools


1

Rahul, first of all you should repair the sudoers file. create a sudoers file on desktop ans paste these lines into it: # # This file MUST be edited with the 'visudo' command as root. # # Please consider adding local content in /etc/sudoers.d/ instead of # directly modifying this file. # # See the man page for details on how to write a sudoers file. # ...


0

You are putting the wrong password. sudo passwd is changing the password of the root user, not the password required to sudo. In addition, the root account is usually locked in ubuntu, so you cannot become root via su or su root, see here. Whatever you did to 90-cloudimg-ubuntu is probably not related to the authentication failure. Are you sure that ubuntu ...


0

The behaviour you're describing is normal, because the root account is locked by default in Ubuntu. If you need an interactive root shell you should use sudo -i instead of su For further information, see the discussion at RootSudo


0

Most of the time GUI is gksudo so try using gksudo instead of sudo and tell me if it worked ~rainbow dash


0

from term sudo nano /etc/sudoers under line after root line add the line below username ALL=(ALL:ALL) ALL or group Members of the admin group may gain root privileges %domain\\domain^Users ALL=(ALL) ALL


0

For sudoers file: In a terminal type: sudo visudo and got to line # Members of the admin group may gain root privileges %admin ALL=(ALL) ALL add your domain like this: %domain\\domain^Users ALL=(ALL) ALL but I advice you to use the LikewiseOpen


-1

It's because Nautilus is out of date. Go to http://askubuntu.com/a/460497/299605 for instructions on updating it.


5

If your script runs as "yourUser", you could create a simple file: sudo visudo -f /etc/sudoers.d/myOverrides with this directive: yourUser ALL = NOPASSWD:/usr/bin/apt-get You can find an useful explanation here.


2

Ok. I have fixed my issue. And like I thought, it was not the file. Solution I had up until 10 minutes ago, only noticed that sudo wasn't working. As most of my work takes place in tmux, I never noticed my user account. Upon first logging in I would get the following error: -bash: /etc/profile Permission denied And it would set me to: I have no ...


0

The reason for the warning is that you are running a GUI app with sudo - this can lead to several problems (one of them: you might not be able to log in again, because your Xauthority file belongs to root). There used to exist a "graphical" sudo - gksudo or gksu or kdesu which prevented that problem. With current Ubuntu versions the proper way to execute ...


0

it's because you are running the application in foreground of you'r terminal press ctrl + z then type jobs command and check the number of that gedit first.ccp process type bg [the number you checked in jobs command ] you won't see those warnings anymore.


3

The message is coded into sudo and you can either recompile (I doubt you want to do that) or configure sudo. I HIGHLY SUGGEST you use visudo . visudo checks the syntax of your sudoers file and helps reduce the possibility of breakage due to a typo. See https://help.ubuntu.com/community/Sudoers You add or edit the line(s) Defaults lecture_file = ...


0

Try exporting the Variable Ie: $ SUDO_EDITOR=/usr/bin/vim $ export SUDO_EDITOR A new shell is started when you run the command and if this variable is not exported it will not exist in the new shell.


0

edit: I misunderstood your question (before your edits). Your target system seems to be set up without execute rights for all on the /bin/* content. That is either intentional, or a configuration error. ls -al /bin (as root) should show you if that is the case. For example, on my system, I get: ls -al /bin/ls -rwxr-xr-x 1 root root 110080 Mar 24 15:35 ...


0

You NEED to go and create the directory as root. mkdir -m 750 /var/log/sudo-io then you need to enable logging in the sudoers file: Add the following 3 lines........ Defaults log_output Defaults!/usr/bin/sudoreplay !log_output Defaults!/sbin/reboot !log_output Good luck :)


1

Sudo doesn't behave that way, for security reasons. You can echo the password to sudo using the -s option, but I don't suggest it. Even if you protect your script from other users, they can still see your parameters using e.g. ps -ef. I think your problem is better solved by installing the unattended-upgrades package.


1

The 'rm' command does not employ the Trashcan mechanism of Unity. You may be able to employ some of the tools mentioned in How to recover deleted files?, however it might already be too late - one of the first steps in a situation like this is "stop using the hard disk"


0

First you should mount the partition in read only mode to prevent the OS accidentally overwriting the deleted content. You could try it with PhotoRec. Although there is "Photo" in the title it can recover any files. You need a second partition in which PhotoRec then writes the recovered files. Because it can't check how recent the file was deleted, it will ...


1

If you use NetworkManager, you can try this command to toggle wifi off and on: nmcli radio wifi off nmcli radio wifi on This commands works over D-Bus and is about the equivalent to rfkill block wifi; rfkill unblock wifi.


2

I guess the following would work to install the package to a directory: ~/local/ Download the package as package.deb using : apt-get download <package_name> Then run dpkg --install package.deb --instdir=~/local


2

As mentioned in one of the comments, use apt-get just to download, then dpkg -i to install. mkdir $HOME/.local apt-get download <package_name> dpkg -i --force-not-root --root=$HOME/.local <package_name.deb> Note: what's nice is that apt-get automatically picks the package that fits your Ubuntu distribution and your architecture.


1

Extending time: From the sudo man page : -v When given the -v (validate) option, sudo will update the user's cached credentials, authen‐ ticating the user's password if necessary. For the sudoers plugin, this extends the sudo timeout for another 15 minutes (or whatever ...


0

You can get that done in the same way as you would do it for other users: By adding the new alias to the user's ~/.bashrc file (for root user the absolute path is /root/.bashrc); (Preferred method as you can have all custom aliases and functions under one file.) By creating, if it is not there, and adding the new alias to the user's ~/.bash_aliases file ...


2

You should add that alias command line to .bashrc file in /root folder and not in /home/user/.bashrc(this .bashrc file belongs to user account not root). By doing so .bashrc file in /root is run at root login, your alias command will be automatically created every time. So that you can use your alias command directly in shell when logged in as root.


0

use sudo or gksu $ sudo nethogs or $ gksu nethogs


0

try this sudo awk -v LIMIT=50000 -F: '($3>=LIMIT) && ($3!=65534) {print $1}' /etc/passwd | tee - |sudo egrep -f - /etc/shadow > /home/bulgarini/server_transfer/shadow.sync or sudo awk -v LIMIT=50000 -F: '($3>=LIMIT) && ($3!=65534) {print $1}' /etc/passwd | tee - | sudo egrep -f - /etc/shadow > ...


1

See the permisions of /etc/shadow file: ls -l /etc/shadow The output is something like: -rw-r----- 1 root shadow 1530 apr 10 08:47 /etc/shadow So, only root and those users from shadow group have permissions to read that file. So, in conclusion, you need to run that command as root. If you think that you run that compound command as root because you ...


1

There's no solution for this bug at this moment because there no root user in ubuntu Linux os, what I'm trying to say is that issues is impossible to solve , 'you need the root access to give permission' , 'ubuntu root access by sudo' , 'sudo is broken' so you can't solve sudo when it doesn't work ,'su' command needs a root user, when you try give 755 ...


3

You'll need to start by getting root write access to /usr/bin/. You'll need recovery mode or even a Live CD/USB. Both those approaches are covered here — just ignore the password setting bit. By this point you should be logged in as root. Anyway fixing this isn't too hard because most of the files are straight 755 and there are only a handful of ...


0

You can do this: Create a copy cp /etc/sudoers /etc/sudoers.bak Edit problem parts there vim /etc/sudoers.bak Replace the origin sudoers file cp /etc/sudoers.bak /etc/sudoers It works for me.


5

Yes, that is how it should be. Ubuntu is designed this way. Benefits of using sudo (from the Community Help Wiki): The Ubuntu installer has fewer questions to ask. Users don't have to remember an extra password (i.e. the root password), which they are likely to forget (or write down so anyone can crack into their account easily). It avoids the "I can do ...


4

From what I gather you're simply trying to return to your user account after gaining access to root. Try typing exit in terminal. Or you can simply press CTRL+D.


0

Just type exit and you will leave the root shell and get a shell of your previous user.


2

Wrap it up in a subshell: sudo sh -c "/path/to/script; shutdown -h now" The problem there is the script will run as root too. This might not be an issue (consider it in your case) but you can work around this by using sudo again to break back down to your $USER (which will be replaced because we're using double-quotes): sudo sh -c "sudo -u $USER ...


4

sudo does not work the way you envision. You can configure sudo to allow root access to commands, such as gedit, but not specify files. So if you give a user root access to gedit, the user can edit any system file. Example, for the user joe joe ALL = /usr/bin/gedit would grant root access to gedit , but the user could then access and edit any file. ...



Top 50 recent answers are included