New answers tagged

0

I fixed it my Self I uninstilled it. And instead of downloading from steam. Or the ubuntu store I used the terminal.


1

Running the following command will allow your computer to work with 32-bit libraries: sudo apt-get install --reinstall libgl1-mesa-glx:i386 Run that in a terminal and try to install Steam again.


1

According to this WineHQ page, you need to run a command. Open a terminal and run: wine reg add 'HKCU\Software\Valve\Steam' /v DWriteEnable /t REG_DWORD /d 00000000 Steam should now run.


0

wine cannot install Windows Media Feature Pack currently, as it does not support installing msu files yet. This is how I was able to add H264 support to Firefox under wine: Get mfplat.dll msmpeg2adec.dll msmpeg2vdec.dll from Windows7 windows\system32 and put them to wine's windows/system32 (get 32 or 64 bit dlls according to your wine settings). Import the ...


0

Alright finished it, Based on @Pilot6's answer I started my system, pressed cntr-alt-f1 and entered my user name and password. I then tried to purge nvidia but it gave me an error that dpkg was not configured properly. I then entered dpkg --configure -a and after rebooting it worked fine. Just reporting this if anyone else has this problem.


0

The problem could be a driver bug. To exclude it you could run the game with Mesa software rendering enabled, just set the variable LIBGL_ALWAYS_SOFTWARE=1 when starting the game, and see if the problem persist. If this is the case (though if that didn't work too), you could either try upgrading to latest unstable Mesa drivers by adding Xorg edgers PPA ...


1

Based on Urgazhi's answer, you can do the following: Open the file $HOME/.steam/steam.sh in a text editor Add these as the first two lines of the file: export LD_PRELOAD='/usr/$LIB/libstdc++.so.6' export DISPLAY=:0 Save and launch steam normally.


2

You can easily fix it. Press Ctrl+Alt+F1. login to console and run sudo apt-get purge 'nvidia.*' That will remove Nvidia drivers. Then you can install some driver, like sudo apt-get install nvidia-352 Then reboot sudo reboot


0

Have you tried the latest version of Wine? From https://wiki.winehq.org/Ubuntu: If your system is 64 bit, enable 32 bit architecture (if you haven't already): sudo dpkg --add-architecture i386 Add the repository: sudo add-apt-repository ppa:wine/wine-builds Update packages: sudo apt-get update Then install (example for the development branch): sudo ...


1

This is a more general approach on how to find out if any specific game will be playable on Ubuntu. It also is the approach I take before I buy a game for my kids. Check the system requirements on Steam A game that has a native Linux support will mostly run without issues provided we have an appropriate graphic card and driver. This will be listed like ...


2

The game is listed as Windows only on Steam. You won't be able to download it through Steam for Linux. You can install Wine (and then install the Windows version of Steam on Wine) and download the game though that. This might work. It's not a very popular game so there are no reports as to whether or not this works yet. Some games just never work through ...


1

You can check it on the Steam website. No need to install anything. And the answer is no. It's Windows only.


0

The issue here is a lack of 32bit support on your system, Steam is a 32bit application (hence i386 in the package names), you should enable 32bit support on your 64bit system, then install steam, so it can use 32bit packages. Open a terminal and run sudo dpkg --add-architecture i386 sudo apt-get install steam If you still get that same error, you need to ...


0

Found a solution in duplicate question here. Just run this in terminal: sudo apt-get install libc6:i386 libgl1-mesa-dri-lts-utopic:i386 libgl1-mesa-glx-lts-utopic:i386 If you're on 14.04.3 or greater using Hardware Enablement Stack (kernel 3.19) run this instead: sudo apt-get install libc6:i386 libgl1-mesa-dri-lts-vivid:i386 ...


0

My MadCatz fightstick (1bad:f03a) works fine in Steam's Big Picture Mode out of the box on 14.04. Looks like a X360 controller ≠ official X360 controller "logic3 in lsusb" doesn't look like an official controller made and sold by Micosoft for the Xbox 360. Most drivers and software use the USB IDs to detect devices that they are compatible with. If your ...


0

DS4 in Steam The DS4 seems to have native support in Steam (client from 2016-01-01, tested on Ubuntu 14.04 with HWE kernel and 15.10) and Big Picture Mode works as intended through USB and Bluetooth. To pair the DS4 in Ubuntu go to the Bluetooth settings and press the plus button (+) below the listing of paired devices to get to the pairing dialog, then ...


1

Why not use new User Account (via System Settings). This is the only one method on Linux for "permissions". New user "SteamUser" should not be in sudoers (just a limited account). Then create second account called "SuperAdmin" and make it sudoers account (root access). But keep its password only with you. Then remove your son's account from sudoers. (sudo ...


4

Set a time- limit on a process or application With a small background script, you can set a time- limit on a process or application. As long as your user does not know the administrator's password, it is not surpassed too easily. The solution below Is such a small background script. It limits the usage per day to a defined number of minutes, to set in ...


4

From my own experience restricting access to computer games is one of the most challenging tasks in educating our kids. Of course we parents want them to use their computers mainly for school but this heavily conflicts with the kid's intentions. They will hate us for giving them hardware usable for school only. And of course we also want them to learn how ...


1

This can be achieved by using shell scripts. First script is to kill Steam as soon as it is run: #!/bin/bash while true do pkill steam sleep 1 done exit 0 Save it as /path/to/anyname.sh and add it to the list of start-up applications. What this script will do is that it will check any open process named steam every second and if it finds any ...


1

Try installing Wine - it resolved the issue for me ;-) I usually install Wine before Steam and do not get the problem. After recently completely zapping and reinstalling Ubuntu, I forgot to install Wine and got the same problem with Steam. After installing Wine the problem disappeared.


0

Add an entry in the fstab file at: /etc/fstab for your device. With "exec" option, for example: UUID=6C046CDF046CADB0 /media/SAMSUNG ntfs rw,user,auto,exec 0 0


1

Maybe the gcc libs in the steam runtime are incompatible with your mesa drivers. Back up your home folder, then try to delete these library files: rm ~/.local/share/Steam/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-gnu/libstdc++.so.6 rm ~/.local/share/Steam/ubuntu12_32/steam-runtime/i386/lib/i386-linux-gnu/libgcc_s.so.1


0

The differences will be extremely subtle. Ubuntu, before the 11.04 release, used the GNOME shell. But it kept alive after Unity's release with Ubuntu GNOME. The GNOME shell used by Ubuntu is basically the same used by Fedora. The things that may change are the shell's version and the default theme used on it. The GNOME project is one of the oldest ...


4

First mount your flash drive with read/write/execute privileges. How to auto mount a flash drive with root and read/write/execute privileges Then create an empty folder on your flash drive. Open Steam settings, click on Steam and then click on Settings. Steam -> Settings -> Downloads Click on Steam Library Folders 3.Click on Add Library Folder ...


0

I don't know anything about this Crouton business, but I store my steam games on a separate drive off my OS SSD. Have Steam installed. Go your games Library. You have no games installed. Mount your external drive. Select a game and Install game. In the drop down list, choose Install under /media/username/your-external-drive/Steam This will create a Steam ...


1

as far as I now, by default everything related to steam is installed in /home/USER/.steam. If your USB drive is mounted with execute permission, you can go to steam's settings menu -> downloads -> content libraries and add a new content library on your USB drive. But I don't see the benefit since the USB drives are slow...for simple arcade games ...


0

You could do this: Dowland the package from http://steampowered.com and then appgrid sudo apt-get install appgrid or sudo dkms-reconfigure steam sudo apt-get install --reinstall steam sudo apt-get update sudo apt-get upgrade sudo apt-get dist-upgrade and it might work fine this way.


0

You can easily fix this by opening a terminal and runing the following commands: sudo apt-get update sudo apt-get install libgl1-mesa-dri:i386 libgl1-mesa-glx:i386 libc6:i386


0

The error message says you are missing the files: radeonsi_dri.so and swrast_dri.so. Run the following commands to install those files: sudo apt-get update sudo apt-get install libgl1-mesa-dri libgl1-mesa-dri:i386 Please post any errors.


3

This is a simple fix. According to the error message, you are missing the following files:r600_dri.so and swrast_dri.so Run the following commands to install these missing files: sudo apt-get update sudo apt-get install libgl1-mesa-dri libgl1-mesa-dri:i386 The problem should now be solved. Please post any additional errors.


0

Using wine: Uninstall steam and fix any broken packages that you may have. You can so this by running sudo apt-get -f install then install wine if you do not already have it; dowload steam for Windows. and install it in wine. For more on how to install wine. Other options: After uninstalling the current steam installed & running sudo -f install ...


0

This because the Red Alert 3 is only built for single OS, whilst CS was built for GNU/Linux as well. Here you can read about the error. If that happened to you, you have to run Windows version of steam through wine.


0

For the sake of posterity, restarting your computer should fix this, unless you use modprobe to block xpad. If so, you can just use modprobe to unblock it. xpad is a kernel-space driver, whereas xboxdrv is a userland driver; xboxdrv is run by the user (even if it's done automatically in the background), but xpad is "baked-in" to the linux kernel, so you ...


0

Steam do not support all that many browsers! By default it uses Firefox on Linux - so install that, and your links will be opened in Firefox. Read more in: Ubuntu: Powerful Hacks and Customizations By Neal Krawetz See this: ...


0

Every application installed with dpkg or apt-get has a *.list file in /var/lib/dpkg/info folder. Those files list everything associated with that application, including images. According to /var/lib/dpkg/info/steam.list, there is /usr/share/pixmaps/steam_tray_mono.png file, which is the icon you wish to change. You could take that image and replace it with ...


0

Basically, you cannot change Steam's menu icon. You can temporarily replace it with another icon, but it will eventually get replaced with whatever Steam wants it to be, during an update. You should probably contact Steam support to complain that the Steam tray icon does not work well with light themes, and hopefully they will fix it in an update, so it ...


0

Boba, As Eduardo said you can go to additional drivers to install the Proprietary driver. Hit the super key (Windows Key) and type, "Additional Drivers". You should be able to click on the Additional drivers icon. Additional Drivers in the Dash After that, the application will scan for additional drivers, and present you with a list. I generally go for ...


0

I had this same issue myself for quite some time. When I tried to install the packages, half of them wouldn't install. What personally worked for me, was deleting that install of Steam (via sudo apt-get remove steam or sudo apt-get purge steam) and doing a fresh install via sudo apt-get install steam -y. Now I can't say that that install will work 100% (it ...


1

You have broken packages run sudo apt-get -f install sudo apt-get update && sudo apt-get upgrade Then try to again. If you are having the same issues you may need to add packages (32 bit) if running 64. sudo dpkg --add-architecture i386 && sudo apt-get upgrade Wine 1.4 if all else fails: This supports win32 and win64. First remove ...


0

Updating the kernel to 4.3.3 fixes this issue.



Top 50 recent answers are included