Tag Info

New answers tagged

0

You can use vnc for gui access to server. Install the VNC-server apt-get install vnc4server Please make sure that you are using only vnc-server & no other VNC-server are installed as this could give errors in future mostly that clipboard sharing between the host Ubuntu Server & vnc-client machine. You can check it as follows: xxx@yyy ~ $ sudo ...


0

I use the seahorse utility to manage the passwords. Under the login search using the filter for the server name and the right click on the server name to change the password.os To run the utility type at the command prompt seahorse


0

Run the commands below to download version 2.10 cd /tmp/ && wget http://cznic.dl.sourceforge.net/project/denyhost/denyhost-2.10/denyhosts-2.10.tar.gz Next, run the commands below to extract it. tar xzf denyhosts*.tar.gz Then run the commands below to change into the extracted folder cd DenyHosts* Finally, run the commands below to install ...


4

Denyhosts is no longer available. You can use fail2ban or better, a few ssh tips. Use ssh keys and disable password authentication. iptables can do essentially the same thing as denyhosts and fail2ban . The advantage is no additional packages are required. iptables -A INPUT -p tcp -m tcp --dport 22 -m tcp -m state --state NEW -m recent --set --name SSH ...


1

It seems that the problem is that the environment variable XAUTHORITY is not preserved in the screen session. I solved this by adding the following to my .bashrc. I didn't think this should be necessary but I guess you do what you must: # ensure X forwarding is setup correctly, even for screen XAUTH=~/.Xauthority if [[ ! -e "${XAUTH}" ]]; then # create ...


1

I've finally found a way to fix the issue I had.I found this article about iptables It helped me a lot to fix the issue. The only thing I did is run the command sudo iptables -F Doing that has allowed me to push again on remote repositories and thus using ssh. But I had to save that. For this I run this other command to make all the changements due to ...


2

@Shutupsqaure answer is correct; but if you want to maintain different usernames on the remote computer, you can just edit/create a $HOME/.ssh/config file and put in it: Host nickname HostName hadoopslave User hadoop1 (edit for your situation, clearly). Now ssh nickname is the same as ssh hadoop1@hadoopslave. $HOME/.ssh must be mode 0700 --- ...


2

If you can login with ssh username@hostname #or ssh username@ip_address but not ssh ipaddress Then your username is not the same as the target user on the host you are trying to connect to. I can see from your output from ssh that your local user is hardoop and the remote user is hadoop1. Unless they are the same name you need to have user@remote


-2

type ifconfig , you will see ip address,suppose it is 10.42.0.1 and netmask is 255.255.255.0 obviously 24 bits are for network address type nmap -n <ip address>/24 it will show no of host up with its ip address. suppose it is 10.42.0.23 type ssh hostname@<ip address of host>,for remote login, password for host machine will be asked for remote ...


0

To login to a machine using ssh you need: ssh username@hostname or ssh username@host_ip To ssh to the localhost i.e. the computer you are currently logged in, you can run any one of the following: ssh username@127.0.0.1 ssh username@127.0.1.1 ssh username@localhost ssh username@hostname In your case you dell is the hostname, not a username. So, you ...


1

Install SSH server daemon on server machine: sudo apt-get install openssh-server sudo service ssh start Configuration files are in /etc/ssh/ Create user for server (do not use root or your own account if possible) mkdir /home/jimmy sudo useradd jimmy -s /bin/sh -d /home/jimmy sudo chown jimmy /home/jimmy And enter password for new jimmy user. For ...


0

Answering this question largely depends on what type of routers you are dealing with but my guess is that it will be impossible. Configuring a hardware VPN without Administrator privileges is impossible. You cannot physically connect to a machine behind the router without having access to port forwarding. Any requests to connect will be sent to the router ...


0

Without access to the routers or changing the router it is going to be virtually impossible. Your router has a firewall. A firewall is a wall blocking ALL data. Rules are added to allow certain data. A port is a specif door in the wall, and a "port forward" is a door to a specific PC. Without a port going to the target box there is NO way to send data to ...


1

You would do a lot better to "forward" the remote network's proxy server over SSH rather than using the built-in SOCKS server (which just expects a bare gateway-addressable network at the other end). ssh -L 8080:internal_ip_of_proxy:8080 user@ssh_server This exposes the proxy server locally, allowing you to set your browser's proxy settings to ...


0

I don't think this is the best way, but it works sudo nano /etc/ssh/sshd_config inside change port to 39 (any, not 22): Port 39 save and restart ssh: sudo service ssh restart when connect use -p 39: ssh developer@37.288.11.11 -p 39


2

See this question here on serverfault for more information, try to use the Match syntax in sshd_config to exclude a certain group from logging in. Match Group groupname PasswordAuthentication no


1

I had the same issue and did the following to solve the problem cd sudo mv /etc/ssh/sshd_not_to_be_run . sudo service ssh start


0

I found my mistake. The problem was in MS Word, I saved all commands in a doc file and just copy and paste them. MS Word does regular - in longer – in some cases. So, this longer dash break my last command: ssh -L 33061:localhost:3306 tunneluser@1.1.1.1 -f -N


0

Okay to do this you need a version of xfreerdp that is higher than in the official repo's sudo apt-get purge freerdp sudo apt-get install build-essential git-core cmake libssl-dev libx11-dev libxext-dev libxinerama-dev \ libxcursor-dev libxdamage-dev libxv-dev libxkbfile-dev libasound2-dev libcups2-dev libxml2 libxml2-dev \ libxrandr-dev ...


0

I am no expert on Ajenti as I've never used it before but on the server side of things a Connection refused on SSH and this page is not available error on the browser could mean that either a firewall is blocking the ports, the ports for your web services are not forwarded correctly or you are trying to connect to the service using the wrong port number. The ...


0

I got the solution to the problem. It seemed that git could not find the private keys to login, so I created ~/.ssh/config containing: Host gitbox User git Hostname 192.168.0.103 Port 22 IdentityFile ~/.ssh/gitolite Of course you need to change the credentials. Then gitbox is used for loggin in credentials. git clone ...


0

You didn't install the X2go server, just the bindings X2Go bindings for LXDE (package name: x2golxdebindings) will add additional X2Go-related functionality to your LXDE Desktop. You need to run sudo apt-get install x2goserver x2goserver-xsession for the server. See the install guide for details. On a side note, X2go depends on openssh-server which ...


0

Public/Private keys are meant for administrators who manage many servers Imagine you have installed Ubuntu in various family members' computer, who live in different cities. Periodically they call you to fix their computers. You want to remotely connect to these computers and fix them. This is where you may want to use public/private keys. The public keys ...


0

The Ask Ubuntu community wiki page is a great introduction to the topic here It helps to get your head round it, and shows you the steps to set key based logins. The answer that @heemayl gave sums up how the key pairs are used. Good luck!


0

Would each user have to have their own private and public key? if you want key based login and if that user need to login to the server then the user should have a public-private key pair of their own. `Each user has a different public key and then one private key on the server machine?Or just one public key distributed to each user and one private ...


0

I'm no expert but I think the problem was the open input stream. This code does the trick: ### Actual Work ### if [[ $manual == 0 ]]; then # Read the servers from the config file. while read line; do # Read line by line. arguments="$arguments $line" # Build a string for $arguments out of the ...


0

Yes, it is possible. To set up password based authentication (non key), you can achieve this by following the below setup, Step 1: Create password for the root user sudo passwd root Step 2: To allow root password, edit sshd_config file and set the "PasswordAuthentication" value as "yes" vi /etc/ssh/sshd_config PasswordAuthentication yes ...


2

You can add the line manually to the /etc/ssh/sshd_config file. If the line were there before restarting, then it should be there after restarting too unless something has been done in the meantime or the restarting (stop-start) the service itself removes the line. In your case the the line should be there after restarting ssh. If any invalid line is added ...


1

the problem is that windows uses a different new line than linux, so when copying the key from windows to linux, there is a \n at the end of the line that you can not see on linux in the editor. If you tail the /var/log/auth.log and try to login, the error is like: sshd: error: key_read: uudecode AAAAB3N[....]==\n If you change your key on windows so ...


1

SSH is a tool that is very good at some things such as forwarding single programs or, with firefox for example, ports, transferring data, running or managing remote servers. Forwarding an entire desktop is not one of them however. It can be done mind you, but performance will be slow. If you connect via ssh, you have already authenticated (logged into the ...


1

The way you added authorised keys, you haven't added your user's key to root's authorised keys. You have added your own key to your authorised keys and root's key to root's authorised keys. Instead do: sudo tee -a /root/.ssh/authorized_keys < ~/.ssh/id_rsa.pub


3

At first you need to know the IP addresses (try ifconfig or ip addr show or any other method) of the laptops lets say Laptop A's IP is "192.168.1.4" and Laptop B's IP is "192.168.1.5". To do ssh from A to B and vice versa you need to install the ssh server on both laptops by following command: sudo apt-get install openssh-server As client is automatically ...


0

You have files named "ssh-add id_rsa" and "ssh-add id_rsa.pub". You did something wrong. Remove those files and retry the whole procedure. Or just use github-keygen for your SSH setup. Easy and secure. Disclaimer: I'm the author of this tool.


0

Just use github-keygen for your SSH setup. Easy and secure. Disclaimer: I'm the author of this tool.


1

Your last command, osascript -e ' tell app "System Events" to display "Hello world"' will be executed only if you exit the remote ssh terminal. In this way you can not achieve what you are trying to do. Hopefully there is expect script. You can work with the following script, #!/bin/sh expect <<'END' set timeout 10 set login "your_username" set ...


1

I don't know how ssh exactly operates, but your script is written in a way that it will wait until the ssh command finally terminates. Then will it continue and run your last line (osascript...). To avoid waiting for ssh to return, write a & at the end of the ssh line. It will have the interpreter to continue executing the next command in a parallel ...


1

Shouldn't be too hard with a couple of read prompts: #! /bin/bash read -p 'Username: ' user read -p 'IP: ' ip ssh "$user"@"$ip"


0

for me the problem was i'd created ~/.ssh/authorized_keys using root so root owned. I had to chown sshuser:sshuser ~/.ssh/authorized_keys then it started working


0

I normally use something like ssh-keygen -t rsa without the ip address of the vps like you did and it works for me. From the ssh-keygen manpage: -R hostname Removes all keys belonging to hostname from a known_hosts file. This option is useful to delete hashed hosts (see the -H option above). Which I don't think is what you want


0

On debian (and as far as I remember on 14.04 too) we have to type the full word "yes" instead of just "y" to answer the question "Are you sure you want to continue connecting (yes/no)?". Otherwise there is a prompt telling "Please type 'yes' or 'no':" Typing a full "yes" may be your solution (although the lack of error message is strange).


0

If your shell is bash, one way could be to use commands in ~/.bash_logout. From man bash: When a login shell exits, bash reads and executes commands from the file ~/.bash_logout, if it exists. SSH runs a login shell, so when it exits .bash_logout should be run. You can check whether it is an SSH session by testing the value of the SSH_TTY variable. So ...


0

So after trying! I logged into router control panel and revoked the server local ip, So now the server is disconnected to internet. After that, I removed all its DHCP enteries that was related to it, After that the router rebooted, I connected the server once again and added a new DHCP record with the new assigned IP, And everything seems to be working now ...


0

Here is my log from ssh -vvv -D 1080 user@IP OpenSSH_6.6.1, OpenSSL 1.0.1f 6 Jan 2014 debug1: Reading configuration data /etc/ssh/ssh_config debug1: /etc/ssh/ssh_config line 19: Applying options for * debug2: ssh_connect: needpriv 0 debug1: Connecting to 107.000.000.000 [107.000.000.000] port 22. debug1: Connection established. debug1: could not open ...


0

Disable Password Authentication Because a lot of people with SSH servers use weak passwords, many online attackers will look for an SSH server, then start guessing passwords at random. An attacker can try thousands of passwords in an hour, and guess even the strongest password given enough time. The recommended solution is to use SSH keys ...


0

I guess after many months of search the best answer is to say that remmina incorporates virtualGL extentions. I have not seen that anywhere stated explicitly, but I have only seen opengl applications be runable when they are run through virtualGL.


0

Exactly what the above comments mentioned, you will need to share the file system with the data from machine 2 back to machine 1. Enabling NFS is probably what you will want and a simple HowTo at https://help.ubuntu.com/community/SettingUpNFSHowTo is a good start to just get a basic setup for testing. Next you will likely want to performance optimize and ...


2

If a LibreOffice window is open, it opens a window in the display of that process. Therefore one way would be to kill any running LibreOffice processes.


0

Just wanted to put this out there since on a normal iso install root account is disabled (unless maybe you enabled it) I'm going to assume you didn't and you're using a cloud based service like maybe Digital Ocean, as they have root enabled unless you setup a key. If this is the case, as I also use digital ocean, I find it is sometimes easier to allow ...


6

PermitRootLogin is an sshd (the daemon) setting, not an ssh (the client) setting. It should go into /etc/ssh/sshd_config, where I'm reasonably certain you'll find a PermitRootLogin line.


0

PuTTY/PuTTYgen uses its own proprietary format of key pair. It won't work on Linux, where OpenSSH format of keys prevails. In PuTTYgen, you can directly see (and copy + paste) a public key in format used by OpenSSH authorized_keys file. You can use button Save public key to save the public key in .pub format (RFC 4716). On Linux the file is typically named ...



Top 50 recent answers are included