Hot answers tagged

22

Wipe the hard drive and reinstall your operating system from scratch. In any case of unauthorised access there is the possibility the attacker was able to get root privileges, so it is sensible to assume that it happened. In this case, auth.log appears to confirm this was indeed the case - unless this was you that switched user: Apr 27 06:55:55 Rho ...


13

It looks like someone opened a guest session on your laptop while you where away from your room. If I were you I'd ask around, that may be a friend. The guest accounts you see in /etc/passwd and /etc/shadow are not suspicious to me, they are created by the system when someone open a guest session. Apr 27 06:55:55 Rho su[23881]: Successful su for ...


3

You want to set up port forwarding on your router, and forward port 22 of router to port 22 of your machine. People connecting to the router ( piblic ip ) of your home network will be forwarded to your home computer. As this setting varies from router to router, i cannot provide an example. Refer to your routers user manual


3

There is no 'root' account available for login by default. It is locked in a default installation. You don't state where your install runs from, so I am going to assume it's running from your remote user account on the server. You can enable the root account if you wish, but there's more 'secure' approaches to do this, than just enabling the account. ...


2

I was getting the exact same error. In the Software & Updates changing the server from my local country to Main server, and also adding the Canonical Partners from the "Other Software" tab helped installing the openssh-server in my case. I am not sure which of the two helped.


2

Do you have any friends that like to access your laptop remotely/physically while you're gone? If not: Wipe the HDD with DBAN and reinstall the OS from scratch. Be sure to backup first. Something may have been severely compromised within Ubuntu itself. When you reinstall: Encrypt /home. If the HDD/laptop itself is ever physically stolen, they cannot gain ...


1

I just ran into the same issue. What had happened is that the key was stored in the old format: cat /etc/ssh/ssh_host_rsa_key SSH PRIVATE KEY FILE FORMAT 1.1 <encoded private key here> However the newer sshd is expecting the newer base64 encoded keys. cat /etc/ssh/ssh_host_rsa_key -----BEGIN RSA PRIVATE KEY----- <base64 encoding here> ...


1

Looks like an ssh-agent is running already but it can not find any keys attached. To solve this add the private key identities to the authentication agent like so: ssh-add Then you can ssh into your server. in addition, you see the list of fingerprints of all identities currently added by: ssh-add -l


1

There is no cipher called blowfish in SSHv2. It was only in the old protocol SSHv1, which is gone (hopefully also on Ubuntu). SSHv2 has cipher called blowfish-cbc as pointed out in manual page for ssh_config (always good place to start).



Only top voted, non community-wiki answers of a minimum length are eligible