Tag Info

Hot answers tagged

44

The real reason (and what may be the root cause of the LaTeX usage) is that many pre-unicode unix fonts (both for the console and X), and two common Adobe Postscript encoding vectors, had typographic opening/closing quote glyphs at these positions, so 'this' would look like ’this’, and ``this'' looked like ‘‘this’’ or ‛‛this’’, which was (especially in a ...


31

One reason is probably the influence of TEX to the Linux world. In most flavors of TEX, the sequence `` creates a typographically correct opening double quote (“) and '' (two single quotes) or " create a typographically correct closing quote (”). So When you type ``Why do you always say `shut up' to me?'' It actually yields “Why do you always say ...


14

You prepend the file name with ./ (or another relative or absolute path that works). This way it's portable. Example: for zefile in ./*.tmp do rm -f "$zefile" done The use of -- to indicate the end of options is not always available. Some commands will know it, some won't. And this will change across different systems. So in the end, it's less ...


14

:() # define ':' -- whenever we say ':', do this: { # beginning of what to do when we say ':' : # load another copy of the ':' function into memory... | # ...and pipe its output to... : # ...another copy of ':' function, which has to be loaded into memory # (therefore, ':|:' simply gets two copies of ':' loaded ...


11

You need to escape special characters. So place a \ in front of the @ like so: export http_proxy=http://deepak:Deepak\@123@12.1.1.1:3128 Alernatively you can also use %40.


10

Please note that the Unicode character range is immense; There is no one font that covers all of it (although GNU FreeFont comes pretty close). If you see empty spaces, or even empty pages, it may be because they just haven't been assigned yet. Those will remain empty until the Unicode Standard utilises them. Even though there is space for 1,114,111 ...


8

In the original name “Documents/trettiårsfirarätare”, the letter “å” is internally represented as U+00E5 LATIN SMALL LETTER A WITH RING ABOVE. This is the common representation of this character. In the filename you got back, it has been turned to the character pair U+0061 LATIN SMALL LETTER A U+030A COMBINING RING ABOVE. This is permissible, but not common; ...


7

One character or more can be replaced with zero, one or more characters as follow: $ some-wrong-long-command $ ^wrong^correct^ some-correct-long-command This quick substitution repeat the last command-line from terminal, replacing wrong string with correct string. Examles:


7

Keyboard layouts in Ubuntu are stored in /usr/share/X11/xkb/symbols/. The easiest way to get your desired result is to create a new layout by copying an existing one. Choose the one you are using at moment (you can have a look inside the files to find see the user friendly name of a layout). So for English (US) type sudo cp /usr/share/X11/xkb/symbols/us ...


7

To get half स you have to type स and then virama (hasnt) ् so that it looks like स् then type व. In Bolnagri the ् is typed by X. To get और type Shift+Alt Gr+O and then R. Where Alt Gr is the Alt key on the right of Space Bar. In general, where the picture below shows two columns of characters on the same key, the bottom row of the left column is entered ...


6

I think the programs you're using all use the readline library to read input. So I guess you've misconfigured the readline library. The system configuration file is /etc/inputrc and the per-user file is ~/.inputrc. You probably put one backslash too much in a binding, so that instead of binding a command to an escape sequence you've bound it to a sequence ...


5

I'm afraid not. U+F200 is in the Private Use Area. These are not official Unicode characters.


5

I just found out how to delete such files witch special characters: cd <directory with that file> ls -ali At the very left of the directory listing you see the ID of the inode of each file. Delete your file via inode ID: find . -inum <inode ID of your file> -exec rm -i {} \; This worked fine for my issue. Hope this helps!


5

sed -e 's/ /\&nbsp;/g' Note the \ before the &. Escape your characters.


4

Use the keyboard layout called English (international with Alt Gr dead keys). (Do this by going to System Settings > Keyboard > Layout settings, and then add the layout you want with the + button on the bottom.) This way, the keys to input the characters ', ", `, ~, and ^ become "dead keys" while you hold pressed Alt Gr. After releasing the key combination ...


4

Just press Alt R+4 like in below image: See also this answer.


4

Simply press Ctrl+Shift+U, then type "00b7Enter", i.e. the unicode value of interpunct character.


4

You have to press ALTGR+Q to get the @


4

This probably has to do with "Dead keys". Go to Menu>System>Preferences>Keyboard click the tab labeled "layout" and try to add a different keybord layout (I have no clue if this helps for a Romanian keybord layout). Alternatively, try to press space afterwards (instead of pressing the key twice).


4

Fold open "Select more options", select "Name matches regular expression" and press the Add button. Now you can fill in a regular expression to match. To use the example of Joris, put [èö] in the text box next to the "Name matches regular expression" search option you added, and it will search for all files that contain è and/or ö. You can add as many ...


3

Since Ubuntu 9.10, you just have to follow those few steps : Install ibus-anthy Go to System -> Preferences -> Keyboard input methods Accept to activate iBus (pop-up window) Add Japanese-Anthy in the Method tab Disconnect and reconnect Open an input field (like Gedit for instance), hit Control + Space ; you should be able to type Japanese characters In ...


3

It's very quick to load the "Character Map" (installed by default). In the first screenshot I am loading it from the dash (click on the Ubuntu button in the top left, or press Super). For even quicker access you could add it to your Launcher on the left as seen in the second screenshot.


3

In Character Map menu, View > By Unicode Block. Then select "Mathematical Operators" in the list at the left.


3

Click on Dash home Search for System Settings Select Network Select Network Proxy Select Manual method Set you proxy and port Kudos You are Done if you set right


3

Finaly I found the answer: grep -lr -i -Z -e 'm:\\' * | xargs -0 sed -i 's/M:\\/K:\\/g' I had to add the -Z to take care that every filename is read, and not the entire bunch in one long string.


3

Go to System Settings > Keyboard Click on Layout Settings (button at bottom) Select your layout in my case English (US) > Click Options Hit the arrow on "Caps Lock Key behavior" > Then select "Caps Lock toggles Shift so all keys are affected" Or, under "Miscellaneous compatibility options" you can check "Both Shift-Keys together toggle ...


3

A macro would be overkill in this scenario. There's a much easier option: Autocorrect. In LibreOffice Writer go to Tools --> Autocorrect: Define a string and its replacement: As you can see I used this method for a set of arrows and it works fine. It might not be the minimum-keystroke option you were searching for, but it sure is far less complicated ...


3

See this link for custom keyboard layout definition


3

The escape codes needs to be interpreted correctly and not literally, before writing the string to file: # echo -e '\e[1;31mUbuntu\e[0m' > /etc/issue



Only top voted, non community-wiki answers of a minimum length are eligible