New answers tagged

0

@guss the version you have there works for the Ubuntu Precise (12.x) based builds. you may want to use the below to determine the proper item to add to the apt-add-repository command, it should identify your distribution. taken from https://deb.nodesource.com/setup_4.x jessie precise trusty wheezy xenial


1

In the absence of clarification, at the request of Elder Geek... I've done a whereis on the file name to give the the following response: /usr/bin/'file_name' /opt/'file_name'/bin/'file_name' It sounds like you already installed it, and you should be able to launch it by typing 'file_name' (replacing your unwieldy appellation 'file_name' with the ...


1

Bunsen Labs is based directly on Debian, so you shouldn't be able to install Handbrake from its official repository. You can install it instead from Bunsen's repositories. It won't be the latest version but it should work on your machine. First you have to remove the added repo with sudo add-apt-repository --remove ppa:stebbins/handbrake-releases and ...


1

I had the same problem - Lubuntu 15.10 and Tulip doesn't start. Assuming your default Tulip installation is in /usr/bin/Tulip, you can check for missing dependencies using ldd /usr/bin/Tulip. When libbfd-2.25-system.so is missing, install the binutils package using sudo apt-get install binutils. The package provides libbfd-2.25.1-system.so. Afterwards ...


0

Upgrade to 16.04.1 and Python fixes itself :P


0

You can also run "apt install php-dev" first before running "pecl install xdebug". This installs the appropriate dev tools for php7. The answer above is more of a work-around getting a php5 set of dev tools to work with php7.


0

so I finally fixed the problem. I used the following - sudo apt-get autoremove octave sudo apt-get update sudo apt-get upgrade sudo apt-get install libblas-dev liblapack-dev libpcre3-dev libarpack2-dev libcurl4-gnutls-dev epstool libfftw3-dev transfig libfltk1.3-dev libfontconfig1-dev libfreetype6-dev libgl2ps-dev libglpk-dev libreadline-dev gnuplot ...


0

pip is a python2 file. To use pip with python3 : Install and use pip3. sudo apt install python3-pip ( provides /usr/bin/pip3 ) pip3 install youtube-dl


2

Consider using checkinstall. From https://help.ubuntu.com/community/CheckInstall: CheckInstall keeps track of all files installed by a "make install" or equivalent, creates a Slackware, RPM, or Debian package with those files, and adds it to the installed packages database, allowing for easy package removal or distribution. You can install it ...


3

There is no way to "track" all applications you install from source code. When you install from source, some scripts copy some files somewhere. That is the main reason why package management has been implemented. You can track yourself what you install by e.g. keeping all sources in one place.


0

Reposting the solution provided by the OP in the question Alright! After doing a little bit of digging, I figured out how to do it! Here's the step by step method to (hopefully) solve the issue for anyone having the same problems: If you have the .tar.gz file for MATLAB, be sure to right click it and extract it to folder (I did this in ~/Downloads). ...


0

Open a terminal and type: sudo rm /var/lib/apt/lists/* -vf sudo apt-get clean all sudo apt-get update Hopefully that fixed your problem:


2

This is a no command line installation option. I did it as a dummy user. Hope it helps. 1. Browse to https://www.skype.com/en/download-skype/skype-for-computer/ 2. Choose Ubuntu 12.04 (multiarch) from the drop-down menu Let it download.. After finishing the download, just click the file from the browser Install it to your system, you will be ...


2

I also had this problem. The solution above from Ignasi is good, and very much appreciated, thank you. However in addition people who have this problem might want to do the following too: sudo apt-get remove modemmanager This is to remove the influence of the modem manager from interfering with the tty link (unlikely to be a problem in practice, but does ...


1

Workaround (symlink the nss libraries into /usr/lib/nss): If on 64 bit system: sudo ln -s /usr/lib/x86_64-linux-gnu/nss/ /usr/lib/nss If on 32 bit system: sudo ln -s /usr/lib/i386-linux-gnu/nss/ /usr/lib/nss Source: Chromium Issue Tracker


0

I take the question to be how to run Java in firefox. My solution was to load Firefox 37.0.2 in a Firefox37 folder. Load the Java(TM) Platform SE 7 U5 10.5.1.255 plug-in. Enable Java as required.


0

After downloading the .deb file from the opera website, you should be able to open it by double clicking it. After installation Opera can simply be opened from Dash or you can open a new terminal and type opera <enter>. I just installed it and works perfect. Maybe you should first uninstall whatever you just installed. Be sure to download it from here: ...


1

I installed LoL myself under WINE and it ran just fine on 15.10. However, I utilized a program called PlayOnLinux to help with the installation. PlayOnLinux is really useful because it hides a bunch of the complexity of WINE and gives a nice GUI, it keeps all of the programs installed through it in separate virtual drives, so if one program messes something ...


0

You have several issues there: You are missing self in for items in packages: self.packages is a string, when you call for item self.packages it iterates over each character of that string. You should have declared packages as list from the beginning or added .split() at the end. your self.packages is long, doesn't conform to PEP8 standard of 79 ...


0

You didn't say what version of Ubuntu, Wine, and LoL. However, if you check the Wine app database, you may find your answer. https://appdb.winehq.org/objectManager.php?sClass=application&iId=10436 For LoL v6: https://appdb.winehq.org/objectManager.php?sClass=version&iId=33303 Do a little digging on these pages. Cheers, Al


0

Fixed : def package_installation(self): self.apt = "apt " self.ins = "install " self.packages = "python-pip python-sqlalchemy mongodb python-bson python-dpkt python-jinja2 python-magic python-gridfs python-libvirt python-bottle python-pefile python-chardet git build-essential autoconf automake libtool dh-autoreconf libcurl4-gnutls-dev libmagic-...


0

Move to the directory where you have downloaded the .sh file cd "path/to/downloaded-file" Take Read/Write/Execute permission by typing following command in terminal sudo chmod 777 downloaded-file.sh Run the file by ./downloaded-file.sh Done!


2

There are two ways of fixing it, the hard way and the easy way. The hard way You didn't type the correct package name for Python Interpreter (v3.4) in your question. Open the terminal and type: sudo apt-get install python3.4 In Ubuntu 14.04, this command will install the python3.4 package correctly. Using the Ubuntu Software Center in Ubuntu 14.04 to ...


6

Your installation with cmake fails because you are downloading a very old version of jsoncpp from SourceForge , a version that actually does not use cmake. The file README.txt with the 0.5.0 tarball has the details: * Building/Testing: ================= JsonCpp uses Scons (http://www.scons.org) as a build system. Scons requires python to be installed (...


-1

You should use ubuntu make to install most other programming languages in ubuntu from now on. That includes Swift. Once you install ubuntu make, you can just type in umake swift to install it on the system. If you type in only umake, you'll see all of the things that you can install. Check out this link for more information: https://github.com/ubuntu/ubuntu-...


1

Add following two lines in /etc/apt/sources.list file using nano or vim or any other your favorite text editor. deb http://apt.llvm.org/trusty/ llvm-toolchain-trusty-3.9 main deb-src http://apt.llvm.org/trusty/ llvm-toolchain-trusty-3.9 main Above lines are for Ubuntu 14.04 LTS. If you are using Ubuntu 15.10, just replace trusty with wily in above lines. ...


0

First install avconv: $ sudo apt-get install libav-tools Then create a soft link to avconv named ffmpeg: $ sudo ln -s /usr/bin/avconv /usr/bin/ffmpeg Now you can use ffmpeg normally.


0

Now Pepper Flash plugin with the regular Flash has been moved to Ubuntu Partner repository. Both Flash players can be installed by sudo apt-get install adobe-flashplugin after the Canonical Partner repository is enabled in Software & Updates.


1

Don't bother with WINE. Nor with Autocad on Linux. It is not intented to run under Linux. Best you can get from WINE is "gold" so that is nowhere near good enough and that is not even with the 2016 version. Unless your knowledge about WINE is near perfect, so you can tune internal settings for WINE to makes this work, not going to happen any time soon. ...


0

You can install pip for Python 2 by running: sudo apt-get install python-pip


1

Paraview is available in the repositories of all currently supported Ubuntu versions, so regardless of which one you are running, you can install it by opening a terminal and typing sudo apt-get update && sudo apt-get install paraview Then you can launch from a terminal by typing paraview or by pressing alt+F2 and typing paraview or by searching ...


-1

sudo apt-get purge openjdk* sudo add-apt-repository ppa:webupd8team/java sudo apt-get update sudo apt-get install oracle-java8-installer wget http://download-cf.jetbrains.com/webide/PhpStorm-2016.1.tar.gz tar -xvf PhpStorm-2016.2.tar.gz cd PhpStorm-145.258.2/bin ./phpstorm.sh


0

First, you should change the access settings for your /etc/ppp/pap-secrets file Warning - secret file /etc/ppp/pap-secrets has world and/or group Second, there seems to be a Configuration Problem. You have multiple LCP ConfNak (LCP Configuration not Acknowledged) Packets, some are ok, but you need at least one LCP ConfAck(LCP Configuration ...


2

The following command, copied and pasted into a Terminal window, should install autokey: sudo apt-get install autokey-gtk Now I am no friend of the Software Center but the command line finds the package easily: andrew@athens:~$ apt-cache search autokey autokey-common - desktop automation utility - common data autokey-gtk - desktop automation utility - ...


1

Some dependencis can not work on lower versions of linux. There are two options. Upgrade your Ubuntu or use ''aptitude '' since aptitude can have a solution for your situation.


0

You might have trouble getting ttf-mscorefonts-installer to accept the EULA. These commands will accept the EULA and reinstall the packages (assuming you downloaded the individual font .exes): echo ttf-mscorefonts-installer msttcorefonts/accepted-mscorefonts-eula select true | sudo debconf-set-selections sudo dpkg-reconfigure ttf-mscorefonts-installer


0

By running apt-cache policy <package. You display an information about the priority selection of the named package. The package in question must be installed by apt-get beforehand. It will not be aware of the packages you installed manually (for example with git command). By running which command you ask your system what would be the exact path of a ...


0

apt-cache is an information tool of the package manager apt/dpkg. It only has information about packages you installed through them (note that the Software Center is just a GUI front-end for them) i.e. regular .deb packages (including everything from the official repositories and PPAs). If you install applications manually by either just copying their ...


0

I have ubuntu xenial 16.04 i386 and star TSP-700. starcupsdrv-3.6.0 driver is for i386, so I've installed i386 version of ubuntu. For successful build of drivers I've installed packages apt-get install libcups2-dev libcupsimage2-dev Then in source folder, make and make install. Additional problem was something with usb: "Printer does not have vid, pid, ...


1

You have the GetDeb package repository configured to use the Xenial packages even though your other packages are for Trusty. You need to edit the relevant sources.list file and replace xenial with trusty. Here's one automated way to do it and update the package list: sudo sed -i -e `s/xenial-getdeb/trusty-getdeb/` /etc/apt/sources.list{,.d/*.list} sudo apt-...


1

In this website you can see the list of FileZilla packages that are available from the repositories of each Ubuntu version still with official support. As you can see, the latest release of FileZilla -- 3.19.0-1ubuntu1 -- is only available for Ubuntu 16.10, which has not even been released yet. If your Mint distro is based on Trusty, from the normal ...


0

From the same directory: sudo make uninstall sudo apt-get install --reinstall python Then, close your terminal to refresh bash or run the following command: . ~/.bashrc Also, close any open terminals or run the last command specified in each running terminal to refresh each running terminal.


3

Files in /etc/asterisk looks like they are generally shipped by the asterisk-config package. So it is this package you need to purge. Your autoremove did remove this package, but did not purge it. sudo apt-get --purge autoremove would have done it, but now that it is removed, dpkg -P asterisk-config is necessary. There may be other files that you need to ...


0

For me, I just had to set SetJavaHome entry with the path for the JDK in the ~/.sqldeveloper/4.1.0/product.conf and it worked like a charm.


2

Installing llvm 3.9 can easily be done under Xenial Xerus by using the 'LLVM Debian/Ubuntu nightly packages' PPA. Just follow these steps: Add the archive signature: wget -O - http://apt.llvm.org/llvm-snapshot.gpg.key | sudo apt-key add - Add the PPA: sudo apt-add-repository "deb http://apt.llvm.org/xenial/ llvm-toolchain-xenial main" Allow the ...


3

There is NO installation file in the .tar.gz file that you downloaded from Adobe website. Ditch the manual installation. Here's how you can install flash from the terminal: Open the program Software and Updates Go to Other Software Enable (check) Canonical Partners and close Software and Updates Open up a terminal and run: sudo apt-get update Now install ...


1

Go to software & updates and switch to main server. sudo apt install -f && sudo apt update && sudo apt dist-upgrade && sudo apt install playonlinux Ubuntu has playonlinux on it's repo. So you didn't have to add repositories by yourself.


1

Most likely the sudo apt-get install -f will fix the issue. The needed packages will be installed. You could install PoL an easier way from Ubuntu repositories by sudo apt install playonlinux but that could install not the very latest version. Now you can remove the custom repository by sudo rm /etc/apt/sources.list.d/playonlinux.list sudo apt ...


3

Guide for 14.04 LTS without RVM Jekyll 3 needs ruby 2.0 or higher, so we first install ruby 2.0, it's development headers and nodejs: sudo apt-get install -y ruby2.0 ruby2.0-dev nodejs Then we point the commands included in the ruby package to the new version. sudo update-alternatives --install /usr/bin/ruby ruby /usr/bin/ruby2.0 10 sudo update-...


3

Isn't Synaptic > Status > Installed the answer to what you are looking for?



Top 50 recent answers are included