New answers tagged

1

This behavior is consistent with Ubuntu Software Centre. Canonical works with third-party software providers to provide payment and hosting for commericial software in the partner repository. In Ubuntu 16.04 LTS, this is being replaced by the Ubuntu App Store which powers the snap repository's backend. While the command line tools provide access to ...


3

Try installing the package software-center with sudo apt install software-center :)


0

You can remove Ubuntu Software Center manually and if not already installed, install Ubuntu Software instead. Open terminal (CTRL+ALT+T) and execute the following commands: sudo apt-get remove software-center sudo apt-get install ubuntu-software


1

I doubt it's the old one. They have the same icon, but the old one is called Ubuntu Software Center, while the new one is called Ubuntu Software. If you have the old one, you'll see something like this: GNOME Software (the new one) looks like: If this is a fresh installation of Ubuntu 16.04, there should be no way you have the old Software Center. ...


0

As first open a terminal (ctrl+alt+t) and check if there is a file called virtualbox.desktop in /usr/share/applications. You can do that by: ls -l /usr/share/applications/virtualbox.desktop which should give you the following output: -rw-r--r-- 1 root root 861 Apr 28 16:07 /usr/share/applications/virtualbox.desktop If you got the prompted result on ...


0

Take a look at Iris, I use it for this purpose and it's quite cool


0

Yes, you'll be able to install/remove snaps via Ubuntu Software. That work is in progress, and doesn't seem to have been released to Xenial just yet. I don't know if Ubuntu Software will indicate if it's a snap or a deb, though.


0

It is a known bug for the moment, the cpu also runs at 100% with this bug. A quick fix is, open the program named software & updates uncheck unsupported updates(xenial-backports). This fixes the problem for now.


0

If you haven't already, reinstall it with sudo apt remove <package forgot its name> then sudo apt install package.


0

You can still install software-center (Ubuntu Software Center) which is not discontinued yet, in fact it got an update in 16.04 release. You can also use synaptic(Synaptic Package Manger) for more advanced options. I use both depending on what i want to do, I removed gnome-software immediately after the update :P


2

You can use the Synaptic Package Manager for installing the missing/corrupted packages. Which can be installed from software center or can be installed by running the following commands in the terminal sudo apt-get update sudo apt-get install synaptic


0

Removing unused dependency packages solved this problem for me. To do this open a Terminal (using the Dash menu or CTRL+ALT+T and type or insert sudo apt autoremove and press Enter. You will be asked for your users password. You will not see anything while typing, this is normal and a security feature. Now, restart the software center and try to search ...


0

I'm having the similar problem. Can't also install steam from its website. They are both waiting on the task bar saying "waiting to install". I'm a newbie and really can use every suggestion.


0

sudo apt-get purge --auto-remove visual-studio-code This should remove the files (of visual-studio-code), its configuration files and the dependencies.


0

Please try to Download from here: https://launchpad.net/ubuntu/+archive/primary/+files/ubuntu-release-upgrader_0.220.1.tar.gz Unzip, open terminal and go to the directory location, Type: ./do-release-upgrade Done. Source: https://launchpad.net/ubuntu/+source/ubuntu-release-upgrader/1:0.220.1 ...


0

You are unable to boot off a USB to reinstall the operating system? The error message you are receiving is about the Message of the Day, which wouldn't affect the issue you are having at all. have you tried running the update through terminal? sudo apt-get update sudo apt-get upgrade


3

As we found out in our chat, the problem was due to 11 missing keys and 2 unwanted keys. Remove the unwanted keys (Chromium and Steam) with : sudo apt-key del B05498B7 4E5E17B5 Import the missing keys with : `sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys <all missing keys in the warning>` Update the repositories : sudo apt-get ...


0

sudo dpkg --remove visual-studio-code This will remove the software (including the Dash icon/desktop entry). I think that this method will leave the configuration information around (if you re-install); there's also a purge option on dpkg that will remove this information as well. sudo dpkg --purge visual-studio-code


0

I had similar problem.Then I got solution by installing the previous Ubuntu Software Center. Open terminal (Ctrl+Alt+T) then type following command and hit Enter. sudo apt install software-center After installation, search for Ubuntu Software Center in dashbox using Super key. You can now install apps with ease.


0

Yes there is a difference, in 16.04 LTS you will have the Gnome-Software-Center instead of the Ubuntu-Software-Center. As for adding repositories, this you always can do in System Settings --> Software & Updates --> Other Software


1

There is no uninstaller for MATLAB on UNIX or Linux. To remove MATLAB you simply need to delete the MATLAB installation following the instructions below: If you are running a license manager for MATLAB, shut down the license manager using the lmdown script located in MATLAB's etc directory. If this folder does not exist, you are not running the FlexNet ...


0

If you are looking for an alternate source of software not available in the official repos, you can try : http://www.getdeb.net/welcome/. For saving and restoring your ppas, you could try Aptik: http://www.teejeetech.in/2014/01/introducing-aptik.html


1

Ok, from the description and your added info, I think it is because you are trying Ubuntu(live USB), so not all software repos are enabled. By default, live session only select main and restricted software as below pic: The software you wanted - clementine or synaptic are both in "Community-maintained free and open-source software". So you can enter in ...


0

Have you tipped the check box to download updates during install? If not try to make an update. sudo apt-get update sudo apt-get upgrade But normaly it should be installed, except the case of a beta build


0

Well that was easy.... Solved via reboot. What is this, Windows? :)


0

There is another app ubuntu-software! But, if you still want to use old software center, then install it! sudo apt-get install software-center


0

I've got same failure with my upgrade to 16.04 LTS. I've tried several way like : sudo apt-get install -f but some packages remain not installed. I've repaired my upgrade by reinstalling all packages. You must exclude the libgtk-3-* packages from the install process, because they have dependencie failures. sudo apt-get --reinstall install $(dpkg-query ...


0

This is not specifically a bug in ubuntu its an APT thing . Its just very unfortunate timing for the 16.04 release that the SHA1 has is being retired. SHA1 is used by the APT system extensively to checksum packages , its being deprecated in favour of SHA256 or SHA512 which is safer. If you notice a package is not working then please contact the repo ...


1

You are supposed to select the All window, and use the search feature to find the program(s) you consider to install. https://help.ubuntu.com/stable/ubuntu-help/addremove-install.html


0

If you echo $HADOOP_HOME you'll find that you made a typo in the path. This will output $/home/hdp/hadoop-2.6.4/ which is nor a directory nor a file and bash was smart enough to answer. To fix it just type this it Terminal HADOOP_HOME=/home/hdp/hadoop-2.6.4/ export HADOOP_HOME


0

Here's a work-around until the package is fixed: TMP=`mktemp -d` cd $TMP grep Url: /usr/share/package-data-downloads/ttf-mscorefonts-installer | awk '{print $2}' | xargs -n 1 wget sudo /usr/lib/msttcorefonts/update-ms-fonts $TMP/* cd - rm -rf $TMP Note that this does skip the hash sum check, but they're just fonts, It's not like someone's going ...


0

All sorted. Turns out that some of the files in the default python package were missing. I used the following: sudo apt-get -m --reinstall install python python-minimal dh-python sudo apt-get -f install


0

If the method above doesn't work you can try this: First, open the terminal and type this: ps aux | grep apt You will get a result in a table form, we are interested in the apt requests that contain the words http or software in them. Once you find it, look at the second column. For example this is how it might look like: username 2514 0.0 0.0 ...


0

By the time this question was answered, things have evolved. By now, you can simply go to Download Opera browser, then click the button above Opera for Windows, Mac or Linux and the website will detect your operating system and processor architecture (32 or 64 bits) using device fingerprinting and prompt you a .deb package to download and install by a ...


1

This is a bug in the new software app. Try using the terminal to install your application with sudo dpkg -i new_app.deb. If you see messages about missing dependencies, than also enter the command sudo apt-get install -f


0

I too got this error. I did $ ps -aux | grep gnome-software and found that there was already a process running. (I believe this may be because I had tried to invoke it from the launcher and it had failed, but that much is a hunch.) I killed the process. I then ran gnome-software again in the terminal and got: (gnome-software:6912): Gs-WARNING **: ...


1

I suggest you to take a look at Take A Break. sudo add-apt-repository ppa:vlijm/takeabreak sudo apt-get update sudo apt-get install takeabreak


2

imagemagick may be a dependency for other pieces of software run apt-cache showpkg imagemagick to see what packages depend on imagemagick to run However if you want to force a removal, this may cause unintended consequences! run sudo dpkg --purge --force-all imagemagick


2

You can do this in a terminal window sudo apt remove --purge imagemagick But doing it you will remove also other software that you may need, like parts of the printing system. My recomendation? don't remove image magic


1

When installing from a .deb file, dependencies do not get automatically installed as well, as would be the case if Hamachi were a complete package. However, it is easy to install the dependency yourself in this case. Open a terminal and do sudo apt-get install lsb-core Then retry installing from the .deb file.


0

Try installing the old software-center from the commandline: sudo apt install software-center Or try installing synaptic sudo apt install synaptic


5

Remove the old version after upgrade When you upgrade from previous Ubuntu versions, the "old" Software-center is not removed it seems. Since it is replaced by the new Software-center, you can remove it by running the command: sudo apt-get remove software-center This will not remove the new software-center, since it has a different package name. If the ...


5

Just had this problem after using bleachbit to cleanup the system on moving from the beta to the official release. Cleaning out all the cache data also blanked out the software center (re:user533424 above). It seems to "magically" reappear by anything that regenerates this data. So... settings>region languages> ... and changing or reinstalling your ...


0

Yes, it seems to be a language configuration issue. Ridiculously impossible out-of-the-box glitch, yet there it is in an LTS release. :\ Even if your system is in English already, re-select it in System Settings > Language Support, re-apply system-wide, and reboot. Now the new app store actually functions.


0

Cancellation isn't supported now. It's a pending feature request on GNOME's bug tracker (with nothing related on Launchpad). There's no opposition to it (but then again, there's not much activity at all related to that request). Even if it does get implemented in a later version, I'm not sure the feature will be backported to Ubuntu 16.04. Consider filing ...


2

It works for me. Change Language Support > Regional Formats to English(United States), then reboot your computer. Software center works properly now.


0

go to ubuntu software center and search for "gdebi" or you can do sudo apt-get install gdebi after installing it, find the .deb package you wish to install, right click it, choose properties, and find the tab that says something like "open with" after finding it, choose gdbi and select "set as default". you may then close the menus and double click the .deb ...


11

If you want to install programs via .deb files, I suggest to use Gdebi. It's a lightweight application that is better at installing .deb packages, and is quicker as well. If there are dependencies, it notifies that as well. In the terminal, type: sudo apt install gdebi You can right click on .deb file and select to open it with Gdebi. If you like Gdeb, ...


0

I had the same problem after a fresh install and it started working after I killed the process in System Monitor.


2

Install .deb packages from the terminal: $ sudo dpkg -i <path/to/deb.deb> $ sudo apt-get install -f Credit: Mohit Rajan's comment



Top 50 recent answers are included