Tag Info

New answers tagged

0

this question was solved here: http://unix.stackexchange.com/q/1974 you just need to add that command like echo -e "\a" to execution of power button event. it uses "beep" package, so you should install it before sudo apt-get install beep


0

You can use Polkit rules to control the GUI shutdown privileges (the shutdown command isn't affected, and needs root as usual). A set of rules like in this answer should do. Create a .pkla file in /etc/polkit-1/localauthority/50-local.d/ (say 00-disable-shutdown.pkla): [Disable Shutdown, etc. for all users] Identity=unix-user:* ...


-1

You didn't include much about your problem and given that you claim not to be very good with Linux, I would recommend the following: Create an Ubuntu live USB using another computer with Windows or Ubuntu. Use it to backup all your data. Unplug your new USB mouse and connect your laptop to internet with an ethernet cable. Open a console and type the ...


0

Modified @redanimalwar script to warn user and give a chance to cancel the shutdown. For tests, it is usung 3 seconds and a chero message. Please adjust for your tastes. HTH. #!/bin/bash #https://askubuntu.com/questions/442795/ #http://ubuntuforums.org/showthread.php?t=2172828 function showProgress(){ # # Force Zenity Status message box to always be on ...


0

Just to report back. I noticed these errors on the console when the system hangs: Failed to start Load Kernel Modules. I updated my kernel to 4.0, which didn't seem to work, and now I can't even boot from the 4.0 kernel. So I switched back to boot from 3.19, removed the problematic 4.0 kernel, and everything starts to work again. I suspect the ...


0

After a quick web search, and a little inventiveness, here's what I came up with. #! /bin/bash read -p "Do you want to shutdown (Y/N)" yn case $yn in [Yy]* ) sleep 30 && sudo shutdown now;; [Nn]* ) exit;; * ) echo "Please answer Y or N.";; esac When I ran it, it quit back to command prompt when I selected N, and went to ...


3

GShutdown is a utility which allows you to schedule the shutdown or restart of your computer. With it you can simply and quickly choose the turn off time at either a specific time or after a countdown. Install Gshutdown: sudo apt-get install gshutdown source.


0

You may need ACPI support for your laptop. Run the following commands to install: sudo apt-get update sudo apt-get install acpi-support acpid acpi acpitool libacpi0 A reboot may also be necessary. As you can see in this loosly related example, typically, when ACPI is disabled, the computer will halt but will not shut down when ACPI support is needed.


1

sudo shutdown now Will bring the system down into single user mode, according to the man page. sudo shutdown -P now Is the more correct command, the -P option makes it power off after bringing the system down.


2

Try to type : sudo shutdown -h now The -h option is for halt which means to stop. For more info : 5 Linux commands to shutdown and reboot the system


0

Did you try these for reinstalling desktop and unity ? sudo apt-get update sudo apt-get install --reinstall ubuntu-desktop sudo apt-get install --reinstall unity


0

As a test to see if it is a configuration problem or a kernel problem, boot from the Ubuntu Live CD. If you can shut down from there, you are fine. Then just reinstall. If it freezes again, then maybe it requires a kernel update to 4.1 (because they may have fixed it). WARNING! THIS KERNEL MAY BE OUTDATED! GO TO kernel.org TO SEE THE LATEST VERSION! If that ...


0

I can offer no guarantees on this, but you might look into the reboot= kernel option. As documented in the kernel source tree's Documentation/kernel-parameters.txt file: reboot= [KNL] Format (x86 or x86_64): [w[arm] | c[old] | h[ard] | s[oft] | g[pio]] \ [[,]s[mp]#### \ ...


0

The command used for shutdown uses dbus. Indeed the shutdown command is: dbus-send --system --print-reply --dest=org.freedesktop.login1 /org/freedesktop/login1 "org.freedesktop.login1.Manager.PowerOff" boolean:true Indeed the systemd-logind service is responsible for user losings. In addition to what @thomasrutter said, Indeed the systemd-logind ...


3

Things like this are controlled by Polkit (its official name, but still often referred to by its former name PolicyKit). This tool facilitates non-root users being able to perform certain actions to the system that would otherwise require root, and shutting down is one of the actions it is usually configured to grant to regular users. How it works is the ...


0

Follow these steps: Open a file /etc/default/grub (as root), using this command: $ sudo gedit /etc/default/grub And, edit this file Change the line with: GRUB_CMDLINE_LINUX="" to: GRUB_CMDLINE_LINUX="acpi_sleep=nonvs" Run update-grub (as root) $ sudo update-grub Now, check is it works on not. If above solution not works, then try this also but ...


0

You can also open a terminal and do the following sudo apt-get update sudo apt-get upgrade sudo apt-get install bleachbit sudo bleachbit It will open a program that removes a lot of clutter, old kernels and it will give you a performance boost. Also a reboot every now and then is not bad :)


1

You probably don't need to restart to clear the ram and swap, as you can clear both without restarting: Clearing Swap: You can turn swap off and on again to clear it (make you have enough spare memory using free -m, top or similar) using sudo swapoff -a && sudo swapon -a. If stuff is moved to swap when you have enough free memory, and you don't ...


3

Some applications, when working for days can "grow up" in memory because there might be memory leaks (memory is reserved and not returned when not needed). When you have less memory (because of memory leaks) system moves information from memory to disk (swap partitions) more often, and this is probably the reason of slowing down you experience.


0

Downloaded drivers from Mactel support, now able to boot in EFI mode and shutdown works properly.


0

Restart then F2 Go to configuration and disable xHCI Save and exit Don't think about it just trust me and do it :)


0

Very interestingly, it has been solved. The only thing I`ve done was restarting my router. ( Using dual boot for Windows8.1 and wifi there was just working ) . Then I restarted and logged into my Ubuntu installation. And it suddenly worked.


2

My best guess based on the info provided is a buggy UEFI BIOS. digging through the kernel bugs for Haswell I found a possible workaround. Try using xhci_hcd.quirks=262144 as a boot option or Disabling xhci in the UEFI. The only other options I can think of are as follows: A) Wait and hope that either the kernel development team or Lenovo comes up with an ...


1

Figured it out!!!!!! After flashing a new bios, partitioning and repartitioning, changing NTFS and FAT file systems and learning a crap load about BIOS, I just needed to clean the fan. It was registering 118c! The Fan......


0

Disabling the wake on via LAN option is working well with my case. Machine: HP Elitebook 850 G2 O/S: Ubuntu 14.04


9

Here's a script to emulate the desired behavior. Must be ran as with sudo. Can be bound to a keyboard shortcut ( with preliminary addition of the shutdown command to sudoers file to allow passwordless run ). Simplistic, concise, and does the job. #!/bin/bash # Date: June 11,2015 # Author: Serg Kolo # Description: a script to emulate # behavior of GNOME ...


6

Not literally what you asked for, but at least an (effectively) comparable solution would be to put the script below under a shortcut key. What it does When the shortcut key is used: the gnome-session-quit --power-off command is run the mouse is moved to the corresponding "close" button, effectively making the shutdown button pre- selected: Then: ...


0

Your hardware might not support software shutdown. I've had that happen before, and the way to test is this: sudo poweroff If that does not shutdown the hardware, it's a hardware issue and not software.


0

From your Kernel Logs (Screenshot) I have a hunch that unattended-upgrades might be the cause of your issue. There have been several bug reports on this years ago, but they have not been resolved. A temporary fix to this would be to disable automatic updates by updates, but we will keep it as a last resort. But first of all, we will try a manual upgrade: ...



Top 50 recent answers are included