Tag Info

New answers tagged

0

It does not sound like you want to use a full-blown Ubuntu with the Unity desktop environment for this. Generally speaking, there are many window managers that allow more precise control of input. In case you are new to Linux and graphical environments: There are three aspects of how linux renders nice, high-resolution output - the X-Server, responsible for ...


0

The Ubuntu desktop is actually compiz and Unity itself is just a compiz plugin. If you, instead, set and enable the compiz "commands" plugin and set keyboard shortcuts using ccsm where there is a conflict, ccsm should alert you to what plugin is causing the conflict and should also provide options to disable the conflicting plugin or conflicting keybinding ...


0

I'll add the following ones about changing area: Change from tree view (1) to breadcrumb bar (2) Tab Change from breadcrumb bar (2) to file view (3) Tab Change from directory file view (3) to tree view (1) Tab In other words: Tab makes you change area clockwise: 1 --> 2 --> 3 --> 1 Shift + Tab makes you change area counterclockwise: 1 --> 3 --> 2 --> ...


0

If your GUI ubuntu desktop is not freezed, open a terminal by Ctrl+Alt+T shortcut and do the following: To shutdown now : sudo shutdown -P now To restart now : sudo shutdown -P -r now To shutdown after (say) 20 minutes : sudo shutdown -P 20 Similarly, for restart also replace now by 20. (To stop timed execution: Say after 15 minutes you decide ...


0

I tried a few things, but it's not easy. What you'd need would be two different commands, one for zooming into a split, and a different one for zooming out. You can add this to your local ~/.byobu/.tmux.conf and then use Shift-F11 to zoom in, and Alt-F11 to zoom out: bind-key -n S-F11 resize-pane -Z \; unbind-key -n S-Up \; unbind-key -n S-Down \; ...


0

isearch-repeat-forward is bound to C-s on the Isearch mode. You may notice that when you press C-s you enter a new minor mode in your buffer. Since each mode has its own keybinding map, you should alter C-s binding on this map. The define-key function receives an argument which is the mode map you want to bind the key, in that case isearch-mode. Try put this ...


0

Ubuntu 14.04 has a screenshot section now. Doesn't answer your question, but it's a simple alternative.


0

I propose that this should be achievable via the unity dash by typing the super-key then "reboot" (without quotes): https://bugs.launchpad.net/ubuntu/+source/unity/+bug/1403293


2

There are several ways to go about this. Here are three options I can suggest you to try. It really depends on how you prefer to go about it for your system. System Settings - Option 1 Change what key calls your HUD or completely disable it like so: System settings… 1. -> Keyboard 2. -> Shortcuts tab 3. -> Launchers Assign a new key to ...


0

To show all: gsettings list-recursively | grep --ignore-case "keys\|hotkey\|keybind" To get: gsettings get org.gnome.settings-daemon.plugins.media-keys calculator To set: gsettings set org.gnome.settings-daemon.plugins.media-keys calculator 'Hiragana' For more info: man gsettings To easily get the values for "special" keys (multimedia, non-standard ...


0

The solution was to skip the script, and set the keyboard switch shortcut with setxkbmap. I now run this in my login script: # Keyboard layout switcher setxkbmap -layout us,se -variant ,kinesis -option 'grp:alt_shift_toggle' , which does exactly what I wanted.


0

what I understand that you have to change Fn-F9 from toggling airplane mode to toggling wireless ,, I suggest that 1) Disable Fn-F9 from toggling airplane: open dconf-editor (install it if not) and search for WLAN (press ctrl + f and type WLAN) then it's up to you to change the binding if you find it 2) Bind Fn-F9 to toggling wireless as in my other ...


0

in ubuntu 14.04 it's alt + ctrl + s to change it goto System Settings> keyboard > shortcuts window from the left menu press windows search for toggle visibility and assign a new shortcut


0

In addition to Matt's answer, it should also be noted that the Fn and Ctrl key usage can be swapped in BIOS (see image below). This may have been set if the Fn key doesn't seem to behave as you may expect. It may also be very useful to know, as at least personally having Ctrl nearest the edge is more practical than having the Fn key there.


1

1) create a file called wifi.sh 2) copy these lines #!/bin/sh if [ $(nmcli nm wifi | awk '/led/ {print}') = 'enabled' ] ; then nmcli nm wifi off echo 'wifi off' else nmcli nm wifi on notify-send -i network-wireless-none "Wireless" "Wireless enabled" echo 'wifi on' fi 3) make it executable 4) remember its full path so if you ...


0

I think the best way to do it is to create a context menu entry similar to "Open in Terminal..." for directories in nautilus. I do not know how to map nautilus menu entries to a key (You can activate the entry with multiple keys using the context menu by keyboard, like with Menu). But as you seem to already solved the key mapping part, maybe some hints on ...


0

Remember that terminal is VERY literal! The + key Ubuntu terminal wants is on top row and requires Shift otherwise it's =.


0

I couldn't find the answer to my question (which would be convenient), but instead coded up a Python GUI with a slider. I made two versions, one with wxPython and one with Tk. https://gist.github.com/nmz787/ff7ae7b64d59070390ea


0

I figured that answers (currently all other answers) that suggest pactl set-sink-volume 0 ... don't work (or stop working) on systems with more than one audio devices, e.g. as soon as you connect to a hdmi monitor. we should use @DEFAULT_SINK@ instead of 0 to refer to active audio device. so here is my setup on ubuntu 14.04 with gnome 3.10 and should work ...


1

You are out of luck: GtkSettings:gtk-keynav-wrap-around has been deprecated since version 3.10 and should not be used in newly-written code. This setting is ignored. While gnome-terminal in Ubuntu is only 3.6.2, libgtk-3-0 is 3.10.8.


3

There are two circumstances that make your situation a bit different from the supposed duplicate(s): Some process seems to wake your screen up, if your screen wakes up after the xset dpms force off command, it must be. My screen doesn't for example. If you don't want your screen to wake up, just with any key press, the xset dpms force off command is not ...


-1

Okay so after spending literally hours trying to find an answer I managed to find an application to fix it and allow me to switch and all is good now...


0

With the CompizConfig Settings Manager, you can enable the Super + D shortcut to show desktop without having that annoying icon in the launcher. Just open CompizConfig and go to Desktop >> Ubuntu Unity Plugin >> General and change the show desktop shortcut.


0

Ok I can disconnect by using CTRL_R + F4 however I cannot get T for show/hide toolbar to work no matter what I key combo I use with it. I've renamed the .remmina folder and and restarted remmina and recreated one of my connections and I get the same issue so I guess it's a bug (as they still have the reference to the toolbar in shortcuts so doesn't look ...


-1

ctrl+shift+u+2000, and ctrl+shift+u+2006 respectively


2

I am just answering 2nd part of your question, because 1st part is not possible using just ls command. to list only hidden files and only hidden directories sorted in alphanumerically manner. folders will come in alphabetically order(along with files), not before files ls -a1d .* -a gives you all file/directory hidden or not -1 gives you one result per ...


1

No there isn't any, but it's a good idea! You can always try to get an additional sort option defined by e-mailing the address at the end of ls --help You can even write the code yoursef and e-mail them the code! (that will get their attention more then just an email)


0

This seems to be a bug in unity-settings-daemon. I have filed it with them: https://bugs.launchpad.net/ubuntu/+source/unity-settings-daemon/+bug/1399132 As a workaround you can edit the settings manually with dconf Editor. To install it run sudo apt-get install dconf-tools. You can find your custom shortcut under ...


1

You need to create .desktop file for your program (eclipse.desktop in your case). Then put it to /usr/share/applications directory or ~/.local/share/applications if you want it to be accessible for one user only. It is easier to create the file on the desktop first and test it before copying to its destined directory. Basic stucture of a .desktop file is ...


0

After reading it here http://choorucode.com/2013/01/21/byobu-function-keys-do-not-work-in-putty/ I changed the session so that "Terminal → Keyboard" has the option "Xterm R6" selected.


1

I have the same issue. I installed the 4.4.1 deb package for ubuntu 14.10 from the Texmaker website which resolved the issue for me (http://www.xm1math.net/texmaker/download.html#linux)


0

Here I found solution, which works for me. Type in console ibus-setup, and then make sure, that you have following settings: To avoid different problems with switching beetwen Polish and English, I removed English from list. Proof: u mnie działa świetnie :)


0

On my Asus k55v, brightness & rfkill (wifi on/off) where not working when I install Debian. As *buntu derives from Debian, you can try adding "acpi_osi='!Windows 2012'" to your kernel command line modifying the file /etc/default/grub at line GRUB_CMD_LINE_DEFAULT=. It should see like GRUB_CMDLINE_LINUX_DEFAULT="acpi_osi='!Windows 2012'" Then execute, ...


2

You can setup your own keybindings using an init.el file inside your .emacs.d. Just copy and paste the following code in your startup script: (define-key global-map [?\s-x] 'kill-region) (define-key global-map [?\s-c] 'kill-ring-save) (define-key global-map [?\s-v] 'yank) If you don't know the names of the commands executed by a key sequence, you can ...


-1

Some keyboards have a button for this, look around on your keyboard and see if you can find a key looking like the marked one below


1

I've had the same problem as you had except I installed the whole Gnome desktop package. To solve this problem I log of the Gnome Shell then log in the Unity and set (re set) hotkey to change keyboard layout in Unity. Check if it work there and then go back to the Gnome Shell. It works for me. My answer is probably irrelevant for you now but I hope it'll ...


3

If you need such characters frequently, one-shot solutions like composing or going through code points don't really cut it. I would suggest you give one of the "international" US key layouts a try. I'm German, but prefer (*) US keyboards with the "English (US) English (international AltGr dead keys)" key layout -- at least that's what Mint (an Ubuntu ...


2

If you need "Æ" because you actually write in Norwegian sometimes the most simple would be to activate the Norwegian keyboard layout in Ubuntu's OS settings so that you have two available keyboards layouts, English and Norwegian (f. ex.) and you can quickly switch between them. You can probably also set a keyboard shortcut for swithcing between the keyboard ...


0

I like Put to next Output with Ctrl + Alt + n enjoy it! Put at CCSM. Put to Next Output


0

The solution is one line: xmodmap -e "keycode 115 = Pointer_Button2" so now my Home key is doing left click and behave just as if I hit the mouse click and I can keep the key pressed and it highlights (copy) as expected. I also mapped my End key to be middle click, so I can use it to paste: xmodmap -e "keycode 110 = Pointer_Button1"


2

When one needs some specific unicode char one can open KCharSelect and guess it's name there: one then can copy-paste that in any application.


1

There’s another method: typing using the Meta key In this case, it’s Meta-f because the ASCII code (and Unicode) of f is 66hex, and the Unicode of æ is U+00E6, and 66hex + 80hex = E6hex. You will need to either use xterm with Meta key configured correctly, or a BSD with wscons(4) text console (not FreeBSD, which has a different one), or a custom keyboard ...


0

I have same problem. Solved executing from command line the following after login: $ setxkbmap -option "grp:caps_toggle,grp_led:scroll,compose:ralt" -layout es (in this sample i set the ayout to my natural language es ) I set this command as a default stating application when gnome starts. Hope this helps


16

Whatever you have set as the compose key then a then e in sequence will produce æ This solution is much simpler, as you don't have to know the unicode for the character you wish to type. For example compose key then o then e will produce œ. compose key then c then , (comma) will produce ç and so on.


21

Typing unicode is slightly different in Ubuntu. The key combination is: Ctrl+Shift+U+code+Space However, Windows uses decimal notation while Ubuntu uses Hex notation. Æ in this case (what 0198 is) is c6 for Ubuntu. So, you'd do: Press Ctrl+Shift+U. Release it. Type c6 (or 00c6) Press Space If you were talking about æ (or 145 on Windows), replace all ...


4

From this Ubuntu Forums post: Press CtrlShiftu and the Unicode number of the character. In this case, æ is 00e6 (or simply e6). e6 is 230 in decimal, so presumably you were talking about the capital letter (Æ), which is c6 (198).


0

Install Compiz With Extras sudo apt-get install compizconfig-settings-manager compiz-plugins-extra -y Then open CompizConfig and go to Ubuntu Unity Plugin > General > Key to show the menu bar while pressed, and change it.


0

Install CompizConfig Settings Manager via Ubuntu Software Center or terminal: sudo apt-get install compizconfig-settings-manager. Then open CompizConfig and go to Ubuntu Unity Plugin > General > Key to show the menu bar while pressed, and change it. Hope this will help you.


0

Most desktops have some accessibility settings that will control the mouse with the keyboard already built-in, like XFCE has them in it's All Settings -> Accessibility -> Mouse -> Mouse Emulation, that uses the keyboard number pad so the 5 key does exactly what you're trying to do. If I recall, gnome, cinnamon and mate have similar features under something ...


0

What version of gnome-shell are you using? gnome-shell --version Upgrading to version 3.12 has solved the problem for others - sudo add-apt-repository ppa:gnome3-team/gnome3-staging sudo apt-get update sudo apt-get dist-upgrade sudo apt-get install gnome-shell ubuntu-gnome-desktop In case it doesn't work, you can go back to version 3.10 - sudo ...



Top 50 recent answers are included